summaryrefslogtreecommitdiff
path: root/media-sound/audacity/audacity-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-16 05:29:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-16 05:29:50 +0000
commitf174ed40d3cca6ab6b3bb718e8b5fccca6b04b3f (patch)
treed5b82bd892cb75d60b0adf4c44305caa9f3fce7a /media-sound/audacity/audacity-9999.ebuild
parent02f2811de683662c5c6f5f120de6b59898ed6b98 (diff)
gentoo auto-resync : 16:01:2024 - 05:29:50
Diffstat (limited to 'media-sound/audacity/audacity-9999.ebuild')
-rw-r--r--media-sound/audacity/audacity-9999.ebuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/media-sound/audacity/audacity-9999.ebuild b/media-sound/audacity/audacity-9999.ebuild
index ad59e3249ef7..b8d173af117a 100644
--- a/media-sound/audacity/audacity-9999.ebuild
+++ b/media-sound/audacity/audacity-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
WX_GTK_VER="3.2-gtk3"
-inherit cmake wxwidgets xdg
+inherit cmake wxwidgets xdg virtualx
DESCRIPTION="Free crossplatform audio editor"
HOMEPAGE="https://www.audacityteam.org/"
@@ -37,10 +37,9 @@ LICENSE="GPL-2+
"
SLOT="0"
IUSE="alsa audiocom ffmpeg +flac id3tag +ladspa +lv2 mpg123 ogg
- opus +portmixer sbsms twolame vamp +vorbis wavpack"
-
-# The testsuite consists of two tests, 50% of which fail.
-RESTRICT="test"
+ opus +portmixer sbsms test twolame vamp +vorbis wavpack"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( mpg123 )"
# dev-db/sqlite:3 hard dependency.
# dev-libs/glib:2, x11-libs/gtk+:3 hard dependency, from
@@ -67,6 +66,7 @@ RESTRICT="test"
RDEPEND="dev-db/sqlite:3
dev-libs/expat
dev-libs/glib:2
+ dev-libs/rapidjson
media-libs/libsndfile
media-libs/libsoundtouch:=
media-libs/portaudio[alsa?]
@@ -103,7 +103,8 @@ RDEPEND="dev-db/sqlite:3
vorbis? ( media-libs/libvorbis )
wavpack? ( media-sound/wavpack )
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/catch:0 )"
BDEPEND="app-arch/unzip
sys-devel/gettext
virtual/pkgconfig
@@ -120,13 +121,16 @@ PATCHES=(
# For has_networking
"${FILESDIR}/${PN}-3.3.3-local-threadpool-libraries.patch"
+
+ # Allows running tests without conan
+ "${FILESDIR}/${PN}-3.3.3-remove-conan-test-dependency.patch"
)
src_prepare() {
cmake_src_prepare
- local header_subs="${S}/lib-src/header-substitutes"
- cat <<-EOF >"${header_subs}/allegro.h" || die
+ local header_subs="${S}/libraries/lib-note-track"
+ cat <<-EOF >"${header_subs}/WrapAllegro.h" || die
/* Hack the allegro.h header substitute to use system headers. */
#include <portsmf/allegro.h>
EOF
@@ -199,11 +203,17 @@ src_configure() {
## Keep watch of PA_HAS_OSS in lib-src/portmixer/CMakeLists.txt;
## AFAICT it introduces no deps as-is, but that could change.
## Similar goes for PA_HAS_JACK.
+
+ -Daudacity_has_tests=$(usex test ON OFF)
)
cmake_src_configure
}
+src_test() {
+ virtx cmake_src_test
+}
+
src_install() {
cmake_src_install