summaryrefslogtreecommitdiff
path: root/media-sound/audacity/audacity-2.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /media-sound/audacity/audacity-2.2.2.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'media-sound/audacity/audacity-2.2.2.ebuild')
-rw-r--r--media-sound/audacity/audacity-2.2.2.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/media-sound/audacity/audacity-2.2.2.ebuild b/media-sound/audacity/audacity-2.2.2.ebuild
index 5c71e713a5d4..7f0a6fabb20a 100644
--- a/media-sound/audacity/audacity-2.2.2.ebuild
+++ b/media-sound/audacity/audacity-2.2.2.ebuild
@@ -1,22 +1,24 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils gnome2-utils wxwidgets xdg-utils
+EAPI=6
+
+inherit autotools gnome2-utils wxwidgets xdg-utils
MY_P="${PN}-minsrc-${PV}"
DOC_PV="${PV}"
DESCRIPTION="Free crossplatform audio editor"
-HOMEPAGE="http://web.audacityteam.org/"
+HOMEPAGE="https://web.audacityteam.org/"
SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${MY_P}.tar.xz
doc? ( https://dev.gentoo.org/~polynomial-c/dist/${PN}-manual-${DOC_PV}.zip )"
# wget doesn't seem to work on FossHub links, so we mirror
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ~mips ~ppc ~ppc64 x86"
IUSE="alsa cpu_flags_x86_sse doc ffmpeg +flac id3tag jack +ladspa +lame libav
+lv2 mad +midi nls +portmixer sbsms +soundtouch twolame vamp +vorbis +vst"
+
RESTRICT="test"
RDEPEND=">=app-arch/zip-2.3
@@ -26,8 +28,10 @@ RDEPEND=">=app-arch/zip-2.3
media-libs/soxr
x11-libs/wxGTK:3.0[X]
alsa? ( media-libs/alsa-lib )
- ffmpeg? ( libav? ( media-video/libav:= )
- !libav? ( >=media-video/ffmpeg-1.2:= ) )
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( >=media-video/ffmpeg-1.2:= )
+ )
flac? ( >=media-libs/flac-1.3.1[cxx] )
id3tag? ( media-libs/libid3tag )
jack? ( virtual/jack )
@@ -41,7 +45,6 @@ RDEPEND=">=app-arch/zip-2.3
vamp? ( >=media-libs/vamp-plugin-sdk-2.0 )
vorbis? ( >=media-libs/libvorbis-1.0 )"
DEPEND="${RDEPEND}
- app-arch/xz-utils
virtual/pkgconfig
nls? ( sys-devel/gettext )"
@@ -56,8 +59,7 @@ PATCHES=(
)
src_prepare() {
- epatch "${PATCHES[@]}"
-
+ default
# needed because of portmixer patch
eautoreconf
}
@@ -108,7 +110,7 @@ src_install() {
rm -r "${D%/}"/usr/share/doc || die
# Install our docs
- dodoc README.txt
+ einstalldocs
if use doc ; then
docinto html