summaryrefslogtreecommitdiff
path: root/media-sound/aucatctl/aucatctl-0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /media-sound/aucatctl/aucatctl-0.1.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'media-sound/aucatctl/aucatctl-0.1.ebuild')
-rw-r--r--media-sound/aucatctl/aucatctl-0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/aucatctl/aucatctl-0.1.ebuild b/media-sound/aucatctl/aucatctl-0.1.ebuild
new file mode 100644
index 000000000000..a04a482f9d15
--- /dev/null
+++ b/media-sound/aucatctl/aucatctl-0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool for controlling aucat and/or sndiod volume through MIDI"
+HOMEPAGE="http://www.sndio.org/"
+SRC_URI="http://www.sndio.org/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/libbsd
+ media-sound/sndio:=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's?/usr/local?/usr?g' \
+ -e 's?man/man1?share/man/man1?g' \
+ -e 's?LDADD = -lsndio?LDADD = -lbsd -lsndio?' \
+ Makefile || die "Failed modifying Makefile"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}