summaryrefslogtreecommitdiff
path: root/media-sound/asunder/asunder-2.9.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-30 17:40:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-30 17:40:25 +0100
commit3c78a1ce7924fbf571e133e697f8a29e18d2bf4b (patch)
tree5bbedb5d3c2716d5b332f7e74f54941c9a2b50b8 /media-sound/asunder/asunder-2.9.7-r1.ebuild
parentc417025a2ab386cddabb71ad598a9b75b47af313 (diff)
gentoo auto-resync : 30:09:2023 - 17:40:25
Diffstat (limited to 'media-sound/asunder/asunder-2.9.7-r1.ebuild')
-rw-r--r--media-sound/asunder/asunder-2.9.7-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/asunder/asunder-2.9.7-r1.ebuild b/media-sound/asunder/asunder-2.9.7-r1.ebuild
new file mode 100644
index 000000000000..f55896226042
--- /dev/null
+++ b/media-sound/asunder/asunder-2.9.7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="Graphical Audio CD ripper and encoder with support for many output formats"
+HOMEPAGE="http://littlesvr.ca/asunder/"
+SRC_URI="http://littlesvr.ca/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="flac mac mp3 musepack opus vorbis wavpack"
+
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+DEPEND="media-libs/libcddb
+ media-sound/cdparanoia
+ x11-libs/gtk+:2"
+# dlopen() deps
+RDEPEND="${DEPEND}
+ flac? ( media-libs/flac )
+ mac? ( <=media-sound/mac-4.12 )
+ mp3? ( media-sound/lame )
+ musepack? ( media-sound/musepack-tools )
+ opus? ( media-sound/opus-tools )
+ vorbis? ( media-sound/vorbis-tools )
+ wavpack? ( media-sound/wavpack )"
+
+src_prepare() {
+ default
+ sed -i -e 's:cd syslogng && $(MAKE) install:true:' Makefile.in || die
+}