summaryrefslogtreecommitdiff
path: root/media-sound/asunder/asunder-2.9.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /media-sound/asunder/asunder-2.9.5.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'media-sound/asunder/asunder-2.9.5.ebuild')
-rw-r--r--media-sound/asunder/asunder-2.9.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/asunder/asunder-2.9.5.ebuild b/media-sound/asunder/asunder-2.9.5.ebuild
new file mode 100644
index 000000000000..df537f03bf42
--- /dev/null
+++ b/media-sound/asunder/asunder-2.9.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="Graphical Audio CD ripper and encoder with support for many output formats"
+HOMEPAGE="http://littlesvr.ca/asunder/"
+SRC_URI="http://littlesvr.ca/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="flac mac mp3 musepack opus vorbis wavpack"
+
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+DEPEND=">=media-libs/libcddb-0.9.5
+ media-sound/cdparanoia
+ x11-libs/gtk+:2"
+RDEPEND="${DEPEND}
+ flac? ( media-libs/flac )
+ mac? ( media-sound/mac )
+ mp3? ( media-sound/lame )
+ musepack? ( media-sound/musepack-tools )
+ opus? ( media-sound/opus-tools )
+ vorbis? ( media-sound/vorbis-tools )
+ wavpack? ( media-sound/wavpack )"
+
+src_prepare() {
+ default
+ sed -i -e 's:cd syslogng && $(MAKE) install:true:' Makefile.in || die
+}