summaryrefslogtreecommitdiff
path: root/media-sound/ario
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/ario
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/ario')
-rw-r--r--media-sound/ario/Manifest6
-rw-r--r--media-sound/ario/ario-1.5.1-r1.ebuild68
-rw-r--r--media-sound/ario/files/ario-1.5.1-single-includes2.patch557
-rw-r--r--media-sound/ario/metadata.xml11
4 files changed, 642 insertions, 0 deletions
diff --git a/media-sound/ario/Manifest b/media-sound/ario/Manifest
new file mode 100644
index 000000000000..6ec48c16e98f
--- /dev/null
+++ b/media-sound/ario/Manifest
@@ -0,0 +1,6 @@
+AUX ario-1.5.1-single-includes2.patch 16062 SHA256 5416d83482a3ae6682eaabf8acbd125e176a3d44fb23b1859a741afba3da9d97 SHA512 f832498f2445f2f937a1b9636ba6c75fce3a75e706296a315e0c33c3a852140ba829f6972d8cc2ade3fa4a45f21a964eef8134b315fdfe1155cd221e9ee0cbb2 WHIRLPOOL 6ca5474ee8cb3f2e7d291902c0ceec9f76f4de8e25fa3a41dab6dca718d7e210a17fd9715f33364114c218c02a0b655f2852f7b167eb55ea16c7a06e9aaabdcf
+DIST ario-1.5.1.tar.gz 1135444 SHA256 0831281ab8634eb92424b61230eee035822f7f92d8b0526da7316c898239c91e SHA512 78c3d881d51c3109b73252da0742da2a77bcc24ec21ff2ff02fd3527d62d49a75e412bf092051a9035863d645cba73e6cd2fc674d97629909b931ae9d3ec002b WHIRLPOOL 3f280635019dca6dfff5e5681bb38a559986475b31c9c03831ae7e9893af18c03ee8fd3cfd1524a9756b80543bbde01ec3de1a7a4f223e5aeca4e6e8462fe87a
+EBUILD ario-1.5.1-r1.ebuild 1559 SHA256 06d087c4439af501395cf9c7bec3832dd740fe56e8da9a2ab0b719de29538fdc SHA512 8f401913bd6930d2f1979055bbe05f0612b3061bcafe601652399e0b1d4d6644b679db4feb9ad21e2fd211187e860ad1a5a346eb25c3e0e130e8fd9063815275 WHIRLPOOL 05416cb130d2f26e2881144542ed2effe41262d63614d8f9a5d9f951cdf478638033304aec5b200ff01219667b1ff81f27d60d7ad2bc18975b46cc17a395724a
+MISC ChangeLog 2813 SHA256 c4db7df6bdb341e9e00694065471ef8419542537f47ec98d937dcbf25377bee9 SHA512 aaa06080785e590f177352146f25974433589ba0cf95e3ad46914395ede1602b5bfc1b412973f4067dbb5842efd4aa6650be6cc929b35f33252382515f087b90 WHIRLPOOL 1573f0beeea44363dabfdbc33fcc8da58ae96062d99cefc443e885d378773cab146cfffc96ce93a3e2f6a72c25082c5d6a947ac3c752e1e14437c607f1a7e86b
+MISC ChangeLog-2015 4286 SHA256 ede8213bfb30dd168ca14a2cc690b7d703189689b4aef6cd9397c760a8a4a3ad SHA512 128e882b2b03b7ef695a37706729b216923549c7c6567baa27766298235fa2d4c80765ffc8cddf1f520806db385bd735bec8d7a218b90cb5a55d6d735c8029e0 WHIRLPOOL 325957735147c9c7782f7f5663f76a0cbcc9190acc47d136dc1fa6c9204756d71c0947d3b1039c9f97507a82da0c8a7654c1a4ade9ba738be8fcd2dc3f733a51
+MISC metadata.xml 436 SHA256 35813a6688a19e745cc7397da701f85953cf96ca6417d496480bb556ed6c0ebc SHA512 25031895d05402f35f2979f8bce734142d539b21ce602c17ee21bb3b49b9d3e097f948020b9a104c314f16dd22fc0436cc8ac65a927eb76442f66907311ad7bd WHIRLPOOL 1176a8758f3d494cd050b86eb124a6a0f316697bd2db2b6ac1efe79a311059d4bebff757e692886256267f3a83b2c4769549e86d58f60c11cbe914f4bf6c8554
diff --git a/media-sound/ario/ario-1.5.1-r1.ebuild b/media-sound/ario/ario-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..403cf04a8be5
--- /dev/null
+++ b/media-sound/ario/ario-1.5.1-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+GNOME2_LA_PUNT=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools gnome2 python-any-r1
+
+DESCRIPTION="a GTK2 MPD (Music Player Daemon) client inspired by Rythmbox"
+HOMEPAGE="http://ario-player.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}-player/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="audioscrobbler dbus debug +idle libnotify nls python taglib zeroconf"
+
+RDEPEND=">=dev-libs/glib-2.14:2
+ dev-libs/libgcrypt:0=
+ dev-libs/libunique:1
+ dev-libs/libxml2:2
+ media-libs/libmpdclient
+ net-misc/curl
+ net-libs/gnutls
+ >=x11-libs/gtk+-2.16:2
+ audioscrobbler? ( net-libs/libsoup:2.4 )
+ dbus? ( dev-libs/dbus-glib )
+ libnotify? ( x11-libs/libnotify )
+ python? ( dev-python/pygtk:2
+ dev-python/pygobject:2 )
+ taglib? ( media-libs/taglib )
+ zeroconf? ( net-dns/avahi )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( AUTHORS )
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-single-includes2.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-xmms2 \
+ --enable-libmpdclient2 \
+ --enable-search \
+ --enable-playlists \
+ --disable-deprecations \
+ $(use_enable audioscrobbler) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable idle mpdidle) \
+ $(use_enable libnotify notify) \
+ $(use_enable nls) \
+ $(use_enable python) \
+ $(use_enable taglib) \
+ $(use_enable zeroconf avahi)
+}
diff --git a/media-sound/ario/files/ario-1.5.1-single-includes2.patch b/media-sound/ario/files/ario-1.5.1-single-includes2.patch
new file mode 100644
index 000000000000..e5936cfbe2c1
--- /dev/null
+++ b/media-sound/ario/files/ario-1.5.1-single-includes2.patch
@@ -0,0 +1,557 @@
+Index: plugins/radios/ario-radio.h
+===================================================================
+--- plugins/radios/ario-radio.h (revision 772)
++++ plugins/radios/ario-radio.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_RADIO_H
+ #define __ARIO_RADIO_H
+
+-#include <gtk/gtkhbox.h>
++#include <gtk/gtk.h>
+ #include <config.h>
+ #include "widgets/ario-playlist.h"
+ #include "sources/ario-source.h"
+Index: plugins/filesystem/ario-filesystem.h
+===================================================================
+--- plugins/filesystem/ario-filesystem.h (revision 772)
++++ plugins/filesystem/ario-filesystem.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_FILESYSTEM_H
+ #define __ARIO_FILESYSTEM_H
+
+-#include <gtk/gtkhpaned.h>
++#include <gtk/gtk.h>
+ #include <config.h>
+ #include "widgets/ario-playlist.h"
+ #include "sources/ario-source.h"
+Index: plugins/information/ario-information.h
+===================================================================
+--- plugins/information/ario-information.h (revision 772)
++++ plugins/information/ario-information.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_INFORMATION_H
+ #define __ARIO_INFORMATION_H
+
+-#include <gtk/gtkhbox.h>
++#include <gtk/gtk.h>
+ #include <config.h>
+ #include "sources/ario-source.h"
+
+Index: src/plugins/ario-plugin-info.c
+===================================================================
+--- src/plugins/ario-plugin-info.c (revision 772)
++++ src/plugins/ario-plugin-info.c (revision 774)
+@@ -27,7 +27,7 @@
+
+ #include <string.h>
+ #include <glib/gi18n.h>
+-#include <glib/gkeyfile.h>
++#include <glib.h>
+
+ #include "plugins/ario-plugin-info-priv.h"
+ #include "ario-debug.h"
+Index: src/sources/ario-search.h
+===================================================================
+--- src/sources/ario-search.h (revision 772)
++++ src/sources/ario-search.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_SEARCH_H
+ #define __ARIO_SEARCH_H
+
+-#include <gtk/gtkhbox.h>
++#include <gtk/gtk.h>
+ #include <config.h>
+ #include "sources/ario-source.h"
+
+Index: src/sources/ario-storedplaylists.h
+===================================================================
+--- src/sources/ario-storedplaylists.h (revision 772)
++++ src/sources/ario-storedplaylists.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_STOREDPLAYLISTS_H
+ #define __ARIO_STOREDPLAYLISTS_H
+
+-#include <gtk/gtkhpaned.h>
++#include <gtk/gtk.h>
+ #include <config.h>
+ #include "sources/ario-source.h"
+
+Index: src/sources/ario-source-manager.h
+===================================================================
+--- src/sources/ario-source-manager.h (revision 772)
++++ src/sources/ario-source-manager.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_SOURCE_MANAGER_H
+ #define __ARIO_SOURCE_MANAGER_H
+
+-#include <gtk/gtknotebook.h>
++#include <gtk/gtk.h>
+ #include "sources/ario-source.h"
+
+ G_BEGIN_DECLS
+Index: src/sources/ario-browser.h
+===================================================================
+--- src/sources/ario-browser.h (revision 772)
++++ src/sources/ario-browser.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_BROWSER_H
+ #define __ARIO_BROWSER_H
+
+-#include <gtk/gtkhbox.h>
++#include <gtk/gtk.h>
+ #include "sources/ario-source.h"
+
+ #define MAX_TREE_NB 5
+Index: src/sources/ario-tree.h
+===================================================================
+--- src/sources/ario-tree.h (revision 772)
++++ src/sources/ario-tree.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_TREE_H
+ #define __ARIO_TREE_H
+
+-#include <gtk/gtkhbox.h>
++#include <gtk/gtk.h>
+ #include "servers/ario-server.h"
+ #include "sources/ario-source.h"
+ #include "shell/ario-shell-coverdownloader.h"
+Index: src/ario-util.h
+===================================================================
+--- src/ario-util.h (revision 772)
++++ src/ario-util.h (revision 774)
+@@ -18,8 +18,8 @@
+ */
+
+ #include "servers/ario-server.h"
+-#include "glib/gslist.h"
+-#include "gdk/gdkpixbuf.h"
++#include <glib.h>
++#include <gdk/gdk.h>
+
+ /* Number of covers used to generate the drag & drop image */
+ #define MAX_COVERS_IN_DRAG 3
+Index: src/ario-main.c
+===================================================================
+--- src/ario-main.c (revision 772)
++++ src/ario-main.c (revision 774)
+@@ -21,7 +21,7 @@
+ #include <locale.h>
+ #include <libintl.h>
+ #include <gtk/gtk.h>
+-#include <gdk/gdkkeysyms.h>
++#include <gdk/gdk.h>
+ #include <curl/curl.h>
+ #include <libxml/parser.h>
+ #include <glib/gi18n.h>
+Index: src/ario-profiles.h
+===================================================================
+--- src/ario-profiles.h (revision 772)
++++ src/ario-profiles.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_PROFILES_H
+ #define __ARIO_PROFILES_H
+
+-#include <glib/gslist.h>
++#include <glib.h>
+ #include "servers/ario-server.h"
+
+ G_BEGIN_DECLS
+Index: src/covers/ario-cover-handler.h
+===================================================================
+--- src/covers/ario-cover-handler.h (revision 772)
++++ src/covers/ario-cover-handler.h (revision 774)
+@@ -17,7 +17,7 @@
+ *
+ */
+
+-#include <gtk/gtkdialog.h>
++#include <gtk/gtk.h>
+
+ #ifndef __ARIO_COVER_HANDLER_H
+ #define __ARIO_COVER_HANDLER_H
+Index: src/covers/ario-cover.c
+===================================================================
+--- src/covers/ario-cover.c (revision 772)
++++ src/covers/ario-cover.c (revision 774)
+@@ -19,8 +19,7 @@
+
+ #include "covers/ario-cover.h"
+ #include <glib.h>
+-#include <gtk/gtkdialog.h>
+-#include <gtk/gtkmessagedialog.h>
++#include <gtk/gtk.h>
+ #include <string.h>
+ #include <glib/gi18n.h>
+ #include "ario-util.h"
+Index: src/preferences/ario-others-preferences.h
+===================================================================
+--- src/preferences/ario-others-preferences.h (revision 772)
++++ src/preferences/ario-others-preferences.h (revision 774)
+@@ -21,7 +21,7 @@
+ #define __ARIO_OTHERS_PREFERENCES_H
+
+ #include <glib.h>
+-#include <gtk/gtkvbox.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/preferences/ario-lyrics-preferences.h
+===================================================================
+--- src/preferences/ario-lyrics-preferences.h (revision 772)
++++ src/preferences/ario-lyrics-preferences.h (revision 774)
+@@ -21,7 +21,7 @@
+ #define __ARIO_LYRICS_PREFERENCES_H
+
+ #include <glib.h>
+-#include <gtk/gtkvbox.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/preferences/ario-server-preferences.h
+===================================================================
+--- src/preferences/ario-server-preferences.h (revision 772)
++++ src/preferences/ario-server-preferences.h (revision 774)
+@@ -21,7 +21,7 @@
+ #define __ARIO_SERVER_PREFERENCES_H
+
+ #include <glib.h>
+-#include <gtk/gtkvbox.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/preferences/ario-cover-preferences.h
+===================================================================
+--- src/preferences/ario-cover-preferences.h (revision 772)
++++ src/preferences/ario-cover-preferences.h (revision 774)
+@@ -21,7 +21,7 @@
+ #define __ARIO_COVER_PREFERENCES_H
+
+ #include <glib.h>
+-#include <gtk/gtkvbox.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/preferences/ario-browser-preferences.h
+===================================================================
+--- src/preferences/ario-browser-preferences.h (revision 772)
++++ src/preferences/ario-browser-preferences.h (revision 774)
+@@ -17,7 +17,7 @@
+ *
+ */
+
+-#include <gtk/gtkdialog.h>
++#include <gtk/gtk.h>
+
+ #ifndef __ARIO_BROWSER_PREFERENCES_H
+ #define __ARIO_BROWSER_PREFERENCES_H
+Index: src/preferences/ario-taskbar-preferences.h
+===================================================================
+--- src/preferences/ario-taskbar-preferences.h (revision 772)
++++ src/preferences/ario-taskbar-preferences.h (revision 774)
+@@ -21,7 +21,7 @@
+ #define __ARIO_TASKBAR_PREFERENCES_H
+
+ #include <glib.h>
+-#include <gtk/gtkvbox.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/preferences/ario-stats-preferences.h
+===================================================================
+--- src/preferences/ario-stats-preferences.h (revision 772)
++++ src/preferences/ario-stats-preferences.h (revision 774)
+@@ -21,7 +21,7 @@
+ #define __ARIO_STATS_PREFERENCES_H
+
+ #include <glib.h>
+-#include <gtk/gtkvbox.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/preferences/ario-connection-preferences.h
+===================================================================
+--- src/preferences/ario-connection-preferences.h (revision 772)
++++ src/preferences/ario-connection-preferences.h (revision 774)
+@@ -21,7 +21,7 @@
+ #define __ARIO_CONNECTION_PREFERENCES_H
+
+ #include <glib.h>
+-#include <gtk/gtkvbox.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/preferences/ario-playlist-preferences.h
+===================================================================
+--- src/preferences/ario-playlist-preferences.h (revision 772)
++++ src/preferences/ario-playlist-preferences.h (revision 774)
+@@ -21,7 +21,7 @@
+ #define __ARIO_PLAYLIST_PREFERENCES_H
+
+ #include <glib.h>
+-#include <gtk/gtkvbox.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/lib/gtk-builder-helpers.h
+===================================================================
+--- src/lib/gtk-builder-helpers.h (revision 772)
++++ src/lib/gtk-builder-helpers.h (revision 774)
+@@ -17,7 +17,7 @@
+ *
+ */
+
+-#include <gtk/gtkbuilder.h>
++#include <gtk/gtk.h>
+
+ #ifndef __GTK_BUILDER_HELPERS_H
+ #define __GTK_BUILDER_HELPERS_H
+Index: src/widgets/ario-dnd-tree.h
+===================================================================
+--- src/widgets/ario-dnd-tree.h (revision 772)
++++ src/widgets/ario-dnd-tree.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_DND_TREE_H
+ #define __ARIO_DND_TREE_H
+
+-#include <gtk/gtktreeview.h>
++#include <gtk/gtk.h>
+ #include <config.h>
+
+ G_BEGIN_DECLS
+Index: src/widgets/ario-songlist.h
+===================================================================
+--- src/widgets/ario-songlist.h (revision 772)
++++ src/widgets/ario-songlist.h (revision 774)
+@@ -21,10 +21,7 @@
+ #define __ARIO_SONGLIST_H
+
+ #include <glib.h>
+-#include <gtk/gtkscrolledwindow.h>
+-#include <gtk/gtkliststore.h>
+-#include <gtk/gtktreeview.h>
+-#include <gtk/gtkuimanager.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/widgets/ario-tray-icon.h
+===================================================================
+--- src/widgets/ario-tray-icon.h (revision 772)
++++ src/widgets/ario-tray-icon.h (revision 774)
+@@ -26,8 +26,7 @@
+
+ #include <config.h>
+ #include "shell/ario-shell.h"
+-#include <gtk/gtkuimanager.h>
+-#include <gtk/gtkstatusicon.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/widgets/ario-volume.h
+===================================================================
+--- src/widgets/ario-volume.h (revision 772)
++++ src/widgets/ario-volume.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_VOLUME_H
+ #define __ARIO_VOLUME_H
+
+-#include <gtk/gtkeventbox.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/widgets/ario-connection-widget.h
+===================================================================
+--- src/widgets/ario-connection-widget.h (revision 772)
++++ src/widgets/ario-connection-widget.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_CONNECTION_WIDGET_H
+ #define __ARIO_CONNECTION_WIDGET_H
+
+-#include <gtk/gtkvbox.h>
++#include <gtk/gtk.h>
+
+ #define ARIO_DEFAULT_TIMEOUT 5000
+
+Index: src/widgets/ario-firstlaunch.h
+===================================================================
+--- src/widgets/ario-firstlaunch.h (revision 772)
++++ src/widgets/ario-firstlaunch.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_FIRSTLAUNCH_H
+ #define __ARIO_FIRSTLAUNCH_H
+
+-#include <gtk/gtkassistant.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/widgets/ario-header.h
+===================================================================
+--- src/widgets/ario-header.h (revision 772)
++++ src/widgets/ario-header.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_HEADER_H
+ #define __ARIO_HEADER_H
+
+-#include <gtk/gtkhbox.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/widgets/ario-lyrics-editor.h
+===================================================================
+--- src/widgets/ario-lyrics-editor.h (revision 772)
++++ src/widgets/ario-lyrics-editor.h (revision 774)
+@@ -17,7 +17,7 @@
+ *
+ */
+
+-#include <gtk/gtkvbox.h>
++#include <gtk/gtk.h>
+ #include "lyrics/ario-lyrics-provider.h"
+
+ #ifndef __ARIO_LYRICS_EDITOR_H
+Index: src/widgets/ario-tooltip.h
+===================================================================
+--- src/widgets/ario-tooltip.h (revision 772)
++++ src/widgets/ario-tooltip.h (revision 774)
+@@ -21,7 +21,7 @@
+ #define __ARIO_TOOLTIP_H
+
+ #include <config.h>
+-#include <gtk/gtkhbox.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/shell/ario-shell-coverdownloader.h
+===================================================================
+--- src/shell/ario-shell-coverdownloader.h (revision 772)
++++ src/shell/ario-shell-coverdownloader.h (revision 774)
+@@ -21,7 +21,7 @@
+ #define __ARIO_SHELL_COVERDOWNLOADER_H
+
+ #include <glib.h>
+-#include <gtk/gtkwindow.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/shell/ario-shell-preferences.h
+===================================================================
+--- src/shell/ario-shell-preferences.h (revision 772)
++++ src/shell/ario-shell-preferences.h (revision 774)
+@@ -17,7 +17,7 @@
+ *
+ */
+
+-#include <gtk/gtkdialog.h>
++#include <gtk/gtk.h>
+
+ #ifndef __ARIO_SHELL_PREFERENCES_H
+ #define __ARIO_SHELL_PREFERENCES_H
+Index: src/shell/ario-shell.h
+===================================================================
+--- src/shell/ario-shell.h (revision 772)
++++ src/shell/ario-shell.h (revision 774)
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_SHELL_H
+ #define __ARIO_SHELL_H
+
+-#include <gtk/gtkwindow.h>
++#include <gtk/gtk.h>
+
+ G_BEGIN_DECLS
+
+Index: src/shell/ario-shell-lyrics.h
+===================================================================
+--- src/shell/ario-shell-lyrics.h (revision 772)
++++ src/shell/ario-shell-lyrics.h (revision 774)
+@@ -17,7 +17,7 @@
+ *
+ */
+
+-#include <gtk/gtkwindow.h>
++#include <gtk/gtk.h>
+
+ #ifndef __ARIO_SHELL_LYRICS_H
+ #define __ARIO_SHELL_LYRICS_H
+Index: src/shell/ario-shell-lyricsselect.h
+===================================================================
+--- src/shell/ario-shell-lyricsselect.h (revision 772)
++++ src/shell/ario-shell-lyricsselect.h (revision 774)
+@@ -22,7 +22,7 @@
+ #define __ARIO_SHELL_LYRICSSELECT_H
+
+ #include <glib.h>
+-#include <gtk/gtkdialog.h>
++#include <gtk/gtk.h>
+ #include "lyrics/ario-lyrics.h"
+
+ G_BEGIN_DECLS
+Index: src/shell/ario-shell-songinfos.h
+===================================================================
+--- src/shell/ario-shell-songinfos.h (revision 772)
++++ src/shell/ario-shell-songinfos.h (revision 774)
+@@ -17,7 +17,7 @@
+ *
+ */
+
+-#include <gtk/gtkdialog.h>
++#include <gtk/gtk.h>
+
+ #ifndef __ARIO_SHELL_SONGINFOS_H
+ #define __ARIO_SHELL_SONGINFOS_H
+Index: src/shell/ario-shell-similarartists.h
+===================================================================
+--- src/shell/ario-shell-similarartists.h (revision 772)
++++ src/shell/ario-shell-similarartists.h (revision 774)
+@@ -17,7 +17,7 @@
+ *
+ */
+
+-#include <gtk/gtkwindow.h>
++#include <gtk/gtk.h>
+
+ #ifndef __ARIO_SHELL_SIMILARARTISTS_H
+ #define __ARIO_SHELL_SIMILARARTISTS_H
+Index: src/shell/ario-shell-coverselect.h
+===================================================================
+--- src/shell/ario-shell-coverselect.h (revision 772)
++++ src/shell/ario-shell-coverselect.h (revision 774)
+@@ -22,7 +22,7 @@
+ #define __ARIO_SHELL_COVERSELECT_H
+
+ #include <glib.h>
+-#include <gtk/gtkdialog.h>
++#include <gtk/gtk.h>
+ #include "servers/ario-server.h"
+
+ G_BEGIN_DECLS
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 772)
++++ configure.ac (revision 774)
+@@ -298,9 +298,11 @@
+ if test x"$enable_deprecations" = xyes; then
+ WARNINGS="$WARNINGS -DG_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
++-DGTK_DISABLE_SINGLE_INCLUDES \
+ -DGDK_PIXBUF_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
+--DGSEAL_ENABLE"
++-DGSEAL_ENABLE \
++-DG_DISABLE_SINGLE_INCLUDES"
+ fi
+ AC_SUBST(WARNINGS)
+
diff --git a/media-sound/ario/metadata.xml b/media-sound/ario/metadata.xml
new file mode 100644
index 000000000000..6e2b5222d277
--- /dev/null
+++ b/media-sound/ario/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="audioscrobbler">Enable song tracking via last.fm</flag>
+ <flag name="idle">Enable experimental support for MPD's idle command to reduce bandwidth and cpu usage, requires MPD 0.14</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">ario-player</remote-id>
+ </upstream>
+</pkgmetadata>