summaryrefslogtreecommitdiff
path: root/media-sound/ardour
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-21 11:40:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-21 11:40:26 +0000
commiteb3b53b5fd521edc0e4a7d611e76898732a63a81 (patch)
tree217af8e0b11da87c65601aa317f04b7a2de76d23 /media-sound/ardour
parentb08574f4102ea8282627f075758d981eb4ba6c56 (diff)
gentoo auto-resync : 21:02:2024 - 11:40:26
Diffstat (limited to 'media-sound/ardour')
-rw-r--r--media-sound/ardour/Manifest2
-rw-r--r--media-sound/ardour/ardour-8.4.ebuild193
2 files changed, 195 insertions, 0 deletions
diff --git a/media-sound/ardour/Manifest b/media-sound/ardour/Manifest
index 643f66541101..23785e59cc71 100644
--- a/media-sound/ardour/Manifest
+++ b/media-sound/ardour/Manifest
@@ -1,5 +1,7 @@
AUX ardour-6.8-metadata.patch 568 BLAKE2B 68bb84e5249d67e88e191dbc009b7f2b696d448903a2c7164778f4fda3b526370bd2562fa627faea832da2c115d61fe8ddccf6c54c016a7f68e5cab688868984 SHA512 1bf77b0cf2692e7051a524a049add8f22feb734120d9ae58ffcf06647e8ed28249dcbe2cd124eb2354897f119a2977c6124228fc37c15e476053dc5ea4b5033c
DIST Ardour-8.2.0.tar.bz2 13897958 BLAKE2B 54916b2f0ac3925f160df9536db61b1ece4ace3f9f4a09880c00661e328835a32c04a8faa2b04bb3fe34aeeb97064e0139f4e19524be1a17f33d7e773b893e1b SHA512 62962929201c649a0028c2cfc1e7e6acce3ab9ee24adbc5ebb5a7c3d70f73430c579801788f696769afd2d14d766eb2ef4936b5957dce2288a30cf671ca62ee1
+DIST Ardour-8.4.0.tar.bz2 17574218 BLAKE2B a71be1af5577cf3cbded339c2cb25f3124f973bf8966bd663b1c53cdea51e069a61217e844b2ecbf329ddbc54c61e4e4364fc70c9f90cf38871d0ff55e496846 SHA512 838eae28867f1bf108207d171ac60e50d4d7f467a3fd64f95e8c9585d1b2b02ded1af0405c0a363664f9ea3a007143e9ec4e54f36a7df5387b5e12549b804719
EBUILD ardour-8.2.ebuild 5095 BLAKE2B b3c2511ef4ab82e8308e809ade42a18337846feea96a357afb8f33d7e882e6e9a86f07b5055fab4be5b90cdefbdafbd5d3cf82c11f85070d429f72c7bfce1cfc SHA512 382a48d88c92defcc3ccd1e4db73922597e9089d8097ff76604d2be2dbef134b36cd90a1e53571ef10dda81f5d6b30526544df1c18be3890a4addd621a89e49d
+EBUILD ardour-8.4.ebuild 5096 BLAKE2B 66fe45f3b1596ff658d0c524819b8f9d05fdf034ba480b302e72af1dab386c7c4e1a19b547d5c7200f5d05645423cf5c7b47f5760de575a37366d2048643ad1e SHA512 63913a84412cf0d986cd5f2d74ab4a5fe4a7471a25c9fcbf19ef32984fceda4db51403f8b59f195b0ad666904d159c82adddf0e405f225442e653f33267b6210
EBUILD ardour-9999.ebuild 5096 BLAKE2B 66fe45f3b1596ff658d0c524819b8f9d05fdf034ba480b302e72af1dab386c7c4e1a19b547d5c7200f5d05645423cf5c7b47f5760de575a37366d2048643ad1e SHA512 63913a84412cf0d986cd5f2d74ab4a5fe4a7471a25c9fcbf19ef32984fceda4db51403f8b59f195b0ad666904d159c82adddf0e405f225442e653f33267b6210
MISC metadata.xml 451 BLAKE2B 0ed571ca79f0d4b92239239982f04abf725365df169290e4a02f6d8f580cf801f70d8bc93414b4549c8172ff43864d5c49fa987caeec58e1b2331ffe01a69ae6 SHA512 504bd817356c7ee57c64193584b3fc5b3bc70f5224d5a531ac5ecf8fb974728639e75b77bb9e7c5ad77cf6099123361b9ec6211b855edb4761acd95b8cb7abcb
diff --git a/media-sound/ardour/ardour-8.4.ebuild b/media-sound/ardour/ardour-8.4.ebuild
new file mode 100644
index 000000000000..4f99e58488e4
--- /dev/null
+++ b/media-sound/ardour/ardour-8.4.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE='threads(+)'
+PLOCALES="ca cs de el en_GB es eu fr it ja ko nn pl pt pt_PT ru sv zh"
+inherit toolchain-funcs flag-o-matic plocale python-any-r1 waf-utils desktop xdg
+
+DESCRIPTION="Digital Audio Workstation"
+HOMEPAGE="https://ardour.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.ardour.org/ardour/ardour.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~loong ~x86"
+ SRC_URI="https://dev.gentoo.org/~fordfrog/distfiles/Ardour-${PV}.0.tar.bz2"
+ S="${WORKDIR}/Ardour-${PV}.0"
+fi
+
+LICENSE="GPL-2"
+SLOT="8"
+IUSE="doc jack nls phonehome pulseaudio cpu_flags_ppc_altivec cpu_flags_x86_sse cpu_flags_x86_mmx cpu_flags_x86_3dnow"
+
+RDEPEND="
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/boost:=
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ dev-libs/libxml2:2
+ media-libs/alsa-lib
+ media-libs/aubio
+ media-libs/flac:=
+ media-libs/freetype:2
+ media-libs/liblo
+ media-libs/liblrdf
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ media-libs/libsoundtouch
+ media-libs/raptor:2
+ media-libs/rubberband
+ media-libs/taglib
+ media-libs/vamp-plugin-sdk
+ net-libs/libwebsockets
+ net-misc/curl
+ sys-libs/readline:0=
+ sci-libs/fftw:3.0[threads]
+ virtual/libusb:1
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/pango
+ jack? ( virtual/jack )
+ pulseaudio? ( media-libs/libpulse )
+ media-libs/lilv
+ media-libs/sratom
+ dev-libs/sord
+ media-libs/suil[X,gtk2]
+ media-libs/lv2"
+# !bundled-libs? ( media-sound/fluidsynth ) at least libltc is missing to be able to unbundle...
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( app-text/doxygen[dot] )
+ jack? ( virtual/jack )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-6.8-metadata.patch"
+)
+
+pkg_pretend() {
+ [[ $(tc-getLD) == *gold* ]] && (has_version sci-libs/fftw[openmp] || has_version sci-libs/fftw[threads]) && \
+ ewarn "Linking with gold linker might produce broken executable, see bug #733972"
+}
+
+pkg_setup() {
+ if has_version \>=dev-libs/libsigc++-2.6 ; then
+ append-cxxflags -std=c++11
+ fi
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # delete optimization flags
+ sed 's/'full-optimization\'\ :\ \\[.*'/'full-optimization\'\ :\ \'\','/' -i "${S}"/wscript || die
+
+ # handle arch
+ MARCH=$(get-flag march)
+ OPTFLAGS=""
+ if use cpu_flags_x86_sse; then
+ if [[ ${MARCH} == "i686" ]] || [[ ${MARCH} == "i486" ]]; then
+ elog "You enabled sse but use an march that does not support sse!"
+ elog "We add -msse to the flags now, but please consider switching your march in make.conf!"
+ fi
+ OPTFLAGS="sse"
+ fi
+ if use cpu_flags_x86_mmx; then
+ if [[ ${MARCH} == "i486" ]]; then
+ elog "You enabled mmx with i486 set as march! You have been warned!"
+ fi
+ OPTFLAGS="${OPTFLAGS} mmx"
+ fi
+ if use cpu_flags_x86_3dnow; then
+ OPTFLAGS="${OPTFLAGS} 3dnow"
+ fi
+ sed 's/flag_line\ =\ o.*/flag_line\ =\ \": '"${OPTFLAGS}"' just some place holders\"/' \
+ -i "${S}"/wscript || die
+ sed 's/cpu\ ==\ .*/cpu\ ==\ "LeaveMarchAsIs":/' -i "${S}"/wscript || die
+
+ # boost and shebang
+ append-flags "-lboost_system"
+ python_fix_shebang "${S}"/wscript
+ python_fix_shebang "${S}"/waf
+
+ # handle locales
+ my_lcmsg() {
+ rm -f {gtk2_ardour,gtk2_ardour/appdata,libs/ardour,libs/gtkmm2ext}/po/${1}.po
+ }
+ plocale_for_each_disabled_locale my_lcmsg
+}
+
+src_configure() {
+ # avoid bug https://bugs.gentoo.org/800067
+ local -x AS="$(tc-getCC) -c"
+
+ local backends="alsa,dummy"
+ use jack && backends+=",jack"
+ use pulseaudio && backends+=",pulseaudio"
+
+ tc-export CC CXX
+ local myconf=(
+ --configdir=/etc
+ --freedesktop
+ --noconfirm
+ --optimize
+ --with-backends=${backends}
+ $({ use cpu_flags_ppc_altivec || use cpu_flags_x86_sse; } && \
+ echo '' || echo "--no-fpu-optimization")
+ $(usex doc "--docs" '')
+ $(usex nls '' "--no-nls")
+ $(usex phonehome '' "--no-phone-home")
+ # not possible right now --use-external-libs
+ # missing dependency: https://github.com/c4dm/qm-dsp
+ )
+
+ waf-utils_src_configure "${myconf[@]}"
+}
+
+src_compile() {
+ waf-utils_src_compile
+ use nls && waf-utils_src_compile i18n
+}
+
+src_install() {
+ local s
+
+ waf-utils_src_install
+
+ mv ${PN}.1 ${PN}${SLOT}.1 || die
+ doman ${PN}${SLOT}.1
+
+ for s in 16 22 32 48 256 512; do
+ newicon -s ${s} gtk2_ardour/resources/Ardour-icon_${s}px.png ardour${SLOT}.png
+ done
+
+ # the build system still installs ardour6.png files so we get rid of those to not conflict with ardour:6
+ find "${D}/usr/share/icons/" -name ardour6.png -delete
+
+ sed -i \
+ -e "s/\(^Name=\).*/\1Ardour ${SLOT}/" \
+ -e 's/;AudioEditing;/;X-AudioEditing;/' \
+ build/gtk2_ardour/ardour${SLOT}.desktop || die
+ domenu build/gtk2_ardour/ardour${SLOT}.desktop
+
+ insinto /usr/share/mime/packages
+ newins build/gtk2_ardour/ardour.xml ardour${SLOT}.xml
+ rm "${D}/usr/share/mime/packages/ardour.xml" || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "Please do _not_ report problems with the package to ${PN} upstream."
+ elog "If you think you've found a bug, check the upstream binary package"
+ elog "before you report anything to upstream."
+}