summaryrefslogtreecommitdiff
path: root/media-sound/alsaplayer/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-10 13:27:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-10 13:27:24 +0100
commit0d7aefa5885e7552b4c2221df9f54e5930696228 (patch)
treeb7f05f240bfd3bc81f87edba206e78a8dc1a664b /media-sound/alsaplayer/files
parent34d9839f7e484ac761071da50298470aa5ef5123 (diff)
gentoo auto-resync : 10:07:2022 - 13:27:24
Diffstat (limited to 'media-sound/alsaplayer/files')
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.ebuild b/media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.ebuild
new file mode 100644
index 000000000000..b51277317e0f
--- /dev/null
+++ b/media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.ebuild
@@ -0,0 +1,37 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -82,11 +82,6 @@
+ dnl PKGCONFIG preparations
+ dnl ======================
+
+-if test -z $PKG_CONFIG_PATH; then
+- PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig
+-fi
+-
+-export PKG_CONFIG_PATH
+
+
+ dnl ===============
+@@ -639,10 +634,10 @@
+
+ AC_MSG_CHECKING(for gcc optimization flags)
+ old_cflags=$CFLAGS
+-CFLAGS="$CFLAGS -O2 -funroll-loops -finline-functions -ffast-math -Wall"
++CFLAGS="$CFLAGS -Wall"
+ AC_TRY_COMPILE([#include <stdio.h>],
+ [ printf ("hello, world"); ],
+-[ EXTRA_OPT_CFLAGS="$CFLAGS -O2 -funroll-loops -finline-functions -ffast-math -Wall"],[ EXTRA_OPT_CFLAGS=""])
++[ EXTRA_OPT_CFLAGS="$CFLAGS -Wall"],[ EXTRA_OPT_CFLAGS=""])
+ CFLAGS=$old_cflags
+ AC_MSG_RESULT([$EXTRA_OPT_CFLAGS])
+
+--- a/output/jack/Makefile.am
++++ b/output/jack/Makefile.am
+@@ -24,7 +24,6 @@
+
+ AM_CXXFLAGS = $(COMMON_FLAGS) $(JACK_CFLAGS)
+
+-AM_CFLAGS = $(AM_CXXFLAGS)
+
+ libdir = $(ADDON_DIR)/output
+