summaryrefslogtreecommitdiff
path: root/media-sound/alsa-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
commit1ffbeeb1643e9197d8a58c65a1d76bbaf3656292 (patch)
tree2cb5d912afaf290c355b58f8a7334b0e6c5277f0 /media-sound/alsa-utils
parent7819ef4baadbb9171070ce385f7051989fe64e49 (diff)
gentoo auto-resync : 23:12:2022 - 13:59:28
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/Manifest1
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.2.8-r1.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/media-sound/alsa-utils/Manifest b/media-sound/alsa-utils/Manifest
index ee5114d1660e..d47709dec168 100644
--- a/media-sound/alsa-utils/Manifest
+++ b/media-sound/alsa-utils/Manifest
@@ -5,5 +5,6 @@ AUX alsasound.initd-r8 2183 BLAKE2B 3c3e59847817e06e7847399fad02885fc493e2b51b76
DIST alsa-utils-1.2.7.tar.bz2 1562595 BLAKE2B dd8821c510a98d76e2986d59c01516013f01c632fb6311e6ffd2b10eabbdd68312537d977b1bf2ab48e0f181751ecf58ec1c1da3f8d4f7ee84d8f2623893a091 SHA512 1be8f617315193e6033653ac96a14bd1c3272cd9d8f3776cdb1357f35f5353652acd5975cfc5bd16278cd496f5bf409bb60432818a526282edad9a4c718a97c9
DIST alsa-utils-1.2.8.tar.bz2 1560162 BLAKE2B 4b9676957e775be51076b4798dfd384db4eea440c682899024034d3dd593ba24f1d42b8d742c312e041a37f0dbbc12b16635d79f6e6633a3459cc21f80739b5e SHA512 882e6f67467596ed273bf554fcce87d8ef287806bbdabd6c103de4980981f9e2102fb3800c6e8628ee8e86ffb165c1c92f9370c8145f28a6cb7cca563942330b
EBUILD alsa-utils-1.2.7-r1.ebuild 2513 BLAKE2B 1b6bcd11aa55710907940a1f28713bfe8ee2a871ead905858d1fae1069bbca4893a9bdcfaceddb1915fb8d80cf127eb45f02d9a55b25a9c7dfcb9b7b63105f36 SHA512 1fe83211234f6bbab673150b19775b9aa9d0fd2303b32240c698bdfbb9b8a6a0db8637093e2e29f302985326f147601b4b20406613cd4ffd3c4e655b8bbdc208
+EBUILD alsa-utils-1.2.8-r1.ebuild 2508 BLAKE2B 8133bcdb855be091b167125d55c350996fe2d07a3d3cf503da6005abe5ecc20de7b1d94017b4db8d97f7c24c6e0be671731f5c583328894b655d7e67e0cd8c41 SHA512 8c28e46fb314798294235817746d213f7c4323ceb4f3619d8b5c459819c81782c00001e439f56b5d2d395aa2c935415c576ea5323b56abb8aa52ad28a3a358c4
EBUILD alsa-utils-1.2.8.ebuild 2508 BLAKE2B 8133bcdb855be091b167125d55c350996fe2d07a3d3cf503da6005abe5ecc20de7b1d94017b4db8d97f7c24c6e0be671731f5c583328894b655d7e67e0cd8c41 SHA512 8c28e46fb314798294235817746d213f7c4323ceb4f3619d8b5c459819c81782c00001e439f56b5d2d395aa2c935415c576ea5323b56abb8aa52ad28a3a358c4
MISC metadata.xml 630 BLAKE2B 297896d48e1b947e3d8fdb0e8508846ac5f11740101a80d1d492e8fdd6bb042d629c654583d3262c00a0e33d31ecf3b6f4b3c07c73ede339b4ed168d4c5deae0 SHA512 1e26d146329b58c509ee8a9e6683bd0bc15651d942a7d400383106d3e61df0d3148322bedf0d10e445db74109ee1ee759310eb72c5e3fb1ae4ec258892d378b2
diff --git a/media-sound/alsa-utils/alsa-utils-1.2.8-r1.ebuild b/media-sound/alsa-utils/alsa-utils-1.2.8-r1.ebuild
new file mode 100644
index 000000000000..99651ae43b13
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.2.8-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd udev
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="https://alsa-project.org/wiki/Main_Page"
+SRC_URI="https://www.alsa-project.org/files/pub/utils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="bat doc +libsamplerate ieee1394 +ncurses nls selinux"
+
+DEPEND="
+ >=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ieee1394? ( media-libs/libffado )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7:= )
+ bat? ( sci-libs/fftw:= )
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-alsa )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.8-missing_header.patch
+)
+
+src_configure() {
+ export ac_cv_lib_ffado_ffado_streaming_init=$(usex ieee1394)
+
+ local myeconfargs=(
+ # --disable-alsaconf because it doesn't work with sys-apps/kmod wrt #456214
+ --disable-alsaconf
+ --disable-maintainer-mode
+ --with-asound-state-dir="${EPREFIX}"/var/lib/alsa
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-udev-rules-dir="${EPREFIX}/$(get_udevdir)"/rules.d
+ $(use_enable bat)
+ $(use_enable libsamplerate alsaloop)
+ $(use_enable ncurses alsamixer)
+ $(use_enable nls)
+ $(usex doc '' --disable-xmlto)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc seq/*/README.*
+
+ newinitd "${FILESDIR}"/alsasound.initd-r8 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf
+
+ keepdir /var/lib/alsa
+
+ # ALSA lib parser.c:1266:(uc_mgr_scan_master_configs) error: could not
+ # scan directory /usr/share/alsa/ucm: No such file or directory
+ # alsaucm: unable to obtain card list: No such file or directory
+ keepdir /usr/share/alsa/ucm
+}
+
+pkg_postinst() {
+ udev_reload
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog "# rc-update add alsasound boot"
+ ewarn
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+}