summaryrefslogtreecommitdiff
path: root/media-sound/alac_decoder/alac_decoder-0.2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /media-sound/alac_decoder/alac_decoder-0.2.0-r2.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'media-sound/alac_decoder/alac_decoder-0.2.0-r2.ebuild')
-rw-r--r--media-sound/alac_decoder/alac_decoder-0.2.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-sound/alac_decoder/alac_decoder-0.2.0-r2.ebuild b/media-sound/alac_decoder/alac_decoder-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..765e7d8aefb0
--- /dev/null
+++ b/media-sound/alac_decoder/alac_decoder-0.2.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Basic decoder for Apple Lossless Audio Codec files (ALAC)"
+HOMEPAGE="http://craz.net/programs/itunes/alac.html"
+SRC_URI="http://craz.net/programs/itunes/files/${P}.tgz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~ppc-macos ~x86-solaris"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2.0-fix-build-system.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin alac
+ einstalldocs
+}