summaryrefslogtreecommitdiff
path: root/media-sound/abcm2ps/abcm2ps-8.14.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /media-sound/abcm2ps/abcm2ps-8.14.4.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'media-sound/abcm2ps/abcm2ps-8.14.4.ebuild')
-rw-r--r--media-sound/abcm2ps/abcm2ps-8.14.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/abcm2ps/abcm2ps-8.14.4.ebuild b/media-sound/abcm2ps/abcm2ps-8.14.4.ebuild
new file mode 100644
index 000000000000..4b808b9d06d6
--- /dev/null
+++ b/media-sound/abcm2ps/abcm2ps-8.14.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Program to convert abc files to Postscript files"
+HOMEPAGE="https://github.com/leesavide/abcm2ps"
+SRC_URI="https://github.com/leesavide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples pango"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="pango? ( x11-libs/pango media-libs/freetype:2 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --enable-a4 \
+ --enable-deco-is-roll \
+ $(use_enable pango)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin abcm2ps
+
+ insinto /usr/share/${PN}
+ doins *.fmt
+
+ dodoc README.md
+
+ if use examples ; then
+ docinto examples
+ dodoc sample*.*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}