summaryrefslogtreecommitdiff
path: root/media-sound/a2jmidid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /media-sound/a2jmidid
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'media-sound/a2jmidid')
-rw-r--r--media-sound/a2jmidid/Manifest4
-rw-r--r--media-sound/a2jmidid/a2jmidid-9.ebuild21
-rw-r--r--media-sound/a2jmidid/a2jmidid-9999.ebuild21
3 files changed, 38 insertions, 8 deletions
diff --git a/media-sound/a2jmidid/Manifest b/media-sound/a2jmidid/Manifest
index 031766a2947e..ff683c1fb8a1 100644
--- a/media-sound/a2jmidid/Manifest
+++ b/media-sound/a2jmidid/Manifest
@@ -1,4 +1,4 @@
DIST a2jmidid-9.tar.gz 47925 BLAKE2B ad079e76a54f56ee8f82150c306f91aead52f86632978ea6f3376a0bf163744379210b34701b39da4ee14fc4d8a1c6be82d1052abeb8ccf79410bc242d174d62 SHA512 5bd13b6904ed68c5bfe40ca516fd49b7eb4d4a946b9908ee04687265848734c8e1a81579f0f1a5bd0752595be8858dc748da10487b7f366394c09a5ffc7d5e5c
-EBUILD a2jmidid-9.ebuild 726 BLAKE2B 8df6a6897e2e92626e2b23f9ae76012b4830857dbd48f2612acb90abbeb665cb0dc7ef5c8c8d02d7b3a602f732d94d3cca2a14028ab0453463037e87e1efd03b SHA512 3a27404d187163998bd58840ec30937054e912f0a02c5b512e704787fd30a7368d40ae00dac5a06182363d21e0943e3db74629bd8252962ec02b23c501109062
-EBUILD a2jmidid-9999.ebuild 696 BLAKE2B dd6e045e6c9e3de4077fc5b460d327b690e144e5d34690bccb8371b87ba82ae76cc5801eb9198e9881c3c1d6f3e1a640fc29f6755b029c503cdf21b955ae51c1 SHA512 3a8bb0cf20126b77dca5accc82540e43e5bc5e4a4c930e7b7efe48bba59b7cc92664ad468ceb3c8bf0afd0851098819da6c7ca6a6cdb8a813f3da7cc413fdc03
+EBUILD a2jmidid-9.ebuild 1030 BLAKE2B 19ef7a61136e4d6551e0eff8e9263529ca4d6428bafdda5e2dd8756fe3c08f278211ae5317ae85168fc848d427b8b53bf991139dd520199dece99f9f4a00854b SHA512 a7ae1e32129f5605c79aab5b614b7607dc9ee85fa0a2ec7ac37810769729761245e0b0d034cf248ee74c9212364ab6ffe9e9b29b4277681352d9f72d2d01bfaf
+EBUILD a2jmidid-9999.ebuild 1000 BLAKE2B 822efe0aab56a66ea32d32fa562359941bf6d94b43001e5ed128a17c9742964b9caaff37bbafc726aaf9d8c0cdc6b4d1a026bcd720aea42f60bdf4e165e6e75c SHA512 a9b52f3c48dd4448819beb8b348125620006f0f99c948211c9db48f43206a23e3feef52e8eb7984182dc4901daf75550bf2892452c0f9e130e9c39990cb1c6c1
MISC metadata.xml 369 BLAKE2B bd88b29130a3c698de0abb7984ebcc130c84c55de1e53c69a74279874a350d10651d9a312dfcc76de17e64e5af43f79b31a663247430cbc60ee87def0845fcd9 SHA512 7d8b83bedfbc2cf55cbab1475e7e04c835ef5a49e7500de000a032cc256551a26a73aa6a3a3989dabd4e7f69a4d4a1ac4bbd2d806d5b3d22cdb230793ff91096
diff --git a/media-sound/a2jmidid/a2jmidid-9.ebuild b/media-sound/a2jmidid/a2jmidid-9.ebuild
index 62228ef8c0d6..1d5c181d312a 100644
--- a/media-sound/a2jmidid/a2jmidid-9.ebuild
+++ b/media-sound/a2jmidid/a2jmidid-9.ebuild
@@ -1,9 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit meson
+PYTHON_COMPAT=( python3_{6..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit meson python-single-r1
DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
HOMEPAGE="https://github.com/linuxaudio/a2jmidid"
@@ -12,7 +15,8 @@ SRC_URI="https://github.com/linuxaudio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE="dbus"
+IUSE="dbus python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="
virtual/pkgconfig
@@ -21,6 +25,7 @@ CDEPEND="
media-libs/alsa-lib
virtual/jack
dbus? ( sys-apps/dbus )
+ python? ( ${PYTHON_DEPS} )
"
RDEPEND="${CDEPEND}"
DEPEND="${RDEPEND}"
@@ -34,3 +39,13 @@ src_configure() {
meson_src_configure
}
+
+src_install() {
+ meson_src_install
+
+ if use python; then
+ python_fix_shebang "${ED}"
+ else
+ rm "${ED}/usr/bin/a2j_control" || die
+ fi
+}
diff --git a/media-sound/a2jmidid/a2jmidid-9999.ebuild b/media-sound/a2jmidid/a2jmidid-9999.ebuild
index 7609deb0eba6..eeb15605c52f 100644
--- a/media-sound/a2jmidid/a2jmidid-9999.ebuild
+++ b/media-sound/a2jmidid/a2jmidid-9999.ebuild
@@ -1,9 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit meson git-r3
+PYTHON_COMPAT=( python3_{6..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit meson python-single-r1 git-r3
DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
HOMEPAGE="https://github.com/linuxaudio/a2jmidid"
@@ -12,7 +15,8 @@ EGIT_REPO_URI="https://github.com/linuxaudio/a2jmidid.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="dbus"
+IUSE="dbus python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="
virtual/pkgconfig
@@ -21,6 +25,7 @@ CDEPEND="
media-libs/alsa-lib
virtual/jack
dbus? ( sys-apps/dbus )
+ python? ( ${PYTHON_DEPS} )
"
RDEPEND="${CDEPEND}"
DEPEND="${RDEPEND}"
@@ -34,3 +39,13 @@ src_configure() {
meson_src_configure
}
+
+src_install() {
+ meson_src_install
+
+ if use python; then
+ python_fix_shebang "${ED}"
+ else
+ rm "${ED}/usr/bin/a2j_control" || die
+ fi
+}