summaryrefslogtreecommitdiff
path: root/media-radio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /media-radio
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/Manifest.gzbin4681 -> 4687 bytes
-rw-r--r--media-radio/tucnak/Manifest2
-rw-r--r--media-radio/tucnak/tucnak-4.13.ebuild68
3 files changed, 70 insertions, 0 deletions
diff --git a/media-radio/Manifest.gz b/media-radio/Manifest.gz
index 6b638a7f7ed7..41dabf08569b 100644
--- a/media-radio/Manifest.gz
+++ b/media-radio/Manifest.gz
Binary files differ
diff --git a/media-radio/tucnak/Manifest b/media-radio/tucnak/Manifest
index af249baa6d97..08404060f4cb 100644
--- a/media-radio/tucnak/Manifest
+++ b/media-radio/tucnak/Manifest
@@ -1,3 +1,5 @@
DIST tucnak-4.11.tar.gz 3517554 BLAKE2B 70f704f1251a9a8411ffceaff56b445160affe523e3aa665e7a6a54a2b3c8bfa5e934143b8a342d02240b929a9219287ca2eed74de1d2a906905162fcc2ad74b SHA512 510c13b181f2417e7fddfd13d808288624bfbf3c0e26cab712a7401d24e53432ad4a270a43f8224a75359a2a31ea3f4d7992583bee8188292ed7d8bc5ad8e8a0
+DIST tucnak-4.13.tar.gz 3516237 BLAKE2B 81d2f11ff2cc619ff22072355b08341115f4fcf33af9e9348a73980ba09e61282027d0b0f838682a2143b5d7d06db38b6b8ee502f16dfcded4e63eddb757afdb SHA512 5d5ca272240442cf2727a1285e560f04df6de96f88d990171a53320fb436b46ead7da1701ec4192fc18fab5f97b7a0b50a1025675e78653390301ee3b739d0d3
EBUILD tucnak-4.11.ebuild 1991 BLAKE2B d80af2ffb0945095946c4b90c61e692383b9f1772b166dd6857ed58ebb87c9c6ad2b414f7ab201ec5e2aa4b20aad60e19cdb1516db56e000d6674f834fce2d50 SHA512 55dae58cad12669dbecef391299c7daa8dd73c9c97545cc602154088ef5303a93a5fbdee8d080a4a170a07fe4984beeb7306822be9dc437b49e209027eadd17d
+EBUILD tucnak-4.13.ebuild 1971 BLAKE2B 8b7643d235bd8196d2c4c54abc02d8618983cd232d2f260569661682ee9748d7819b91fe26c536e43b42f3c4a233f59f1d239805630718831cedb7b770b9872c SHA512 fe60f6cd25e3a1dd77abf6dedb28415e8ec2a4eb9aa6fdb5374898ab346e0b5ff04aaacbd44df5eb6725f82bba971902fc85d6d64cb1aa525079a4ec3c898001
MISC metadata.xml 408 BLAKE2B 80978177d2257cefae04860fc52e43ea7f0d2221bf4a5b3050fe8057acda81625117b1ba74e7357d40d00cc7fbd44f2dac713494cd8d20679c690cf851e1b678 SHA512 ad015a404c42d5cd0f160907400f545698045bb6c7c3da59816830ec6ed51938a02988c59d4a9ade472a78fd39feeb49ebe6c2a9c625e535a37e44bf19db1b17
diff --git a/media-radio/tucnak/tucnak-4.13.ebuild b/media-radio/tucnak/tucnak-4.13.ebuild
new file mode 100644
index 000000000000..911cc5d37830
--- /dev/null
+++ b/media-radio/tucnak/tucnak-4.13.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic multilib
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fftw gpm hamlib suid"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libzia
+ media-libs/libsndfile
+ >=media-libs/libsdl-1.2
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( sci-libs/fftw:3.0 )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eapply_user
+ # fix destop file
+ sed -i -e "s/HamRadio/HamRadio;/" share/applications/tucnak.desktop || die
+ # fix doc install path
+ sed -i -e "s/docsdir/# docsdir/" \
+ -e "s/docs_DATA =/# docs_DATA/" \
+ -e "s/EXTRA_DIST =/# EXTRA_DIST =/" Makefile.am doc/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ econf $(use_with alsa) \
+ $(use_with gpm) $(use_with hamlib) \
+ $(use_with fftw fftw3)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog doc/NAVOD.pdf
+ if use suid ; then
+ fperms 4711 /usr/bin/soundwrapper
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+ if use suid ; then
+ ewarn "You have choosen to install the little helper program 'soundwrapper'"
+ ewarn "setuid by setting USE=suid. That helper is only needed if you"
+ ewarn "want to use morse sidetone output via the PC speaker."
+ ewarn ""
+ ewarn "While the helper should be safe by design be aware that setting"
+ ewarn "any program setuid is a security risk."
+ fi
+}