summaryrefslogtreecommitdiff
path: root/media-radio/xwxapt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /media-radio/xwxapt/files
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'media-radio/xwxapt/files')
-rw-r--r--media-radio/xwxapt/files/xwxapt-example-data.patch13
-rw-r--r--media-radio/xwxapt/files/xwxapt-fix-autotools.patch22
2 files changed, 35 insertions, 0 deletions
diff --git a/media-radio/xwxapt/files/xwxapt-example-data.patch b/media-radio/xwxapt/files/xwxapt-example-data.patch
new file mode 100644
index 000000000000..71ed56ae54e4
--- /dev/null
+++ b/media-radio/xwxapt/files/xwxapt-example-data.patch
@@ -0,0 +1,13 @@
+diff --git a/src/main.c b/src/main.c
+index 6cec142..7d7c1bf 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -127,7 +127,7 @@ main (int argc, char *argv[])
+ /* Create file path to xwxapt examples directory */
+ exe_path[bytes] = '\0';
+ Strlcpy( file_path, exe_path, sizeof(file_path) );
+- Strlcat( file_path, "/share/examples/xwxapt", sizeof(file_path) );
++ Strlcat( file_path, "/share/xwxapt", sizeof(file_path) );
+ fprintf( stderr, "xwxapt: creating xwxapt config directory from: %s\n", file_path );
+
+ /* Create system command to copy examples/xwxapt to ~/.xwxapt */
diff --git a/media-radio/xwxapt/files/xwxapt-fix-autotools.patch b/media-radio/xwxapt/files/xwxapt-fix-autotools.patch
new file mode 100644
index 000000000000..ba74a4eacf19
--- /dev/null
+++ b/media-radio/xwxapt/files/xwxapt-fix-autotools.patch
@@ -0,0 +1,22 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -35,17 +35,16 @@
+ AC_CHECK_LIB([gmodule-2.0], [g_module_open])
+
+ # Internationalization tools
++AM_GNU_GETTEXT([external])
+ AM_GNU_GETTEXT_VERSION([0.19.8])
+ GETTEXT_PACKAGE=xwxapt
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["$GETTEXT_PACKAGE"], [Gettext package.])
+-AM_GNU_GETTEXT
+ PROGRAMNAME_LOCALEDIR=[${datadir}/locale]
+ AC_SUBST(PROGRAMNAME_LOCALEDIR)
+
+ # Add the languages which your application supports here.
+ ALL_LINGUAS=""
+-AM_GNU_GETTEXT
+
+ # Checks for header files.
+ AC_CHECK_HEADERS([libintl.h stdlib.h string.h unistd.h])
+