summaryrefslogtreecommitdiff
path: root/media-radio/tlf/tlf-1.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /media-radio/tlf/tlf-1.4.0.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'media-radio/tlf/tlf-1.4.0.ebuild')
-rw-r--r--media-radio/tlf/tlf-1.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-radio/tlf/tlf-1.4.0.ebuild b/media-radio/tlf/tlf-1.4.0.ebuild
new file mode 100644
index 000000000000..5f950b40696f
--- /dev/null
+++ b/media-radio/tlf/tlf-1.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic
+
+DESCRIPTION="Console-mode amateur radio contest logger"
+HOMEPAGE="http://home.iae.nl/users/reinc/TLF-0.2.html"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ dev-libs/glib:2
+ media-libs/hamlib
+ media-sound/sox
+ dev-libs/xmlrpc-c[curl]"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )"
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ econf --docdir=/usr/share/doc/${PF} --enable-fldigi-xmlrpc
+}