summaryrefslogtreecommitdiff
path: root/media-radio/KochMorse/KochMorse-3.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /media-radio/KochMorse/KochMorse-3.4.0-r1.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'media-radio/KochMorse/KochMorse-3.4.0-r1.ebuild')
-rw-r--r--media-radio/KochMorse/KochMorse-3.4.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-radio/KochMorse/KochMorse-3.4.0-r1.ebuild b/media-radio/KochMorse/KochMorse-3.4.0-r1.ebuild
new file mode 100644
index 000000000000..3dbb7b44ee2b
--- /dev/null
+++ b/media-radio/KochMorse/KochMorse-3.4.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Morse-code tutor using the Koch method"
+HOMEPAGE="https://github.com/hmatuschek/kochmorse"
+SRC_URI="https://github.com/hmatuschek/kochmorse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="dev-qt/linguist-tools:5"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/kochmorse-${PV}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # Upstream uses a non-standard category in release 3.4.0. I submitted
+ # a fix which has been accepted, but not yet released.
+ sed -i -e 's/Teaching;/X-Teaching;/' shared/kochmorse.desktop || die
+}