summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-rssreader/vdr-rssreader-2.2.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /media-plugins/vdr-rssreader/vdr-rssreader-2.2.1-r2.ebuild
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'media-plugins/vdr-rssreader/vdr-rssreader-2.2.1-r2.ebuild')
-rw-r--r--media-plugins/vdr-rssreader/vdr-rssreader-2.2.1-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-plugins/vdr-rssreader/vdr-rssreader-2.2.1-r2.ebuild b/media-plugins/vdr-rssreader/vdr-rssreader-2.2.1-r2.ebuild
new file mode 100644
index 000000000000..909b08861462
--- /dev/null
+++ b/media-plugins/vdr-rssreader/vdr-rssreader-2.2.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: RSS reader"
+HOMEPAGE="https://github.com/rofafor/vdr-plugin-rssreader"
+SRC_URI="https://github.com/rofafor/vdr-plugin-rssreader/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=media-video/vdr-2.2.0
+ >=dev-libs/expat-1.95.8
+ >=net-misc/curl-7.15.1-r1"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.0-gentoo.diff"
+ "${FILESDIR}/${P}_c++11.patch"
+)
+QA_FLAGS_IGNORED="
+ usr/lib/vdr/plugins/libvdr-rssreader.*
+ usr/lib64/vdr/plugins/libvdr-rssreader.*"
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/vdr/plugins/rssreader
+ doins "${S}/rssreader/rssreader.conf"
+}