summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-osdserver/vdr-osdserver-0.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/vdr-osdserver/vdr-osdserver-0.1.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/vdr-osdserver/vdr-osdserver-0.1.3.ebuild')
-rw-r--r--media-plugins/vdr-osdserver/vdr-osdserver-0.1.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-plugins/vdr-osdserver/vdr-osdserver-0.1.3.ebuild b/media-plugins/vdr-osdserver/vdr-osdserver-0.1.3.ebuild
new file mode 100644
index 000000000000..31d4afc110d4
--- /dev/null
+++ b/media-plugins/vdr-osdserver/vdr-osdserver-0.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: VDR OSD access for ext. programs through a TCP/IP socket connection"
+HOMEPAGE="http://www.udo-richter.de/vdr/osdserver.en.html"
+SRC_URI=" http://www.udo-richter.de/vdr/files/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.7.20"
+
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${PN}-0.1.1-gentoo.diff"
+ "${FILESDIR}/${P}_gcc-6.patch" )
+
+DOCS="examples/* README README.PERL-MODULE HISTORY"
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/vdr/plugins/osdserver
+ doins "${FILESDIR}"/osdserverhosts.conf
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ elog "Check configuration files:"
+ elog "/etc/vdr/plugins/osdserver/osdserverhosts.conf"
+ elog "/etc/conf.d/vdr.osdserver"
+ elog "Examples are in '/usr/share/doc/vdr/${P}/'"
+}