summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r4.ebuild
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r4.ebuild')
-rw-r--r--media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r4.ebuild b/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r4.ebuild
new file mode 100644
index 000000000000..8d282d5f871b
--- /dev/null
+++ b/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Inform about incoming phone-calls and use the fritz!box phonebook"
+HOMEPAGE="https://github.com/jowi24/vdr-fritz"
+SRC_URI="https://github.com/jowi24/vdr-fritz/releases/download/${PV}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:=
+ dev-libs/boost:=[threads(+)]
+ media-video/vdr"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-boost-1.67.patch"
+ "${FILESDIR}/${P}_clang.patch"
+ )
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ # do not call ar directly
+ export _VDRAR="$(tc-getAR)"
+ sed -e "s:\@ar :\@\$(_VDRAR) :" \
+ -i libconv++/Makefile \
+ -i libfritz++/Makefile \
+ -i liblog++/Makefile \
+ -i libnet++/Makefile || die
+}
+
+pkg_postinst() {
+ elog "It is recommend to update your firmware release to the latest."
+ elog
+ elog "The integrated call monitor (available in Fritz!Box official"
+ elog "firmware releases >= *.04.29) has to be enabled in order to"
+ elog "have the vdr-fritzbox plugin display anything on your tv. To"
+ elog "enable it call #96*5* from your telephone. If that doesn't"
+ elog "work for you, read the documentation for further instructions."
+}