summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-console/vdr-console-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/vdr-console/vdr-console-0.6.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/vdr-console/vdr-console-0.6.0.ebuild')
-rw-r--r--media-plugins/vdr-console/vdr-console-0.6.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-plugins/vdr-console/vdr-console-0.6.0.ebuild b/media-plugins/vdr-console/vdr-console-0.6.0.ebuild
new file mode 100644
index 000000000000..f42b4815802e
--- /dev/null
+++ b/media-plugins/vdr-console/vdr-console-0.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="vdr Plugin: Shows linux console on vdr's output device"
+HOMEPAGE="http://ricomp.de/vdr/"
+SRC_URI="http://ricomp.de/vdr/${P}.tgz"
+
+LICENSE="GPL-2"
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=">=media-video/vdr-1.6.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-vdr-1.3.18.diff
+ "${FILESDIR}"/${P}-uint64.diff )
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ vdr_remove_i18n_include console.c menu.c terminalemulation.c virtualconsole.c virtualconsoles.c
+ sed -i console.c -e "s:RegisterI18n://RegisterI18n:"
+
+ ewarn "plugin will not support the new fonthandling"
+ epatch "${FILESDIR}/${P}-vdr-1.6.x-compilefix.diff"
+}