summaryrefslogtreecommitdiff
path: root/media-plugins/tap-plugins/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-plugins/tap-plugins/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-plugins/tap-plugins/files')
-rw-r--r--media-plugins/tap-plugins/files/tap-plugins-1.0.1-makefile.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-plugins/tap-plugins/files/tap-plugins-1.0.1-makefile.patch b/media-plugins/tap-plugins/files/tap-plugins-1.0.1-makefile.patch
new file mode 100644
index 000000000000..a5b441ee6d4f
--- /dev/null
+++ b/media-plugins/tap-plugins/files/tap-plugins-1.0.1-makefile.patch
@@ -0,0 +1,47 @@
+diff --git a/Makefile b/Makefile
+index 54049cd..86f7175 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,8 +23,8 @@
+ # Change this if you want to install somewhere else. In particular
+ # you may wish to remove the middle "local/" part of the path.
+
+-INSTALL_PLUGINS_DIR = /usr/local/lib/ladspa/
+-INSTALL_LRDF_DIR = /usr/local/share/ladspa/rdf/
++#INSTALL_PLUGINS_DIR = /usr/local/lib/ladspa/
++#INSTALL_LRDF_DIR = /usr/local/share/ladspa/rdf/
+
+ # NO EDITING below this line is required
+ # if all you want to do is install and use the plugins.
+@@ -37,13 +37,15 @@ INSTALL_LRDF_DIR = /usr/local/share/ladspa/rdf/
+ OS := $(shell uname -s)
+
+ CC = gcc
+-CFLAGS = -I. -O3 -Wall -fomit-frame-pointer -funroll-loops -ffast-math -c -fPIC -DPIC
++CFLAGS = -I. -Wall -fomit-frame-pointer -funroll-loops -ffast-math -c -fPIC -DPIC
+ ifeq ($(OS),Darwin)
+-LDFLAGS = -nostartfiles -shared -Wl,-install_name,symbolic -lc -lm
++LDFLAGS = -nostartfiles -shared -Wl,-install_name,symbolic -lc -lm $(EXTRA_LDFLAGS)
+ else
+-LDFLAGS = -nostartfiles -shared -Wl,-Bsymbolic -lc -lm -lrt
++LDFLAGS = -nostartfiles -shared -Wl,-Bsymbolic -lc -lm -lrt $(EXTRA_LDFLAGS)
+ endif
++EXTRA_LDFLAGS =
+ MODULES = $(wildcard *.c)
++LIBADD = -lc -lm -lrt
+
+ all: $(MODULES:%.c=%.so)
+
+@@ -54,10 +56,10 @@ tap_dynamics_m.o: tap_dynamics_presets.h
+ tap_dynamics_st.o: tap_dynamics_presets.h
+
+ %.o: %.c tap_utils.h ladspa.h
+- $(CC) $(CFLAGS) $< -o $@
++ $(CC) $(CFLAGS) $(OPT_CFLAGS) $< -o $@
+
+ %.so: %.o
+- $(CC) -o $@ $< $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $< $(LIBADD)
+
+ # OTHER TARGETS
+