summaryrefslogtreecommitdiff
path: root/media-plugins/obs-vkcapture
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-22 06:42:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-22 06:42:31 +0000
commit564687d289b862b8b079569a45a2d39d7b8c3585 (patch)
tree9ec555a8f8005c24f9d8198ba4941cc6f002a413 /media-plugins/obs-vkcapture
parent30c47f3c341cb37e4808aaa3842b679d0ca420e8 (diff)
gentoo auto-resync : 22:01:2025 - 06:42:31
Diffstat (limited to 'media-plugins/obs-vkcapture')
-rw-r--r--media-plugins/obs-vkcapture/Manifest4
-rw-r--r--media-plugins/obs-vkcapture/metadata.xml16
-rw-r--r--media-plugins/obs-vkcapture/obs-vkcapture-1.5.1.ebuild76
-rw-r--r--media-plugins/obs-vkcapture/obs-vkcapture-9999.ebuild76
4 files changed, 172 insertions, 0 deletions
diff --git a/media-plugins/obs-vkcapture/Manifest b/media-plugins/obs-vkcapture/Manifest
new file mode 100644
index 000000000000..bccd4905051b
--- /dev/null
+++ b/media-plugins/obs-vkcapture/Manifest
@@ -0,0 +1,4 @@
+DIST obs-vkcapture-1.5.1.tar.gz 60844 BLAKE2B d1e2951ecd0d375940ce8547619507e07be79033f94342babf4a66e51e620c6b0fcc96dd269a6d6a8556d62eda5721502986769c83bd6e38b150c4b77fe411b1 SHA512 9477fd738cdf80e09aad46e58ee5e325aa4f5ae72fbe1cb22918d4910fd997ba2a012ce7ca3b24b1b3734983b94e9b7df391f3deca569a79c90c5d115a1a5eed
+EBUILD obs-vkcapture-1.5.1.ebuild 1908 BLAKE2B 639b540f8e746695fe9a37c25ca9a83c5f7b0d9dda1697b3f09187492e51d05c137bf14234da4d1451173c88088486fb6f81cd35791b0d5c1575e1feee5a88f6 SHA512 eae67c2c5908c315fd7ee2da407109607afff3bd9ca81d31e188e4c8fd8a47f6d018199ff6b9eefa579089248ba22db548c01997f9e2a1ccf0fd0ed7903d47dd
+EBUILD obs-vkcapture-9999.ebuild 1908 BLAKE2B 639b540f8e746695fe9a37c25ca9a83c5f7b0d9dda1697b3f09187492e51d05c137bf14234da4d1451173c88088486fb6f81cd35791b0d5c1575e1feee5a88f6 SHA512 eae67c2c5908c315fd7ee2da407109607afff3bd9ca81d31e188e4c8fd8a47f6d018199ff6b9eefa579089248ba22db548c01997f9e2a1ccf0fd0ed7903d47dd
+MISC metadata.xml 551 BLAKE2B 71030878ae96d9d5820d76526f843c3cc15d06779185c55f6b791e45e94aa6b750c121bee65d5668f0db334505cf79c331e24e84647a4388af11d924601fbb10 SHA512 41f0107c4b270f700e9abcdf7a33e22f6df2b3843ce2cdef3da396ea4c2c3799235990daf31c021340ff2e63f7edd67f51e941acf38c00ce8ba4e33bda79778b
diff --git a/media-plugins/obs-vkcapture/metadata.xml b/media-plugins/obs-vkcapture/metadata.xml
new file mode 100644
index 000000000000..d4d6357bab24
--- /dev/null
+++ b/media-plugins/obs-vkcapture/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>hurikhan77+bgo@gmail.com</email>
+ <name>Kai Krakow</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/nowrep/obs-vkcapture/issues</bugs-to>
+ <remote-id type="github">nowrep/obs-vkcapture</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-plugins/obs-vkcapture/obs-vkcapture-1.5.1.ebuild b/media-plugins/obs-vkcapture/obs-vkcapture-1.5.1.ebuild
new file mode 100644
index 000000000000..a5c3c4c2d93d
--- /dev/null
+++ b/media-plugins/obs-vkcapture/obs-vkcapture-1.5.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="OBS Linux Vulkan/OpenGL game capture"
+HOMEPAGE="https://github.com/nowrep/obs-vkcapture"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nowrep/obs-vkcapture.git"
+else
+ SRC_URI="https://github.com/nowrep/obs-vkcapture/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="X wayland"
+
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPENDS="
+ >=media-video/obs-studio-30.2.0
+ >=media-libs/libglvnd-1.7.0[X=,${MULTILIB_USEDEP}]
+ X? (
+ x11-libs/libxcb:=[${MULTILIB_USEDEP}]
+ )
+ wayland? (
+ >=dev-libs/wayland-1.22.0
+ )
+"
+DEPEND="${COMMON_DEPENDS}
+ >=media-libs/vulkan-loader-1.3[X=,layers,wayland=,${MULTILIB_USEDEP}]
+ dev-util/vulkan-headers
+ wayland? (
+ >=dev-util/wayland-scanner-1.22.0
+ )
+ X? (
+ x11-libs/libX11
+ )
+"
+RDEPEND="${COMMON_DEPENDS}"
+
+QA_SONAME="
+ /usr/lib/libVkLayer_obs_vkcapture.so
+ /usr/lib64/libVkLayer_obs_vkcapture.so
+"
+
+pkg_postinst() {
+ if [[ $(</sys/module/nvidia_drm/parameters/modeset) != Y ]] 2>/dev/null; then
+ elog "This plugin needs nvidia-drm with modeset configured properly"
+ elog "to capture windows. To enable, edit /etc/modprobe.d/nvidia.conf"
+ elog "and uncomment the nvidia-drm options to enable modeset."
+ elog
+ fi
+
+ elog "This plugin can only capture the game window if you add one of the"
+ elog "following launcher options to the game (Steam as an example):"
+ elog " - OBS_VKCAPTURE=1 %command% (recommended, Vulkan)"
+ elog " - obs-gamecapture %command% (generic, OpenGL and Vulkan)"
+ elog
+ elog "HINT: This may currently not work on wayland with"
+ elog "x11-drivers/nvidia-drivers[kernel-open]"
+}
+
+multilib_src_configure() {
+ if ! multilib_is_native_abi; then
+ local mycmakeargs+=(
+ -DBUILD_PLUGIN=OFF
+ )
+ fi
+ cmake_src_configure
+}
diff --git a/media-plugins/obs-vkcapture/obs-vkcapture-9999.ebuild b/media-plugins/obs-vkcapture/obs-vkcapture-9999.ebuild
new file mode 100644
index 000000000000..a5c3c4c2d93d
--- /dev/null
+++ b/media-plugins/obs-vkcapture/obs-vkcapture-9999.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="OBS Linux Vulkan/OpenGL game capture"
+HOMEPAGE="https://github.com/nowrep/obs-vkcapture"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nowrep/obs-vkcapture.git"
+else
+ SRC_URI="https://github.com/nowrep/obs-vkcapture/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="X wayland"
+
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPENDS="
+ >=media-video/obs-studio-30.2.0
+ >=media-libs/libglvnd-1.7.0[X=,${MULTILIB_USEDEP}]
+ X? (
+ x11-libs/libxcb:=[${MULTILIB_USEDEP}]
+ )
+ wayland? (
+ >=dev-libs/wayland-1.22.0
+ )
+"
+DEPEND="${COMMON_DEPENDS}
+ >=media-libs/vulkan-loader-1.3[X=,layers,wayland=,${MULTILIB_USEDEP}]
+ dev-util/vulkan-headers
+ wayland? (
+ >=dev-util/wayland-scanner-1.22.0
+ )
+ X? (
+ x11-libs/libX11
+ )
+"
+RDEPEND="${COMMON_DEPENDS}"
+
+QA_SONAME="
+ /usr/lib/libVkLayer_obs_vkcapture.so
+ /usr/lib64/libVkLayer_obs_vkcapture.so
+"
+
+pkg_postinst() {
+ if [[ $(</sys/module/nvidia_drm/parameters/modeset) != Y ]] 2>/dev/null; then
+ elog "This plugin needs nvidia-drm with modeset configured properly"
+ elog "to capture windows. To enable, edit /etc/modprobe.d/nvidia.conf"
+ elog "and uncomment the nvidia-drm options to enable modeset."
+ elog
+ fi
+
+ elog "This plugin can only capture the game window if you add one of the"
+ elog "following launcher options to the game (Steam as an example):"
+ elog " - OBS_VKCAPTURE=1 %command% (recommended, Vulkan)"
+ elog " - obs-gamecapture %command% (generic, OpenGL and Vulkan)"
+ elog
+ elog "HINT: This may currently not work on wayland with"
+ elog "x11-drivers/nvidia-drivers[kernel-open]"
+}
+
+multilib_src_configure() {
+ if ! multilib_is_native_abi; then
+ local mycmakeargs+=(
+ -DBUILD_PLUGIN=OFF
+ )
+ fi
+ cmake_src_configure
+}