summaryrefslogtreecommitdiff
path: root/media-plugins/obs-scale-to-sound
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-22 06:42:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-22 06:42:31 +0000
commit564687d289b862b8b079569a45a2d39d7b8c3585 (patch)
tree9ec555a8f8005c24f9d8198ba4941cc6f002a413 /media-plugins/obs-scale-to-sound
parent30c47f3c341cb37e4808aaa3842b679d0ca420e8 (diff)
gentoo auto-resync : 22:01:2025 - 06:42:31
Diffstat (limited to 'media-plugins/obs-scale-to-sound')
-rw-r--r--media-plugins/obs-scale-to-sound/Manifest4
-rw-r--r--media-plugins/obs-scale-to-sound/metadata.xml16
-rw-r--r--media-plugins/obs-scale-to-sound/obs-scale-to-sound-1.2.4.ebuild25
-rw-r--r--media-plugins/obs-scale-to-sound/obs-scale-to-sound-9999.ebuild25
4 files changed, 70 insertions, 0 deletions
diff --git a/media-plugins/obs-scale-to-sound/Manifest b/media-plugins/obs-scale-to-sound/Manifest
new file mode 100644
index 000000000000..181d6956b5ca
--- /dev/null
+++ b/media-plugins/obs-scale-to-sound/Manifest
@@ -0,0 +1,4 @@
+DIST obs-scale-to-sound-1.2.4.tar.gz 57091 BLAKE2B 13b8a401cc42f711848f1875d7146cd5cdfeb3cdbb9f8f57a95294fc7c2834e468baba1d69292d378e475b76eb74b822a49b1929e48fa3281ffd4c53da340f24 SHA512 6b96c8540d3edbae5e508ba3c4e3531adab32f38c06286798a0d7d85daf73964130024410aca70f0619a041721a3806756ca25ab73924363187185f4e380faf6
+EBUILD obs-scale-to-sound-1.2.4.ebuild 607 BLAKE2B 7ff636f69c0de5a0cdb26d6c502e0754f15b814e6ef694ad46c7a2f69745771664301a9d61dc08bd3d41f8f06666d0e3683ad9d302d2b240e7d57476e9adebe4 SHA512 84e7b6ca5ff98595c5b25f27706415dd8f55b0670c2f113784b4e5e9f02b499b65311c3fee0b49c95a20a3a07c113965e87a6f8bab50f549ce66281e60de16fb
+EBUILD obs-scale-to-sound-9999.ebuild 607 BLAKE2B 7ff636f69c0de5a0cdb26d6c502e0754f15b814e6ef694ad46c7a2f69745771664301a9d61dc08bd3d41f8f06666d0e3683ad9d302d2b240e7d57476e9adebe4 SHA512 84e7b6ca5ff98595c5b25f27706415dd8f55b0670c2f113784b4e5e9f02b499b65311c3fee0b49c95a20a3a07c113965e87a6f8bab50f549ce66281e60de16fb
+MISC metadata.xml 563 BLAKE2B 980d76cbed6a104062e51f6694e5c760bc27c0a8c3f44e793f3eedb1952ec013c02fd20ac96bb566b6a770b981f1383fa5ae00942f90064272b4ef090c2bc51e SHA512 f6c6a8f52ea36bcf5c85d904f963440b085a19180ae348be42dad57d68f6b8b2deac34889ce302615faa9b0cbcbfc686fc2acf6e427df3b1ef2a2717ed8816c8
diff --git a/media-plugins/obs-scale-to-sound/metadata.xml b/media-plugins/obs-scale-to-sound/metadata.xml
new file mode 100644
index 000000000000..7782d53b5bb3
--- /dev/null
+++ b/media-plugins/obs-scale-to-sound/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>hurikhan77+bgo@gmail.com</email>
+ <name>Kai Krakow</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/dimtpap/obs-scale-to-sound/issues</bugs-to>
+ <remote-id type="github">dimtpap/obs-scale-to-sound</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-plugins/obs-scale-to-sound/obs-scale-to-sound-1.2.4.ebuild b/media-plugins/obs-scale-to-sound/obs-scale-to-sound-1.2.4.ebuild
new file mode 100644
index 000000000000..906d0fa4cd9f
--- /dev/null
+++ b/media-plugins/obs-scale-to-sound/obs-scale-to-sound-1.2.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="OBS filter plugin that scales a source reactively to sound levels"
+HOMEPAGE="https://github.com/dimtpap/obs-scale-to-sound"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dimtpap/obs-scale-to-sound.git"
+else
+ SRC_URI="https://github.com/dimtpap/obs-scale-to-sound/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="
+ >=media-video/obs-studio-30.2.0
+"
+RDEPEND="${DEPEND}"
diff --git a/media-plugins/obs-scale-to-sound/obs-scale-to-sound-9999.ebuild b/media-plugins/obs-scale-to-sound/obs-scale-to-sound-9999.ebuild
new file mode 100644
index 000000000000..906d0fa4cd9f
--- /dev/null
+++ b/media-plugins/obs-scale-to-sound/obs-scale-to-sound-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="OBS filter plugin that scales a source reactively to sound levels"
+HOMEPAGE="https://github.com/dimtpap/obs-scale-to-sound"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dimtpap/obs-scale-to-sound.git"
+else
+ SRC_URI="https://github.com/dimtpap/obs-scale-to-sound/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="
+ >=media-video/obs-studio-30.2.0
+"
+RDEPEND="${DEPEND}"