summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-peripheral-joystick
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/kodi-peripheral-joystick
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/kodi-peripheral-joystick')
-rw-r--r--media-plugins/kodi-peripheral-joystick/Manifest4
-rw-r--r--media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.3.2.ebuild38
-rw-r--r--media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-9999.ebuild37
-rw-r--r--media-plugins/kodi-peripheral-joystick/metadata.xml12
4 files changed, 91 insertions, 0 deletions
diff --git a/media-plugins/kodi-peripheral-joystick/Manifest b/media-plugins/kodi-peripheral-joystick/Manifest
new file mode 100644
index 000000000000..56a801f49684
--- /dev/null
+++ b/media-plugins/kodi-peripheral-joystick/Manifest
@@ -0,0 +1,4 @@
+DIST kodi-peripheral-joystick-1.3.2.tar.gz 82787 SHA256 c2025c4ec280b44b5d8bb1c34185a94cc105f66f0b762087804bb7d2d633d999 SHA512 9aa2e5d1af51b83abc0691fb9f6c7603d07c37b61fde898e2010d6370b9dca44275bd53caa2252479128360bc97eb8bd904d268a9c0cab7f2958c0b31f64ba1f WHIRLPOOL 621de3c1ffd9961fe9d43dd85a1e4f6df2100657380f7004ebe1d7f8cb2d6684df99e192903bde9377e617be6f2af90013a04f7e6b6600227eb3cd47df996b49
+EBUILD kodi-peripheral-joystick-1.3.2.ebuild 763 SHA256 3b1cfc9c6873682c71bb6c1842e9cfc2490ef93c6bd0dc0fabaca9b4f41ed006 SHA512 b3e15fc2640315e8df3e45a5554dd61a893f668c5aec593b37d82b4f15676ddaeb8c681a7e9a721c8ddfee40ea5ad2cd3692a1525f164d4ad563751565aa5460 WHIRLPOOL 844ffa2bfdf05001bfb25fb60e56ceeda0feda4d8c616f3f7e34610039659a2077de291c1b2a7adf7556b7cdf71a768e23032e016e75501d29199ad3ea37ac19
+EBUILD kodi-peripheral-joystick-9999.ebuild 735 SHA256 1b335e2d389aeecac7c7ca3698c706e5359cea45b5469f7c42d11730a82cc5be SHA512 a556e792db0a637979dc31beb8e32a9b821ec253728e29def090172f40bf8f1c4ce8b93091ee6952f77e124adc2390d223022be115325a49e65923a82d5ef42f WHIRLPOOL d1007390598f72ca692dbe896e27a6abc6c9f6c4013147452e2656053b34fe061eb26cd3e0bf81c075a18c302a72dcfc371d14cedfea6c99a0b7205c1730299b
+MISC metadata.xml 439 SHA256 1a967aace3adf3a02a6fc5f3cdbba0dcc34d5ba22d434ca9eabcbc14804344e0 SHA512 1489ac3199dbc3033892af4d492e843fff379a18a93059e4c0e164e9140411f8f7756d275b70214c375f4ee649d48786255aa6500c2b6b218f843295ebd6c29e WHIRLPOOL ab42cd1359d20c7297ec7eec70e9b26f13e07774ccd817734c13bd68409561964b7ae601b88184aaf4b27d807cba49891682adb9a07fced09cc2203690a5bf94
diff --git a/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.3.2.ebuild b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.3.2.ebuild
new file mode 100644
index 000000000000..019a5d3f0305
--- /dev/null
+++ b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Libretro compatibility layer for the Kodi Game API"
+HOMEPAGE="https://github.com/xbmc/peripheral.joystick"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/peripheral.joystick.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/peripheral.joystick/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/peripheral.joystick-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >media-tv/kodi-17.0.9999:0
+ =media-tv/kodi-17*:0
+ =media-libs/kodi-platform-17*
+ =dev-libs/libplatform-2*
+ dev-libs/libpcre
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-9999.ebuild b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-9999.ebuild
new file mode 100644
index 000000000000..a5cfea8b92ed
--- /dev/null
+++ b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Libretro compatibility layer for the Kodi Game API"
+HOMEPAGE="https://github.com/xbmc/peripheral.joystick"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/peripheral.joystick.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/peripheral.joystick/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/peripheral.joystick-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-9999
+ =media-libs/kodi-platform-9999
+ =dev-libs/libplatform-2*
+ dev-libs/libpcre
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-peripheral-joystick/metadata.xml b/media-plugins/kodi-peripheral-joystick/metadata.xml
new file mode 100644
index 000000000000..8b8b409a577d
--- /dev/null
+++ b/media-plugins/kodi-peripheral-joystick/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <longdescription>Kodi's Joystick peripheral addon</longdescription>
+ <upstream>
+ <remote-id type="github">xbmc/peripheral.joystick</remote-id>
+ </upstream>
+</pkgmetadata>