summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild')
-rw-r--r--media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild
new file mode 100644
index 000000000000..0afe32da893f
--- /dev/null
+++ b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Libretro compatibility layer for the Kodi Game API"
+HOMEPAGE="https://github.com/xbmc/peripheral.joystick"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_BRANCH="Matrix"
+ EGIT_REPO_URI="https://github.com/xbmc/peripheral.joystick.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ CODENAME="Matrix"
+ SRC_URI="https://github.com/xbmc/peripheral.joystick/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/peripheral.joystick-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ dev-libs/libpcre
+ dev-libs/tinyxml
+ "
+RDEPEND="
+ ${DEPEND}
+ "