summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-game-libretro-snes9x
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /media-plugins/kodi-game-libretro-snes9x
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'media-plugins/kodi-game-libretro-snes9x')
-rw-r--r--media-plugins/kodi-game-libretro-snes9x/Manifest4
-rw-r--r--media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.58.0.6.ebuild38
-rw-r--r--media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-9999.ebuild7
3 files changed, 45 insertions, 4 deletions
diff --git a/media-plugins/kodi-game-libretro-snes9x/Manifest b/media-plugins/kodi-game-libretro-snes9x/Manifest
index d9b89491c79b..ef1ae6dc30bd 100644
--- a/media-plugins/kodi-game-libretro-snes9x/Manifest
+++ b/media-plugins/kodi-game-libretro-snes9x/Manifest
@@ -1,2 +1,4 @@
-EBUILD kodi-game-libretro-snes9x-9999.ebuild 900 BLAKE2B 13a98165ce355746e3e8d0a2428903a59923fe5e86edf1da68c1835c291ff0fdc507f01e22fac63816c67b8cde79a9165244f3d331899cef0bc43a1178985890 SHA512 9f0bd59e7b422ab536f6eef8121ff040efac71ddc998913fbe66451c8473e3904b536765394b56d0411dc92e9ac6b6ab0a8c67e7feeaef06252c939f1f070e96
+DIST kodi-game-libretro-snes9x-1.58.0.6.tar.gz 1373392 BLAKE2B 6d17ac222eeae8e23aa76ab0b1aafe805f260b14c210715275afb370c2c52381013b48805477d01389fa1067e14f24465f35449dd95e309dfec7ac93b090df72 SHA512 3cc3b5eda830223a447dda4efb0438db679222200cae07d59f0879f95b1d252972186a241a74d0fa4668697a4ef8d2860923a43c7f4223af4ce794e937f255aa
+EBUILD kodi-game-libretro-snes9x-1.58.0.6.ebuild 936 BLAKE2B 07dbe84fc0d58fd3df1bfe6454b158affbcf427bb6956e84917e03c2dbc2dd9d82a1ab12bc845d77b273d23997047c8701b3555539997913d9a164a7379bcd68 SHA512 4506b2c017c187e1acd3b6768bfa7118a3b68200e414db52f396cc9ef9988ecaae3e0302284ae9afda2060316b5facee44d2ee9f502a146f8bc46dc23c84aab0
+EBUILD kodi-game-libretro-snes9x-9999.ebuild 937 BLAKE2B a78c39328e36a75286f8b6c96c85078c63f8c19247f69de5a12ab59cc87260b68d1d6659d17516ac309749e1a2a96b233c941e7af8ae125a4766b2d6724cc2b4 SHA512 029868005baedc33272ffa0f8b6de702c75ed0058e176b986e87d1e2f7c1b1a501313eca57f79c37e60783aeb68b33ce2464393f66dec36ed6e870fd77c2d4bd
MISC metadata.xml 439 BLAKE2B 6cec6faa75fdb35edf1f33f2a47d370318b8ab96f2c712571b33d22bc30130826cade398c3f7b4aee986e78baf9c3161b342215457b38d09994a1793b8704fdc SHA512 e3c0f999e2123aa2b23b0b29d1d6d24da0d804e435351c5971a2c60390c33bc3bf001571025cfe4ea7a76680a45be27f18169b201d16c8d8dcad9dbb55e9ebcb
diff --git a/media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.58.0.6.ebuild b/media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.58.0.6.ebuild
new file mode 100644
index 000000000000..de406700e0d6
--- /dev/null
+++ b/media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.58.0.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Snes9x GameClient for Kodi"
+HOMEPAGE="https://github.com/kodi-game/game.libretro.snes9x"
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.snes9x.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ CODENAME="Leia"
+ SRC_URI="https://github.com/kodi-game/game.libretro.snes9x/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/game.libretro.snes9x-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ games-emulation/libretro-snes9x
+ "
+RDEPEND="
+ media-plugins/kodi-game-libretro
+ ${DEPEND}
+ "
+src_prepare() {
+ echo 'find_library(SNES9X_LIB NAMES snes9x_libretro${CMAKE_SHARED_LIBRARY_SUFFIX} PATH_SUFFIXES libretro)' > "${S}/Findlibretro-snes9x.cmake" || die
+ default
+}
diff --git a/media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-9999.ebuild b/media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-9999.ebuild
index a3c02f28e235..7dee71b48dd0 100644
--- a/media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-9999.ebuild
+++ b/media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,8 +15,9 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/kodi-game/game.libretro.snes9x/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/game.libretro.snes9x-${PV}"
+ CODENAME="Leia"
+ SRC_URI="https://github.com/kodi-game/game.libretro.snes9x/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/game.libretro.snes9x-${PV}-${CODENAME}"
fi
LICENSE="GPL-2"