summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-game-libretro-dosbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /media-plugins/kodi-game-libretro-dosbox
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'media-plugins/kodi-game-libretro-dosbox')
-rw-r--r--media-plugins/kodi-game-libretro-dosbox/Manifest4
-rw-r--r--media-plugins/kodi-game-libretro-dosbox/kodi-game-libretro-dosbox-0.74.0.3.ebuild38
-rw-r--r--media-plugins/kodi-game-libretro-dosbox/kodi-game-libretro-dosbox-9999.ebuild7
3 files changed, 45 insertions, 4 deletions
diff --git a/media-plugins/kodi-game-libretro-dosbox/Manifest b/media-plugins/kodi-game-libretro-dosbox/Manifest
index bebfb365f4df..3dc866f3f658 100644
--- a/media-plugins/kodi-game-libretro-dosbox/Manifest
+++ b/media-plugins/kodi-game-libretro-dosbox/Manifest
@@ -1,2 +1,4 @@
-EBUILD kodi-game-libretro-dosbox-9999.ebuild 900 BLAKE2B d8bb6665e6ec706bb50af2cd382feee028881118653b9b2065f070485a82c6a578f45761f2515ce50c5cb25cdf2dccaf5a853aaac08af156751c692d326e0f25 SHA512 25cef03ca6a82c0412bed704491c7b45c787e708803dc18e93de90dbc0a1fae69113e675ffcbb4a04233f99041b1a343bf1d7a918bc030220bba25175a7999c3
+DIST kodi-game-libretro-dosbox-0.74.0.3.tar.gz 53861 BLAKE2B bba95d96c9a313a96df7e3774573fdf43040efd23629242f1400a5a5ca8c2ebe948b68fba7d780ccd4cb3ca7cc4db74e23fece9d192e6988493a89eec19cdca7 SHA512 e802f5bdb1c9b82c5fa3224138f1956e4210aa532bea3ead20fba1a9349ef780f52d966b334beb498ab3433bd3822df7ae9e5cdcddbbf5b97318a5b65f4fc277
+EBUILD kodi-game-libretro-dosbox-0.74.0.3.ebuild 936 BLAKE2B 1c14d09fdc0826fe59374b74ecbfe34d0bea34c7bc68311643aa0392de6a880b49ae01c2b0301f3fd71eff2cda3044250ab478635afa842e93b49c6d81d7d848 SHA512 c009b2dcc6c8e97cc41ff6b2c16757984d280e43813e1080cf535e75686c07d4fa3b73600795a954a1150de4c625813eb15a17fdf4d58afe99e401bd719986b7
+EBUILD kodi-game-libretro-dosbox-9999.ebuild 937 BLAKE2B 576962426c884f6dc83e1cfc5e4f0cae601a864f76953edc89b13d60921171bc125a96d2aaaf867ffa787274e8383d95af18481cabae85560729cf66c76ac3dd SHA512 5c000097c03656e34a99fb444414823852a0095b281d1f7e9471c542c2d0a703992d2eceea70dbffe9425dd50b5b73f335b66dec804a6e13604e2b3633da7932
MISC metadata.xml 439 BLAKE2B 26e660170befb49f4f8cecc4e47a11a4edce7447eecfe8318dc00d5ce6aa4b1a54e6484a50ddf2004caefdaa8c56869e377c2607f2213e73cbcc95d67ae90fee SHA512 fc9f630ac1c8cb229608ac0ee16398a529e1698a254abaa79f786c9ffb543558577ae06c02f2142bd9f3d405457c73a0b8be0f46bf656af1d24c645704d2f560
diff --git a/media-plugins/kodi-game-libretro-dosbox/kodi-game-libretro-dosbox-0.74.0.3.ebuild b/media-plugins/kodi-game-libretro-dosbox/kodi-game-libretro-dosbox-0.74.0.3.ebuild
new file mode 100644
index 000000000000..8d15e745cc22
--- /dev/null
+++ b/media-plugins/kodi-game-libretro-dosbox/kodi-game-libretro-dosbox-0.74.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="DOSBox GameClient for Kodi"
+HOMEPAGE="https://github.com/kodi-game/game.libretro.dosbox"
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.dosbox.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ CODENAME="Leia"
+ SRC_URI="https://github.com/kodi-game/game.libretro.dosbox/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/game.libretro.dosbox-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ games-emulation/libretro-dosbox
+ "
+RDEPEND="
+ media-plugins/kodi-game-libretro
+ ${DEPEND}
+ "
+src_prepare() {
+ echo 'find_library(DOSBOX_LIB NAMES dosbox_libretro${CMAKE_SHARED_LIBRARY_SUFFIX} PATH_SUFFIXES libretro)' > "${S}/Findlibretro-dosbox.cmake" || die
+ default
+}
diff --git a/media-plugins/kodi-game-libretro-dosbox/kodi-game-libretro-dosbox-9999.ebuild b/media-plugins/kodi-game-libretro-dosbox/kodi-game-libretro-dosbox-9999.ebuild
index 44c31d728f6e..3e5fcb2608a7 100644
--- a/media-plugins/kodi-game-libretro-dosbox/kodi-game-libretro-dosbox-9999.ebuild
+++ b/media-plugins/kodi-game-libretro-dosbox/kodi-game-libretro-dosbox-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,8 +15,9 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/kodi-game/game.libretro.dosbox/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/game.libretro.dosbox-${PV}"
+ CODENAME="Leia"
+ SRC_URI="https://github.com/kodi-game/game.libretro.dosbox/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/game.libretro.dosbox-${PV}-${CODENAME}"
fi
LICENSE="GPL-2"