summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-audiodecoder-nosefart
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/kodi-audiodecoder-nosefart
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/kodi-audiodecoder-nosefart')
-rw-r--r--media-plugins/kodi-audiodecoder-nosefart/Manifest4
-rw-r--r--media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-1.1.0.ebuild35
-rw-r--r--media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-9999.ebuild35
-rw-r--r--media-plugins/kodi-audiodecoder-nosefart/metadata.xml12
4 files changed, 86 insertions, 0 deletions
diff --git a/media-plugins/kodi-audiodecoder-nosefart/Manifest b/media-plugins/kodi-audiodecoder-nosefart/Manifest
new file mode 100644
index 000000000000..d0d84171da68
--- /dev/null
+++ b/media-plugins/kodi-audiodecoder-nosefart/Manifest
@@ -0,0 +1,4 @@
+DIST kodi-audiodecoder-nosefart-1.1.0.tar.gz 59921 SHA256 444cc85f4618daa5147a63633db3f300123d5e33b1b5894e7036fa9243e8a535 SHA512 c85768e3b7b31607429d85f6d2f9254bb42a4500a0e42b0a76d953a87b6d2275cef4ed922eb7a2af51770b90cb35403171df6258dae9157683be0a07304f6e6b WHIRLPOOL 0d886db8af3bb334d6ec82c29b8adf7d9f7adde3d06a208de82088706bd11e0f701735f100de6216ba2acf218234d90d34e5fd388588bb8dcd135e41a159595f
+EBUILD kodi-audiodecoder-nosefart-1.1.0.ebuild 676 SHA256 ce2655e3800fb29b32481126e34a1f5bd2af410c36fd3ced1ae1e17dfdcc1176 SHA512 d4bd5c32269f323d4233215c4701fe34e892b5d38ff73f14b2136921e6a80711d2d8333c23adf5f9f56cdabe5219ff9680b8f5f828aee3deaa845213347d46b7 WHIRLPOOL b545c429858ae90f5fe9fee28decfcacfcf14308ea3291e003bfbf59ef125c9f2db2e0fcaed3583cfd5641046e0bd62b6e89357d38ca3e6343ede2994f1c1a5a
+EBUILD kodi-audiodecoder-nosefart-9999.ebuild 676 SHA256 ce2655e3800fb29b32481126e34a1f5bd2af410c36fd3ced1ae1e17dfdcc1176 SHA512 d4bd5c32269f323d4233215c4701fe34e892b5d38ff73f14b2136921e6a80711d2d8333c23adf5f9f56cdabe5219ff9680b8f5f828aee3deaa845213347d46b7 WHIRLPOOL b545c429858ae90f5fe9fee28decfcacfcf14308ea3291e003bfbf59ef125c9f2db2e0fcaed3583cfd5641046e0bd62b6e89357d38ca3e6343ede2994f1c1a5a
+MISC metadata.xml 444 SHA256 d362c09477e7aa82054c076d6516b0b759f8ca1f2d3595e98a1e7b924f5dac0d SHA512 9a6295c8af39d75437b1f56b8a91e234ac1578110e1e64b52ee5ade240bd43764a52ec843735e7e3814fea6a662937315db4ae5e0988c9c016c1f72ab12fe91a WHIRLPOOL ef5147d04ad2592f6969b9c92ee83399baaf0b6a77a7230fa38ce3f168a20c9456c248299cac2f4f9cff6ed7e2957f9265f0b0ac45c3c38006421edac8789a59
diff --git a/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-1.1.0.ebuild b/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-1.1.0.ebuild
new file mode 100644
index 000000000000..ace5ee08839f
--- /dev/null
+++ b/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Nosefart decoder addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/audiodecoder.nosefart"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/notspiff/audiodecoder.nosefart"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/audiodecoder.nosefart/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/audiodecoder.nosefart-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ media-tv/kodi
+ media-libs/kodi-platform
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-9999.ebuild b/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-9999.ebuild
new file mode 100644
index 000000000000..ace5ee08839f
--- /dev/null
+++ b/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Nosefart decoder addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/audiodecoder.nosefart"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/notspiff/audiodecoder.nosefart"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/audiodecoder.nosefart/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/audiodecoder.nosefart-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ media-tv/kodi
+ media-libs/kodi-platform
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-audiodecoder-nosefart/metadata.xml b/media-plugins/kodi-audiodecoder-nosefart/metadata.xml
new file mode 100644
index 000000000000..a54cd0184d17
--- /dev/null
+++ b/media-plugins/kodi-audiodecoder-nosefart/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <longdescription>Nosefart decoder addon for Kodi</longdescription>
+ <upstream>
+ <remote-id type="github">notspiff/audiodecoder.nosefart</remote-id>
+ </upstream>
+</pkgmetadata>