summaryrefslogtreecommitdiff
path: root/media-plugins/imlib2_loaders
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-plugins/imlib2_loaders
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-plugins/imlib2_loaders')
-rw-r--r--media-plugins/imlib2_loaders/Manifest4
-rw-r--r--media-plugins/imlib2_loaders/imlib2_loaders-1.6.0.ebuild36
-rw-r--r--media-plugins/imlib2_loaders/metadata.xml10
3 files changed, 44 insertions, 6 deletions
diff --git a/media-plugins/imlib2_loaders/Manifest b/media-plugins/imlib2_loaders/Manifest
index acda78d1a983..fdf23950302f 100644
--- a/media-plugins/imlib2_loaders/Manifest
+++ b/media-plugins/imlib2_loaders/Manifest
@@ -1,3 +1,5 @@
DIST imlib2_loaders-1.5.1.tar.gz 378169 BLAKE2B a65dabb8fb537489fe77fdc7c197ce4fa91dc13a86d1a5bf5aae4fbc9ac65a4194b57de8d49bb0dc2d906b20b7c79aa458d0ba668aa947a847414f377fd3b540 SHA512 a94996091a7f9f1271c19d24e6edebeb34977a4e67b8300897de0e5afd06bb9b209e404dd86ab3f397c6dec64f4985a515986b6b048d2c13416265eb2058a8a6
+DIST imlib2_loaders-1.6.0.tar.gz 375642 BLAKE2B cf1e8ad887d7b56ab828018e85d5fc635509eadd283ebc051671d8b9129adfded12449a5e8d7d52f4a8bd8e877a0585d62562e169be6176d93ded3dec0569e5d SHA512 948e85260ad9379f71d35ed8f98355f25878acef3bffc9add0419b6c3d3f7eec0dd504701d0bd2ad75a1aacba02e08965a5f0327f7a2832369af34b5d23d9179
EBUILD imlib2_loaders-1.5.1.ebuild 807 BLAKE2B a2efdf32043ac6fa4e9158e05ceb3716861ea2ede0b9593f4c292f84e55bfd98678b5a56ce6aaf352a8f1773f983d45369307eafb3d352ed40a091a20ec7179f SHA512 997492faf9ad956235729970081a36dae05b45f24c88926634afeaeff6cce42e7d21dc4192cb4ba3ad828c2c0ec670f0ca7692738ef48466c6197f26f1f5fe72
-MISC metadata.xml 832 BLAKE2B 24df1b4810fd5d8b8492c4d42543f48123ea2906e85ea8109f7d434be992142193aabafbdf1e564c5df3ea63a7c73c13267312b812928154f14a360803cbd78c SHA512 70242dcb527186844975b2eb9e8a6a041627efbbdd2cd94fc31123b0d883e563161189e06666eb4ef53bbb4eb84d4b8aee7c53d32607db373bb640d000f5a09d
+EBUILD imlib2_loaders-1.6.0.ebuild 878 BLAKE2B f2b57af3da5279620d0291e22e1b08b990ed4bebd302ca6e900bd52b75990f796deb12435328c5b7bc4ad456f230784a75a21fb1e1cbda9f16370bbae12b475b SHA512 7d60fcb61668d1656f09989ab6c5b9bbcb228f93284097989255a66a216b594f867c03e19d9d51ee1eea351f4a8afb1705472a1420645c78ac06d5676bc100c2
+MISC metadata.xml 828 BLAKE2B bb417b5233966162b782c8b9371fbc5b5d6fb3e36cb9d2ce3f3481b82dae184b1f754ad44d9b6275c24d4ff27f48278690eea38174f2ed2dde287fb5778c49fd SHA512 349cb0bbc1ac72e5de17a40b9e913c9fc2288692797255bbb1d48d5017daab8721c646aec489aca777d26a6f1fc5f641a2b30d1aaa2b6f6724678373d98f3e21
diff --git a/media-plugins/imlib2_loaders/imlib2_loaders-1.6.0.ebuild b/media-plugins/imlib2_loaders/imlib2_loaders-1.6.0.ebuild
new file mode 100644
index 000000000000..c6228802d6cb
--- /dev/null
+++ b/media-plugins/imlib2_loaders/imlib2_loaders-1.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Additional image loaders for Imlib2"
+HOMEPAGE="https://www.enlightenment.org/
+ https://sourceforge.net/projects/enlightenment/files/imlib2-src/"
+SRC_URI="https://downloads.sourceforge.net/enlightenment/${P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="eet xcf"
+
+RDEPEND=">=media-libs/imlib2-${PV}
+ eet? ( dev-libs/efl[eet] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_enable eet)
+ $(use_enable xcf)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ V=1 emake install DESTDIR="${D}"
+ einstalldocs
+
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/media-plugins/imlib2_loaders/metadata.xml b/media-plugins/imlib2_loaders/metadata.xml
index ea6a70be15ca..d387cac879dd 100644
--- a/media-plugins/imlib2_loaders/metadata.xml
+++ b/media-plugins/imlib2_loaders/metadata.xml
@@ -10,12 +10,12 @@
<flag name="xcf">Enable XCF image loader</flag>
</use>
<longdescription>
- This package contains image loader plugins for Imlib2 that are not
+ This package contains image loader plugins for Imlib2 that are not
distributed together with the Imlib2 package itself.
- The XCF loader cannot be packaged together with Imlib2 because
- Imlib2 is distributed under the BSD license, whereas the XCF loader
- is using elements of the Gimp's (www.gimp.org) codebase, which is
- distributed under the GPL. The XCF loader therefore is GPL'd as well.
+ The XCF loader cannot be packaged together with Imlib2 because Imlib2 is
+ distributed under the BSD license, whereas the XCF loader is using elements
+ of the Gimp's (www.gimp.org) codebase, which is distributed under the GPL.
+ The XCF loader therefore is GPL'd as well.
</longdescription>
</pkgmetadata>