summaryrefslogtreecommitdiff
path: root/media-plugins/gst-plugins-smoothstreaming
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /media-plugins/gst-plugins-smoothstreaming
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'media-plugins/gst-plugins-smoothstreaming')
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/Manifest2
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.16.2.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-smoothstreaming/Manifest b/media-plugins/gst-plugins-smoothstreaming/Manifest
index 95c68222f35c..5ab511ba3594 100644
--- a/media-plugins/gst-plugins-smoothstreaming/Manifest
+++ b/media-plugins/gst-plugins-smoothstreaming/Manifest
@@ -1,3 +1,5 @@
DIST gst-plugins-bad-1.14.5.tar.xz 4686916 BLAKE2B b22377fbadf54828e86cc4e0bb17fb9b25efe4394c64eeceb228084e58d0db595622670c6c0a2d87fb760fce34974f9e425a2b810460465130ce1a4c2c679e7d SHA512 64d2a9f6203fbeb3db19816f936f4db32dd8bb7d1f4ce1f958ae795f008e72946e8e2e8bcf8c456c33d5567cb66dc34ca95836c52e404835300a3a5f38d52b6b
+DIST gst-plugins-bad-1.16.2.tar.xz 4887812 BLAKE2B edf10aeb365d9a7cf4b5172af29b46cff4c7a49a3e4dde881469f5738b5a525eb51a6f70bb1dd6f680e4e48977d65769ac8e8f41d914b7ce7719b9fa260a7bd4 SHA512 aeaf3388156fe7317e193a3f940d391a6d8a1187f93e6925cee4cb02c4e78d9b456c22c27c318f0f9b2212ca68887c5cdcc256adaf068bfab8ec5c091a1e8805
EBUILD gst-plugins-smoothstreaming-1.14.5.ebuild 1356 BLAKE2B 13243bf1f53db280eb0f8076e84ade16e91341404cef5343883afe4fd49d432cc7bc5bae11e6a9ba8920a91a8bd8eac9a5d0b4a411000c8de01859099e572621 SHA512 d470e7f1c6f1b10b90bb703c03e00f8e90a52f296d9a52a4680bab34972397a5ba643cee922d4d871a7caa09df7d05980905ea1315490889d51a437cd6d4b8c2
+EBUILD gst-plugins-smoothstreaming-1.16.2.ebuild 1358 BLAKE2B bd933f3cfc9cc22d58c7dda7c47bc9185c936b905df8c6c202b8324c9f73a2f74d60d4d10ce031e9d9327bcdf0c00b8974c10b7d703b77e69ce059d5b2a87679 SHA512 85576b560995a495cef929a0e69956298410f7a367c6a688a5409217d468ff253d6b3179998749fc127ff786c83e79f728961ee1d2f1803508f07550e0fa096f
MISC metadata.xml 262 BLAKE2B 16a4a230ef5481afde96333e9555bee1771ced412b11eb982c633709dec57b274f78082ba3fe842f7d3406a688662d34792fff304027833286b30652e9982719 SHA512 608f0a17d576a3b23a6921272eb449a6efed76b3c4b3fdf8737b2d499b56d109186c2883c06e5c843799d2fb1606f3066c43759b40f9d7cf58b6a674c38dd0e0
diff --git a/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.16.2.ebuild b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.16.2.ebuild
new file mode 100644
index 000000000000..eddd74c9f011
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.16.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="Smooth Streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # FIXME: gsturidownloader does not have a .pc
+ # gst-libs/gst/uridownloader:gsturidownloader \
+ # gst-libs/gst/adaptativedemux:gstadaptivedemux \
+ # gst-libs/gst/isoff:gstisoff
+ gstreamer_system_link \
+ gst-libs/gst/codecparsers:gstreamer-codecparsers
+
+ local directory libs
+ directory="gst-libs/gst/uridownloader"
+ libs="-lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgsturidownloader-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+
+ directory="gst-libs/gst/adaptivedemux"
+ libs="-lgsturidownloader-1.0 -lgstapp-1.0 -lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgstadaptivedemux-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+
+ directory="gst-libs/gst/isoff"
+ libs="-lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgstisoff-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+}