summaryrefslogtreecommitdiff
path: root/media-plugins/gst-plugins-gtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /media-plugins/gst-plugins-gtk
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'media-plugins/gst-plugins-gtk')
-rw-r--r--media-plugins/gst-plugins-gtk/Manifest2
-rw-r--r--media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.14.5.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gtk/Manifest b/media-plugins/gst-plugins-gtk/Manifest
index a2b8cf083136..a3328d7f43e7 100644
--- a/media-plugins/gst-plugins-gtk/Manifest
+++ b/media-plugins/gst-plugins-gtk/Manifest
@@ -1,3 +1,5 @@
DIST gst-plugins-good-1.14.4.tar.xz 3792524 BLAKE2B 4c7faac73d33bebe1fd53dc4cfed1a5d27b103f9c4cd801672ad52e385f09addb07cd4a0f511dff23815e3421e5202fb3d7866b7dd58fdaf101d0357c4fdc13f SHA512 30aeb3bb74571287cad1598973da38e7a43a0128d35480ded6d280c1373dc4ecd4ea76caaa04a71cdfba2e1850aee5f1b72d96be86ae92d66633e7d32081c504
+DIST gst-plugins-good-1.14.5.tar.xz 3800104 BLAKE2B acb8ba559c8f4d96cb548fa05e88a556dbfd3aed8572d91cee4fc7b652ab1e814a615713f1372a0acdaa723ddf2d9af9c84c599bc4128b8f61d03bfbc096dcce SHA512 11bfadaf39b28a0a6a6c87c4ade8513496e8f13873cb0c2ddc8b8241029b8775d4839f2de441bda664bc67c66c4ca1d6839dd7570f7d79c1f485d5a25cc9d236
EBUILD gst-plugins-gtk-1.14.4.ebuild 1198 BLAKE2B 043b5ad75eece99caa732e1baab41066c647e5d43ab1d41dde493372dbcea6ad01f431b20ddd764bb1f334414d9b24de934a3dd7015f5dfb2b79e7db5c12b11d SHA512 306dad8ddb3652f3860ad5495f3539471346476604dbd653358913693c0979c1f4b9dc3600473aaa4f9292aa8b35213256387ee80d8214d0e8f367c45b6b6134
+EBUILD gst-plugins-gtk-1.14.5.ebuild 1206 BLAKE2B 4e3df571fa2292b2bfaa4d8e4101a27d53a4f6086a6d35bb39438aacad707abed0b08402eff26204d8396c1b1ab05f0608901f21ca64072fd417c327a233d678 SHA512 f32f9a4275c046e39debf6fb45dc9eaa322f1742769af84921e252e96dcd161eebbdefe85fdf977b51e029f2b9393396f9559ef365b24ef258e3b0a051b75588
MISC metadata.xml 790 BLAKE2B 609210afdad563f5d63ea609ac6a65301907d447a137537aa9451ce6bf5774f9a15a8294a4e11b72697e123a4ffac44cefa5f6cf820a78bd998cd581e7ec720b SHA512 8ca80354a5c57ccbc941bc62cd7fc1b3bfbd2223901c24afac0ade01ab751e790cf9bafc4e0d4a3074606be99ac7aae10a45a9f7c65068342495f2995c956fa5
diff --git a/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.14.5.ebuild b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.14.5.ebuild
new file mode 100644
index 000000000000..c7162ff5ab83
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.14.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer
+
+DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+egl gles2 +opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
+# egl, wayland and X only matters if gst-plugins-bad is build with USE=opengl and/or USE=gles2
+# We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
+# we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
+# gst-plugins-base, but no way to express that.
+
+# We only need gtk+ matching backend flags when GL is enabled
+GL_DEPS="
+ >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
+ >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_BUILD="gtk3"