summaryrefslogtreecommitdiff
path: root/media-plugins/gst-plugins-gtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /media-plugins/gst-plugins-gtk
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'media-plugins/gst-plugins-gtk')
-rw-r--r--media-plugins/gst-plugins-gtk/Manifest2
-rw-r--r--media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.18.4.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gtk/Manifest b/media-plugins/gst-plugins-gtk/Manifest
index 0c0a690935bf..7fa12e4efd6f 100644
--- a/media-plugins/gst-plugins-gtk/Manifest
+++ b/media-plugins/gst-plugins-gtk/Manifest
@@ -1,3 +1,5 @@
DIST gst-plugins-good-1.16.3.tar.xz 3914676 BLAKE2B 52f18027f9d9a77e8b459a0a10fa7c1450dff2faf8a2a63134f833ad08b19985b7f0d3d2af4b766c9b8bf802d048fabd6f52ad5a7865eccd1fe0d26404b7b2de SHA512 3e0da4a4defc0ddea1c26dfc767fed732548654f4155452649777109a17d5b65b2fde895483a3e35dc1646de5a16e913cd2408f826251d46a99b7751b88dcb65
+DIST gst-plugins-good-1.18.4.tar.xz 3277572 BLAKE2B 8acfb975d19eabc681184d0096328051a9a02e5f849599dbad1233a0e9254e1a2d2bef75d8afdc779a7ca01a71b15d1e83a843749c0ef5f7ab2b5818067ab898 SHA512 764c66383c93e57f9c5e7742002013e07e7b25750d6974d6c07744433e8ceb7570e829e68278e2bc5214f77158311a6b3bfb013d615cf66205d8d7a9e2d54b86
EBUILD gst-plugins-gtk-1.16.3.ebuild 1179 BLAKE2B 7aaf5ff28b98509fec7816fc782741b861b6b4775bcebc6b09fe5052d09ac583a356ab394acb73959e16d70e0a6d4c9eedaac525506050686899c49dd620241e SHA512 26e6f770306c868b27b0d71a4de11b22755d22422109ea33ee8827987f155847b49016b3f455747cc216341f9b04d5381c2aee9e0a58333a68b3b94dcbbfad2c
+EBUILD gst-plugins-gtk-1.18.4.ebuild 1193 BLAKE2B ee874aa94a5ba86fef43743e8f9109a6ff5d28b293ef21051fe11800ca0ae975c19185153b8668a31c9f7bd25b89e35acba1a756aa3a8491b65da667dc925fef SHA512 750925f98b6d2ea5007d26985d8d088e9ccd3337460287bea8f671291afd5035db1edbf31cc7101d144d9c5ce42c4709a62fc32bd9197c3e50cf298e45351b6f
MISC metadata.xml 790 BLAKE2B 609210afdad563f5d63ea609ac6a65301907d447a137537aa9451ce6bf5774f9a15a8294a4e11b72697e123a4ffac44cefa5f6cf820a78bd998cd581e7ec720b SHA512 8ca80354a5c57ccbc941bc62cd7fc1b3bfbd2223901c24afac0ade01ab751e790cf9bafc4e0d4a3074606be99ac7aae10a45a9f7c65068342495f2995c956fa5
diff --git a/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.18.4.ebuild b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.18.4.ebuild
new file mode 100644
index 000000000000..a218f3cf7b57
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.18.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer-meson
+
+DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+egl gles2 +opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
+# egl, wayland and X only matters if gst-plugins-base is built with USE=opengl and/or USE=gles2
+# We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
+# we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
+# gst-plugins-base, but no way to express that.
+
+# We only need gtk+ matching backend flags when GL is enabled
+GL_DEPS="
+ >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
+ >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_ENABLED="gtk3"