summaryrefslogtreecommitdiff
path: root/media-plugins/gst-plugins-gtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /media-plugins/gst-plugins-gtk
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'media-plugins/gst-plugins-gtk')
-rw-r--r--media-plugins/gst-plugins-gtk/Manifest2
-rw-r--r--media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gtk/Manifest b/media-plugins/gst-plugins-gtk/Manifest
index 7d468d2741ca..6d6c9da6e6e6 100644
--- a/media-plugins/gst-plugins-gtk/Manifest
+++ b/media-plugins/gst-plugins-gtk/Manifest
@@ -1,3 +1,5 @@
DIST gst-plugins-good-1.14.5.tar.xz 3800104 BLAKE2B acb8ba559c8f4d96cb548fa05e88a556dbfd3aed8572d91cee4fc7b652ab1e814a615713f1372a0acdaa723ddf2d9af9c84c599bc4128b8f61d03bfbc096dcce SHA512 11bfadaf39b28a0a6a6c87c4ade8513496e8f13873cb0c2ddc8b8241029b8775d4839f2de441bda664bc67c66c4ca1d6839dd7570f7d79c1f485d5a25cc9d236
+DIST gst-plugins-good-1.16.2.tar.xz 3897172 BLAKE2B b6341bb2f2456e2c558f71e9f18726eced88cbc703fa017067415297cc7ccdf70b4ceb18e9e3c7c64fc7c55806c7373d9a05eac582067ab764a02c1bafef4b33 SHA512 ab0dfd51af3ea345db466618547c35c78b5f08e725096b66074a5a7e0a83ca25ac51d2d915b7a8c07b70f8e4c9fc65d51c1851f147a5a5a71fbca58e1eb5ffd4
EBUILD gst-plugins-gtk-1.14.5.ebuild 1178 BLAKE2B 291fe2e131bee9c2f07d9af09fbab28a182bbc1829d57484fad0b4e53f3521af3d0a33d559d5b5367ded88411322d6f729d83837bb1ae825b4b2fe2bd8fb85ad SHA512 99409d7214bbf4587c850bebe5a079f0983be00a6e86d6fd65ff57dda1431c97eada97557ab0a8c83b564eef8a45c72edfeee8e406668d2f4d9aaf6c4d439133
+EBUILD gst-plugins-gtk-1.16.2.ebuild 1185 BLAKE2B 210ebc7fcf7551da499b8a349a578d7c46ffc3f115bf1d330ae859db29852c614fc13b91a1ae27449a8432c53a07c503159ac4ed87dda5819c0346d627436d12 SHA512 389c7ae50a0a5771c6d8a9ba3a1ec09dc70af61022610dfd52b0e6070d0e012ce4515b5c474fa1daee17324895fb60d924a60183bb4cd6d2a8ea1ea7c46e266d
MISC metadata.xml 790 BLAKE2B 609210afdad563f5d63ea609ac6a65301907d447a137537aa9451ce6bf5774f9a15a8294a4e11b72697e123a4ffac44cefa5f6cf820a78bd998cd581e7ec720b SHA512 8ca80354a5c57ccbc941bc62cd7fc1b3bfbd2223901c24afac0ade01ab751e790cf9bafc4e0d4a3074606be99ac7aae10a45a9f7c65068342495f2995c956fa5
diff --git a/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild
new file mode 100644
index 000000000000..1b37803b64ac
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer
+
+DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+egl gles2 +opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
+# egl, wayland and X only matters if gst-plugins-base is built with USE=opengl and/or USE=gles2
+# We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
+# we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
+# gst-plugins-base, but no way to express that.
+
+# We only need gtk+ matching backend flags when GL is enabled
+GL_DEPS="
+ >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
+ >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_BUILD="gtk3"