summaryrefslogtreecommitdiff
path: root/media-plugins/gst-plugins-gtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /media-plugins/gst-plugins-gtk
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'media-plugins/gst-plugins-gtk')
-rw-r--r--media-plugins/gst-plugins-gtk/Manifest2
-rw-r--r--media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.3.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gtk/Manifest b/media-plugins/gst-plugins-gtk/Manifest
index a427216fc128..383355172613 100644
--- a/media-plugins/gst-plugins-gtk/Manifest
+++ b/media-plugins/gst-plugins-gtk/Manifest
@@ -1,5 +1,7 @@
DIST gst-plugins-good-1.14.5.tar.xz 3800104 BLAKE2B acb8ba559c8f4d96cb548fa05e88a556dbfd3aed8572d91cee4fc7b652ab1e814a615713f1372a0acdaa723ddf2d9af9c84c599bc4128b8f61d03bfbc096dcce SHA512 11bfadaf39b28a0a6a6c87c4ade8513496e8f13873cb0c2ddc8b8241029b8775d4839f2de441bda664bc67c66c4ca1d6839dd7570f7d79c1f485d5a25cc9d236
DIST gst-plugins-good-1.16.2.tar.xz 3897172 BLAKE2B b6341bb2f2456e2c558f71e9f18726eced88cbc703fa017067415297cc7ccdf70b4ceb18e9e3c7c64fc7c55806c7373d9a05eac582067ab764a02c1bafef4b33 SHA512 ab0dfd51af3ea345db466618547c35c78b5f08e725096b66074a5a7e0a83ca25ac51d2d915b7a8c07b70f8e4c9fc65d51c1851f147a5a5a71fbca58e1eb5ffd4
+DIST gst-plugins-good-1.16.3.tar.xz 3914676 BLAKE2B 52f18027f9d9a77e8b459a0a10fa7c1450dff2faf8a2a63134f833ad08b19985b7f0d3d2af4b766c9b8bf802d048fabd6f52ad5a7865eccd1fe0d26404b7b2de SHA512 3e0da4a4defc0ddea1c26dfc767fed732548654f4155452649777109a17d5b65b2fde895483a3e35dc1646de5a16e913cd2408f826251d46a99b7751b88dcb65
EBUILD gst-plugins-gtk-1.14.5.ebuild 1178 BLAKE2B 291fe2e131bee9c2f07d9af09fbab28a182bbc1829d57484fad0b4e53f3521af3d0a33d559d5b5367ded88411322d6f729d83837bb1ae825b4b2fe2bd8fb85ad SHA512 99409d7214bbf4587c850bebe5a079f0983be00a6e86d6fd65ff57dda1431c97eada97557ab0a8c83b564eef8a45c72edfeee8e406668d2f4d9aaf6c4d439133
EBUILD gst-plugins-gtk-1.16.2.ebuild 1179 BLAKE2B 655be3d08d6b5da6654edd563528890f502c6172bd8d9cf319ef658c663b192347e2654c059b6acd3c877bdaf520f0d38ba6a720025851d907bc7e909dfc3684 SHA512 0d7dfb6ffef393367c367e928117cd93118e46c3bb94ba681c868b59046a1af0f7c168fe58ead0e09cf006cc550ef56905d1dc276a8db78f28c337310c1f0011
+EBUILD gst-plugins-gtk-1.16.3.ebuild 1185 BLAKE2B 132bea44a20e3e4cdd801225a4741e9acf161cfffffff0721bc5a30b30cdef3d3e1bb611362bc77089d7027c22b3f1a721aaff5d03c2a07c9b900270eef44f73 SHA512 2cf14c9109bbc21e76ceee79daefc8c084fa24cab09c0dc6f71c33caaec866c0e1e64aa233f60b60781790fe03e16bf2b958e602f0373e25907933a939061090
MISC metadata.xml 790 BLAKE2B 609210afdad563f5d63ea609ac6a65301907d447a137537aa9451ce6bf5774f9a15a8294a4e11b72697e123a4ffac44cefa5f6cf820a78bd998cd581e7ec720b SHA512 8ca80354a5c57ccbc941bc62cd7fc1b3bfbd2223901c24afac0ade01ab751e790cf9bafc4e0d4a3074606be99ac7aae10a45a9f7c65068342495f2995c956fa5
diff --git a/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.3.ebuild b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.3.ebuild
new file mode 100644
index 000000000000..9fdf00d8fdce
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer
+
+DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+egl gles2 +opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
+# egl, wayland and X only matters if gst-plugins-base is built with USE=opengl and/or USE=gles2
+# We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
+# we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
+# gst-plugins-base, but no way to express that.
+
+# We only need gtk+ matching backend flags when GL is enabled
+GL_DEPS="
+ >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
+ >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_BUILD="gtk3"