summaryrefslogtreecommitdiff
path: root/media-plugins/gst-plugins-gtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-26 20:52:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-26 20:52:48 +0100
commit0e83ee97d831abe38c8e764fb9bbfef9de04daf2 (patch)
treefca9d00e42cd967e466d66fd8d23d3bcee39cf75 /media-plugins/gst-plugins-gtk
parentc3d998909264b1ff687b9c65cae3046443e66f7e (diff)
gentoo auto-resync : 26:08:2022 - 20:52:47
Diffstat (limited to 'media-plugins/gst-plugins-gtk')
-rw-r--r--media-plugins/gst-plugins-gtk/Manifest2
-rw-r--r--media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.20.3.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gtk/Manifest b/media-plugins/gst-plugins-gtk/Manifest
index a9206f7ed2ef..2c19aa945d2b 100644
--- a/media-plugins/gst-plugins-gtk/Manifest
+++ b/media-plugins/gst-plugins-gtk/Manifest
@@ -1,3 +1,5 @@
DIST gst-plugins-good-1.20.2.tar.xz 3411008 BLAKE2B 45eb497d240bf9b05cfbf85babe5ef85fb8a7f25f1b470f131f319064e1dc04f334d4b7dede4f0aedd73dca01605b7e00e2ddc587bcf9ccce6989a9e99776cb1 SHA512 a10ea48fdfbe741e9bc63036b011748558f89968aaa525380ac99884c27463d190c0b49e2d98b4f554eee6ead8a5c5da3ba62e5b0b1fe54877598beccc68a933
+DIST gst-plugins-good-1.20.3.tar.xz 3417252 BLAKE2B 5f288541598d2c308fbb1d5e36e54e8dd4c6e9d7dd71f41b778fbdfe883ed48e8d13fa53d05518cc671de029d804f7dc1d93396de9d199d45ec131230926d33c SHA512 98bb2dd428edaa1a5846fb47b1f42a1e99541faf05cdb0fb632d4a1a1e4fb2c1f9d1229bf0aa2ddcbce139533e9fd51f8f9a1175cd8a8729c5179750ca84afa1
EBUILD gst-plugins-gtk-1.20.2.ebuild 1194 BLAKE2B 8a5ee3cd880b7981c90a9a008dbc69168ee98a82f2d503e42621d7930123de7a8bef837e2cbcdf86b62b3b9a1c85f339080fa0085ffe44d45b574fd8b86f1f69 SHA512 89645882f0c7108c4de271cc9da85aaef5d9bbd1fa59f0db8b4da0c5aa919db2a52d46ca855769dfe48d3dfff51d391d29133ca0c95052423701d7a391204acd
+EBUILD gst-plugins-gtk-1.20.3.ebuild 1200 BLAKE2B 07d7d3e0b3c1e8f44d1d01b44949fb629a09b6a18ed80c0630afb1bea68dc584cc5984915618354d51354938b8d0c105a76746602f701a3dc1294b554d15b1b5 SHA512 d0e4b8982729218df949e404477414fdb90f91ab751f4e77d7e82ac2f0baf147eeea195c7876df05462d1addf915e5d7cc0bbf312b05078f520fd7518521d88e
MISC metadata.xml 791 BLAKE2B 5926a04f19bd8076a5c37efa479a13d2399c230295ff231cf6b16c2ba26da2d5082045ace8e27022618c9f2cf31bef986d664b3d9a795e029492f95ff000eb54 SHA512 b4caabc1551bb36f4c4e8edf70a88716ceeff90309b0268d7db59aa0fe8f4aa02ec3eb26d4cefcd0fdaaf8951c77c2cea57396d7ba0d30955de4db70e2200589
diff --git a/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.20.3.ebuild b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.20.3.ebuild
new file mode 100644
index 000000000000..66b7e2346549
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.20.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer-meson
+
+DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+egl gles2 +opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
+# egl, wayland and X only matters if gst-plugins-base is built with USE=opengl and/or USE=gles2
+# We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
+# we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
+# gst-plugins-base, but no way to express that.
+
+# We only need gtk+ matching backend flags when GL is enabled
+GL_DEPS="
+ >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
+ >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_ENABLED="gtk3"