summaryrefslogtreecommitdiff
path: root/media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
commit423d21dcfee183cc4b04d29c1621615e8c30f834 (patch)
tree23bd6110b9a77b8d679b5ab60fb7663b8627f698 /media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild
parent81e4fbcb846ed1cabdad699c0029b166dd7273b7 (diff)
gentoo resync : 04.01.2018
Diffstat (limited to 'media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild')
-rw-r--r--media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild b/media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild
index 1f1c70e1436e..d99728d90df6 100644
--- a/media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild
+++ b/media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
+EAPI=6
DESCRIPTION="This plugin calls ogg123 and points it at mpd's shoutstream"
HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_SHOUT"
@@ -12,22 +12,23 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="nls"
-RDEPEND=">=media-sound/gmpc-${PV}
+RDEPEND="
+ >=media-sound/gmpc-${PV}
media-sound/vorbis-tools[ogg123]
- dev-libs/libxml2
- x11-libs/cairo"
+ dev-libs/libxml2:=
+ x11-libs/cairo:="
DEPEND="${RDEPEND}
virtual/pkgconfig
- nls? ( dev-util/intltool
- sys-devel/gettext )"
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
src_configure() {
- econf \
- --disable-dependency-tracking \
- $(use_enable nls)
+ econf $(use_enable nls)
}
src_install() {
- emake DESTDIR="${D}" install || die
- find "${ED}" -name "*.la" -delete || die
+ default
+ find "${D}" -name '*.la' -delete || die
}