summaryrefslogtreecommitdiff
path: root/media-plugins/ams-lv2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
commitf6a034d922bf54efeaa781fcb5388b325b90d945 (patch)
treeb9fafda6cf44bf7b09de2c3d74090de10f9cde04 /media-plugins/ams-lv2
parent007b0aae027279095b8605c214b535e59df8f6eb (diff)
gentoo auto-resync : 03:05:2023 - 11:25:06
Diffstat (limited to 'media-plugins/ams-lv2')
-rw-r--r--media-plugins/ams-lv2/Manifest3
-rw-r--r--media-plugins/ams-lv2/ams-lv2-1.2.2-r1.ebuild6
-rw-r--r--media-plugins/ams-lv2/files/ams-lv2-1.2.2-wscript.patch22
3 files changed, 28 insertions, 3 deletions
diff --git a/media-plugins/ams-lv2/Manifest b/media-plugins/ams-lv2/Manifest
index f6f61c0a25ef..004ae1aff513 100644
--- a/media-plugins/ams-lv2/Manifest
+++ b/media-plugins/ams-lv2/Manifest
@@ -1,3 +1,4 @@
+AUX ams-lv2-1.2.2-wscript.patch 662 BLAKE2B 54d7fe6329a3201df239ece6f0e9de6a112a72981b02e4fc576fef9935850296001ee106ae213e09924a42f9564042e5a6d802dad161b993ab4477af15a09d18 SHA512 7c60e0997d258438ad04bc5e8bfe9e1fe1f66128d2cb69ba13d2a58988270c36332b4aab8e6e0744d2f7fd521c164f66426e7afbaa2de8942acbacf912a553f0
DIST ams-lv2-1.2.2.tar.gz 488234 BLAKE2B 1dfeaa2708bda64aadb00d8ec5f57fd3a7dd35a1fdce5fb2289f52f00fd73d25a11f39c91823c9322a5cd625ff369c4b05fd9de300b1635e172aefabb02825ea SHA512 6c1c6f3179a851f67e162d225a761c38678159d9f178d9bfa3991b84b84ea557f5a44882ea710626204f158c40ae18f0e87f24faec0a0bd6aa64e18eeb81c45f
-EBUILD ams-lv2-1.2.2-r1.ebuild 760 BLAKE2B ca3e47f6dfbb9d772b30db0867db7d9d35a9d81ba1a78a45d45f474d6eae87f4a9f47e8681b79ebaac15beff8f4c7e0882f769762a6d6a2800d92be8a680770d SHA512 027dbf6ece89c9ac2e58242b1a82a03440c4cf1005ac39b0b338253804ba71931840e47148530db027967d2d7a6facf971cf96125ae760790593efd711e60554
+EBUILD ams-lv2-1.2.2-r1.ebuild 802 BLAKE2B c7bdb8fddc733633def6700c17ed321d5685e33582dc400c7f0977422e9c853e2233c02984beb170f177fc8f0e2b87bc5b1575bced6654f4daa9496055269bc5 SHA512 69abfdb158a6b65d397008aa0ec22e9be941977fbf7bc735f163267ae3ef5ba2b7a9f9c43add1d9423168c9c19ac4209363f89845bbec5f7975ef8e57117b7a4
MISC metadata.xml 351 BLAKE2B 248d596a21a4a64360817bf3858379b642372928e718123042882cd9888fd0b08b697209d3bb4351488e086d7c957411feaf9f9a5fae60cda2face90202de02c SHA512 20760d1e76dec5beff0f044a357f2a40ea84f1246b211b9e48d3d0449b57abaedbd273f83f91a0f3bc52f3ff10734094707505e870bec59799c11a44315cf357
diff --git a/media-plugins/ams-lv2/ams-lv2-1.2.2-r1.ebuild b/media-plugins/ams-lv2/ams-lv2-1.2.2-r1.ebuild
index d19fa5cdba04..4c4d78535a74 100644
--- a/media-plugins/ams-lv2/ams-lv2-1.2.2-r1.ebuild
+++ b/media-plugins/ams-lv2/ams-lv2-1.2.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# version 1.2.2 does not compile with python 3.11
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="threads(+)"
inherit waf-utils python-any-r1
@@ -28,3 +28,5 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( LICENSE README.md THANKS )
+
+PATCHES="${FILESDIR}/${P}-wscript.patch"
diff --git a/media-plugins/ams-lv2/files/ams-lv2-1.2.2-wscript.patch b/media-plugins/ams-lv2/files/ams-lv2-1.2.2-wscript.patch
new file mode 100644
index 000000000000..5fd4fd7857f5
--- /dev/null
+++ b/media-plugins/ams-lv2/files/ams-lv2-1.2.2-wscript.patch
@@ -0,0 +1,22 @@
+--- a/waflib/ConfigSet.py
++++ b/waflib/ConfigSet.py
+@@ -312,7 +312,7 @@ class ConfigSet(object):
+ :type filename: string
+ """
+ tbl = self.table
+- code = Utils.readf(filename, m='rU')
++ code = Utils.readf(filename, m='r')
+ for m in re_imp.finditer(code):
+ g = m.group
+ tbl[g(2)] = eval(g(3))
+--- a/waflib/Context.py
++++ b/waflib/Context.py
+@@ -662,7 +662,7 @@ def load_module(path, encoding=None):
+
+ module = imp.new_module(WSCRIPT_FILE)
+ try:
+- code = Utils.readf(path, m='rU', encoding=encoding)
++ code = Utils.readf(path, m='r', encoding=encoding)
+ except EnvironmentError:
+ raise Errors.WafError('Could not read the file %r' % path)
+