summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-06 22:33:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-06 22:33:57 +0100
commitc4b3d05f2d4415c0d6f135a3ea0d2055d6e055b5 (patch)
tree3ed89f0ec34cf85a0c06c027a6889e7890e08db6 /media-libs
parent8965d348ad07c326c8e17e3137c151bcc98b0a53 (diff)
gentoo auto-resync : 06:09:2022 - 22:33:57
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/Manifest.gzbin65975 -> 65970 bytes
-rw-r--r--media-libs/mesa/Manifest2
-rw-r--r--media-libs/mesa/mesa-9999.ebuild30
3 files changed, 22 insertions, 10 deletions
diff --git a/media-libs/Manifest.gz b/media-libs/Manifest.gz
index 5ffa4f02860b..0d9d5f2cfc25 100644
--- a/media-libs/Manifest.gz
+++ b/media-libs/Manifest.gz
Binary files differ
diff --git a/media-libs/mesa/Manifest b/media-libs/mesa/Manifest
index d1bb39fe7339..76063ad48141 100644
--- a/media-libs/mesa/Manifest
+++ b/media-libs/mesa/Manifest
@@ -2,5 +2,5 @@ DIST mesa-22.1.3.tar.xz 16016520 BLAKE2B 3f9838022914b4ecc8882bc648bdd99a81aab2c
DIST mesa-22.1.7.tar.xz 16109944 BLAKE2B 0d4724068eff0ad242e81808ff94b73e1b5da810d27706b5a594ad77875b54562db6d9f752b61bcfff773b26bbc64b751d4dd13cfa256106d3114377ea668d26 SHA512 447e87359445edce231761d94b316b2aa20e9ab58e4b59d75cbb1696dd0900e7164c32bebc3b75700b4070570b456f7a8cf0914181371754a52427d34e4b9120
EBUILD mesa-22.1.3.ebuild 12075 BLAKE2B fca03cd409af59496d249409f5b7484669e5226fc299da198b71c4d43d626a94006ebac18d2354593e0385e02e7f16514f3603fd96923b719489293856ab2e82 SHA512 cfa5cbf4dfdcdc9d00ba2bada8a3f7e7ecae704f92a0fe63b116f898023977e817c65554adb8d9973899e822eba6d24305e0eafb79f18fc2b38ae419b456c61a
EBUILD mesa-22.1.7.ebuild 12043 BLAKE2B 2c84c59bb325ae48c615f4bcf9383b7e02436221bd1fd189753ca804a7c57a85c54ac99289f52d1fdd01170e17b3301488ad7ebd535f747bc57be86f57c6276d SHA512 d91bfae247e8cf49e0a1a0d4cf821955eef4c5094c595848adbad28ef6127251601e7ccdcef041a4986d8d097094710f530d2244d17a9ea930543e0f2dc4214f
-EBUILD mesa-9999.ebuild 12152 BLAKE2B c8c46b10699c28cc48a061f088aa99a24b1a943361a5ef794bad0a2575218d79b915c97e25da7a788fbba1553b389d70eb2d5acfd7890621c63c63318459fd3f SHA512 bebc380d05050a8cc072f28c96f008d4454d7614b56f371d6d6a389b4d30189ff84d11f7b1258932b83c6a7aaf21a7d44feb8e8b18b6ee0459620cd5594755bd
+EBUILD mesa-9999.ebuild 12595 BLAKE2B db72258d28521bc716ab1da55de70956fd19fe9827c96ffef27b12279699767ec2673329334fb394289271b4553c8d4dcaf5c3476c19cb3f497d7f532b71bc62 SHA512 4326c6489b152a0d61e1bfb689fc11bdd4f0fcfb7ba2f17bb5ab3ce8b30b41f30c7b6bd657b1ad8c85685b4545c953ae4c195f93787d1a59f5a103eaf7a891b4
MISC metadata.xml 1649 BLAKE2B dbbaf2c16c29d6b75e272a403f59f943047fc6d19361b289d7a31bffeeed73d7ee6b16acb4a481b8e647b807fd3b4a7354092a52cc55edccb722180eae124370 SHA512 e0f05c43af12b12142eb4fa08b4e5a103bc160554836d614aaa56928b41d5f7160dd1e89e78d54df6ee6e3bb0e4d9d7667402af3dd2e7051e09b17506caf7985
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 379fc0756847..830e5bfd10f3 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -25,7 +25,7 @@ SLOT="0"
RESTRICT="!test? ( test )"
RADEON_CARDS="r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} freedreno intel lima nouveau panfrost v3d vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel lima nouveau panfrost v3d vc4 virgl vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -176,6 +176,7 @@ RDEPEND="${RDEPEND}
unset {LLVM,CLANG}_DEPSTR{,_AMDGPU}
DEPEND="${RDEPEND}
+ video_cards_d3d12? ( dev-util/directx-headers[${MULTILIB_USEDEP}] )
valgrind? ( dev-util/valgrind )
wayland? ( >=dev-libs/wayland-protocols-1.24 )
X? (
@@ -223,11 +224,12 @@ llvm_check_deps() {
pkg_pretend() {
if use vulkan; then
- if ! use video_cards_freedreno &&
+ if ! use video_cards_d3d12 &&
+ ! use video_cards_freedreno &&
! use video_cards_intel &&
! use video_cards_radeonsi &&
! use video_cards_v3d; then
- ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain freedreno, intel, radeonsi, or v3d"
+ ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain d3d12, freedreno, intel, radeonsi, or v3d"
fi
fi
@@ -239,19 +241,21 @@ pkg_pretend() {
fi
if use vaapi; then
- if ! use video_cards_r600 &&
+ if ! use video_cards_d3d12 &&
+ ! use video_cards_r600 &&
! use video_cards_radeonsi &&
! use video_cards_nouveau; then
- ewarn "Ignoring USE=vaapi since VIDEO_CARDS does not contain r600, radeonsi, or nouveau"
+ ewarn "Ignoring USE=vaapi since VIDEO_CARDS does not contain d3d12, r600, radeonsi, or nouveau"
fi
fi
if use vdpau; then
- if ! use video_cards_r300 &&
+ if ! use video_cards_d3d12 &&
+ ! use video_cards_r300 &&
! use video_cards_r600 &&
! use video_cards_radeonsi &&
! use video_cards_nouveau; then
- ewarn "Ignoring USE=vdpau since VIDEO_CARDS does not contain r300, r600, radeonsi, or nouveau"
+ ewarn "Ignoring USE=vdpau since VIDEO_CARDS does not contain d3d12, r300, r600, radeonsi, or nouveau"
fi
fi
@@ -329,7 +333,8 @@ multilib_src_configure() {
emesonargs+=(-Dgallium-nine=false)
fi
- if use video_cards_r600 ||
+ if use video_cards_d3d12 ||
+ use video_cards_r600 ||
use video_cards_radeonsi ||
use video_cards_nouveau; then
emesonargs+=($(meson_feature vaapi gallium-va))
@@ -338,7 +343,12 @@ multilib_src_configure() {
emesonargs+=(-Dgallium-va=disabled)
fi
- if use video_cards_r300 ||
+ if use video_cards_d3d12; then
+ emesonargs+=($(meson_feature vaapi gallium-d3d12-video))
+ fi
+
+ if use video_cards_d3d12 ||
+ use video_cards_r300 ||
use video_cards_r600 ||
use video_cards_radeonsi ||
use video_cards_nouveau; then
@@ -375,6 +385,7 @@ multilib_src_configure() {
gallium_enable video_cards_freedreno freedreno
gallium_enable video_cards_intel crocus i915 iris
gallium_enable video_cards_lima lima
+ gallium_enable video_cards_d3d12 d3d12
gallium_enable video_cards_nouveau nouveau
gallium_enable video_cards_panfrost panfrost
gallium_enable video_cards_v3d v3d
@@ -400,6 +411,7 @@ multilib_src_configure() {
if use vulkan; then
vulkan_enable video_cards_freedreno freedreno
vulkan_enable video_cards_intel intel
+ vulkan_enable video_cards_d3d12 microsoft-experimental
vulkan_enable video_cards_radeonsi amd
vulkan_enable video_cards_v3d broadcom
fi