summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-18 18:58:09 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-18 18:58:09 +0000
commit6ec19c7f1bc4aa70e5f8a86cd29d579a95d97035 (patch)
tree860348d8573f52d9ddf8a87c31099b8bb3a04806 /media-libs
parent1118729405d206538433388e0a8bd578f7ae7303 (diff)
gentoo resync : 18.01.2020
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libglvnd/files/libglvnd-1.3.0-tests-Add-_GLOBAL_OFFSET_TABLE_-to-PLATFORM_SYMBOLS.patch28
-rw-r--r--media-libs/rlottie/rlottie-0.0.1_pre20200110.ebuild39
2 files changed, 67 insertions, 0 deletions
diff --git a/media-libs/libglvnd/files/libglvnd-1.3.0-tests-Add-_GLOBAL_OFFSET_TABLE_-to-PLATFORM_SYMBOLS.patch b/media-libs/libglvnd/files/libglvnd-1.3.0-tests-Add-_GLOBAL_OFFSET_TABLE_-to-PLATFORM_SYMBOLS.patch
new file mode 100644
index 000000000000..f3492462ddb7
--- /dev/null
+++ b/media-libs/libglvnd/files/libglvnd-1.3.0-tests-Add-_GLOBAL_OFFSET_TABLE_-to-PLATFORM_SYMBOLS.patch
@@ -0,0 +1,28 @@
+From a322bd006c5e505a1a2406828211736a93c99924 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Wed, 15 Jan 2020 19:21:02 -0800
+Subject: [PATCH] tests: Add _GLOBAL_OFFSET_TABLE_ to PLATFORM_SYMBOLS
+
+On PA-RISC, the _GLOBAL_OFFSET_TABLE_ symbol is always exposed. See
+
+https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=blob;f=bfd/elf32-hppa.c;h=2e653083ce05a77b3e33c056e2f9a51b327c2b22#l1001
+https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=blob;f=sysdeps/hppa/dl-machine.h;h=9e98366ea3b09612d54a3e956d5c35c1bdc86560#l80
+---
+ bin/symbols-check.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/bin/symbols-check.py b/bin/symbols-check.py
+index 1c028e4..1548638 100644
+--- a/bin/symbols-check.py
++++ b/bin/symbols-check.py
+@@ -30,6 +30,7 @@ import subprocess
+
+ # This list contains symbols that _might_ be exported for some platforms
+ PLATFORM_SYMBOLS = [
++ '_GLOBAL_OFFSET_TABLE_',
+ '__bss_end__',
+ '__bss_start__',
+ '__bss_start',
+--
+2.24.1
+
diff --git a/media-libs/rlottie/rlottie-0.0.1_pre20200110.ebuild b/media-libs/rlottie/rlottie-0.0.1_pre20200110.ebuild
new file mode 100644
index 000000000000..50f5ab3f029d
--- /dev/null
+++ b/media-libs/rlottie/rlottie-0.0.1_pre20200110.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+MY_COMMIT="f6fc61f214945ac9961ba49fdfc9a3d3336e999b"
+
+DESCRIPTION="A platform independent standalone library that plays Lottie Animations"
+HOMEPAGE="https://www.tizen.org/ https://github.com/Samsung/rlottie"
+SRC_URI="https://github.com/Samsung/rlottie/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD FTL JSON LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+
+S="${WORKDIR}/rlottie-${MY_COMMIT}"
+
+PATCHES=( "${FILESDIR}"/rlottie-0.0.1_pre20190920-disable-werror.patch )
+
+src_configure() {
+ local emesonargs=(
+ -D example=false
+ $(meson_use test)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die "Failed to switch into BUILD_DIR."
+ eninja test
+}