summaryrefslogtreecommitdiff
path: root/media-libs/zxing-cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /media-libs/zxing-cpp
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'media-libs/zxing-cpp')
-rw-r--r--media-libs/zxing-cpp/Manifest3
-rw-r--r--media-libs/zxing-cpp/files/zxing-cpp-1.1.1-gcc11.patch22
-rw-r--r--media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild4
3 files changed, 27 insertions, 2 deletions
diff --git a/media-libs/zxing-cpp/Manifest b/media-libs/zxing-cpp/Manifest
index 9370551c35c1..7c1adbcb910b 100644
--- a/media-libs/zxing-cpp/Manifest
+++ b/media-libs/zxing-cpp/Manifest
@@ -1,3 +1,4 @@
+AUX zxing-cpp-1.1.1-gcc11.patch 612 BLAKE2B 661ce79b9d44667225b33480c2dcabeaa771acb35a8b908c76ca78571f360576c36889c1629a3eb22af316fcedbaece3a68713a39f3d6a8ec17f34d09ec19b0f SHA512 647f862468764b902fe7204c304e1e2d838efcfa226468027662942a7a6286dfdf5884bfae6d4f14e325d13ba40a20671a3ba72ec46db4417b451654c2806a09
DIST zxing-cpp-1.1.1.tar.gz 128925736 BLAKE2B d2d6b4b13c26ee1bf8c9f1188809207f895d9ab4bde83e7e06d85d7105c56021bb9f82f34b9f11e1c8ff5b82825de127d1bc873745fa6ef603a8d206f3eaedec SHA512 c7d97df147602e31e58eede54413814378895e9710cf266de984b22965a9a3f4c67648a0bf936a8bc8b213b45def59d1e5b34d6ce516265333dd2c0430554dc7
-EBUILD zxing-cpp-1.1.1.ebuild 581 BLAKE2B d8f997530e0fece0dc6f2e20bd1c7237e8c7d9fbb83e022a944546142cf4c4f1b8a82f74f1387ec57db065ff0280aeb68f2b27824cc4052e2a217d1825c7fc1d SHA512 4fbb4435837c59c75bcd075cd83304a405dc578d6e06414404a9c1a5ea2bf59e00320c0674158f3f16b37d2ae13f5800f1324a944fabe9703c86e2c65bfd6336
+EBUILD zxing-cpp-1.1.1.ebuild 625 BLAKE2B 460b22d28d1458b4affdb2be9e4b5cd71b849eabecbd05fbb0c486117bc5836fa73e05ee2895b701c2775155f9d1746085f522ced874f1f9c5a55a3fe650bc6a SHA512 73532b0a7fe4f8dc31b24d45cf173de9284c92344dae15981fdb9c0575acdb8f7da42cd640323a56f38ed3a27dd9012118d88b3bfa2a08782a35d3ab0044bd4a
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/media-libs/zxing-cpp/files/zxing-cpp-1.1.1-gcc11.patch b/media-libs/zxing-cpp/files/zxing-cpp-1.1.1-gcc11.patch
new file mode 100644
index 000000000000..13adad906c0d
--- /dev/null
+++ b/media-libs/zxing-cpp/files/zxing-cpp-1.1.1-gcc11.patch
@@ -0,0 +1,22 @@
+From 427e814ebcfd2e55e1c18531b7e4aa9d6a1ca6fc Mon Sep 17 00:00:00 2001
+From: Christophe Giboudeaux <christophe@krop.fr>
+Date: Tue, 9 Feb 2021 09:28:23 +0100
+Subject: [PATCH] Fix build with GCC 11
+
+Starting with GCC 11, the 'limits' header is not included transitively anymore.
+---
+ core/src/Pattern.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/core/src/Pattern.h b/core/src/Pattern.h
+index 4bbe6d26..c4a3f7c5 100644
+--- a/core/src/Pattern.h
++++ b/core/src/Pattern.h
+@@ -22,6 +22,7 @@
+ #include <cmath>
+ #include <cstddef>
+ #include <cstdint>
++#include <limits>
+ #include <numeric>
+ #include <vector>
+
diff --git a/media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild b/media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild
index a43d3881a651..3b38eb67cad9 100644
--- a/media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild
+++ b/media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,6 +16,8 @@ IUSE="test"
RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${P}-gcc11.patch" )
+
src_configure() {
local mycmakeargs=(
-DBUILD_EXAMPLES=OFF # nothing is installed