summaryrefslogtreecommitdiff
path: root/media-libs/zxing-cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 23:52:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 23:52:39 +0100
commit1b2c0d19f75523db182b267901484f87abf732cf (patch)
tree3c4832e97c3846189d07c64c2eba333bf33b8ab2 /media-libs/zxing-cpp
parentdd851ab76c56a249df7a0ec052acd90940bc014f (diff)
gentoo auto-resync : 04:10:2023 - 23:52:39
Diffstat (limited to 'media-libs/zxing-cpp')
-rw-r--r--media-libs/zxing-cpp/Manifest1
-rw-r--r--media-libs/zxing-cpp/files/zxing-cpp-2.0.0-fix-crash.patch24
2 files changed, 0 insertions, 25 deletions
diff --git a/media-libs/zxing-cpp/Manifest b/media-libs/zxing-cpp/Manifest
index a2aafce457e8..579cd0313d4e 100644
--- a/media-libs/zxing-cpp/Manifest
+++ b/media-libs/zxing-cpp/Manifest
@@ -1,4 +1,3 @@
-AUX zxing-cpp-2.0.0-fix-crash.patch 1042 BLAKE2B 30045a15717fe7d64e9f8cb9769d84fdeeaadd1baa7b47509d32c2a454cef7d16098776db1af6029875f01cd902ed1f5f20818627a296e519cfded31407914ac SHA512 7275fac1ccc230393b1fe8432a3b37c782c8e5966d324054a39f415a51052697559b87fbcfdee8d531e878847d21672a284ad4de176453267dccae33b094da30
DIST zxing-cpp-2.1.0.tar.gz 866787 BLAKE2B 2589862e790bac85cee92818381b4ec3f9eeb5ac1dc2a78babf372ad7672bfe1a43ac7cfe4cc228eabed8a6c013f835c7e3e1948137d61edf1056906a149df80 SHA512 a00778c1fb7bb664176f7035aa96db4bab3e7ca28b5be2862182cb591d18edd4c3dfcbd34b4af08e0797bb4af893299d523f98aa84d266b68e4c766410e2e26d
EBUILD zxing-cpp-2.1.0.ebuild 676 BLAKE2B ccb737a5d37d63a7e22f4c1b0f5b802c40c869bbe177a885ab309de10b7a9cfb4de3023a603263d2328fbde221ffb31d1270348dcc970b0dd03eab882ac267f0 SHA512 6534891dc23c79e264119861452791ebe1af39e7e7722fd86e95bb4c3847f3a7260871123fb0bc50de35f9e5c5cc79af169a09f9565fdfb75357fa4e24f00fdb
MISC metadata.xml 332 BLAKE2B f9f865eb6a86bdab5a5d7fe20c01e1ca84bc3977529b2826e1c6b161e31283c8108f57680442096da25a02b961f2f96a7c39458eaf62f654a56f5c17b9552ccc SHA512 f90cb5552e79b1bc3a1f17bd53b9dc756e6825beedf18c0eab5cb44c87c22b9789a19e0ebbfccb529bd935b8b842e48b335d15aab2b80e21a11ea85c1b388be5
diff --git a/media-libs/zxing-cpp/files/zxing-cpp-2.0.0-fix-crash.patch b/media-libs/zxing-cpp/files/zxing-cpp-2.0.0-fix-crash.patch
deleted file mode 100644
index e6b25633e8e9..000000000000
--- a/media-libs/zxing-cpp/files/zxing-cpp-2.0.0-fix-crash.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 23c19c5f98602a4d69d1667fff99678308b28b5b Mon Sep 17 00:00:00 2001
-From: liule <levie.liu@gmail.com>
-Date: Fri, 6 Jan 2023 22:06:24 +0800
-Subject: [PATCH] fix crash when the source image is less than 3 pixels
- width/height
-
----
- core/src/ReadBarcode.cpp | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/core/src/ReadBarcode.cpp b/core/src/ReadBarcode.cpp
-index 905dd191c..5ac61e250 100644
---- a/core/src/ReadBarcode.cpp
-+++ b/core/src/ReadBarcode.cpp
-@@ -76,7 +76,8 @@ class LumImagePyramid
-
- layers.push_back(iv);
- // TODO: if only matrix codes were considered, then using std::min would be sufficient (see #425)
-- while (threshold > 0 && std::max(layers.back().width(), layers.back().height()) > threshold)
-+ while (threshold > 0 && std::max(layers.back().width(), layers.back().height()) > threshold &&
-+ std::min(layers.back().width(), layers.back().height()) >= N)
- addLayer();
- #if 0
- // Reversing the layers means we'd start with the smallest. that can make sense if we are only looking for a