summaryrefslogtreecommitdiff
path: root/media-libs/zimg/zimg-2.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /media-libs/zimg/zimg-2.9.2.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'media-libs/zimg/zimg-2.9.2.ebuild')
-rw-r--r--media-libs/zimg/zimg-2.9.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/zimg/zimg-2.9.2.ebuild b/media-libs/zimg/zimg-2.9.2.ebuild
new file mode 100644
index 000000000000..4e92e0eec814
--- /dev/null
+++ b/media-libs/zimg/zimg-2.9.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+inherit autotools multilib-minimal
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="cpu_flags_x86_sse debug static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable debug) \
+ $(use_enable cpu_flags_x86_sse x86simd) \
+ $(use_enable static-libs static)
+}