summaryrefslogtreecommitdiff
path: root/media-libs/woff2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/woff2
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/woff2')
-rw-r--r--media-libs/woff2/Manifest1
-rw-r--r--media-libs/woff2/woff2-1.0.2-r5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/woff2/Manifest b/media-libs/woff2/Manifest
index 0a208a6f83dd..05ef2ba6ed97 100644
--- a/media-libs/woff2/Manifest
+++ b/media-libs/woff2/Manifest
@@ -1,3 +1,4 @@
DIST woff2-1.0.2.tar.gz 38934 BLAKE2B b4a762cb2377b896147d9ebdae97f17e80bdb94fa8ec1b04e28e9df48c2f3456f83fc548b10a49bbc271bead349348f7582a85c5011f60a9feb4dda84920b6f3 SHA512 c788bba1530aec463e755e901f9342f4b599e3a07f54645fef1dc388ab5d5c30625535e5dd38e9e792e04a640574baa50eeefb6b7338ab403755f4a4e0c3044d
EBUILD woff2-1.0.2-r4.ebuild 875 BLAKE2B a476d41e48546fda707c634bc66921ddb0ce26cb70634017c8ea1ec686f7c2ee575a4fdde64e19c53c5224d2b78bf91a1c96daf21d84b636307155363a5bd5b8 SHA512 c9c5d23377043fa0b99dcbdcd74a2a31491aba7f8088276ac4ee15529eb0131980d66dc97692bb71365fc2dfad0aa1e98f06ede88d3eabaacb010e52e42b8595
+EBUILD woff2-1.0.2-r5.ebuild 865 BLAKE2B bd372a9e6862ec417353d9a492999ccc742de15a6ffc5014cebfd2e6cc7cdfc75c056a226be63f8aee0f16493cdb52f481cf99b06923ca498a6256dab6478784 SHA512 d6cc4989f8e37b4c6266469e25724bfde30f9a2f8b1dda5f916f399f7ca591dede90863324cd15fb9ab91ec3fb8ccf94815e7831b1f02c1b777bc186155a3287
MISC metadata.xml 354 BLAKE2B ad57a794365a6750452e942c5570e3357d829c917f09f7d79d7cd14612d0adfe6d0dc4f0e6697a3d0ab91dbc8b4927270b7ecff99c1ca0b5f95c88d07b78d23a SHA512 c42129cdbfc646eb68afe8f1cabaefa9aacd6444a99dd469b686bea805ffe3929382ebbab79c1936d5c1b3c4709647aba751e7a73baba367687ba63f1e605afe
diff --git a/media-libs/woff2/woff2-1.0.2-r5.ebuild b/media-libs/woff2/woff2-1.0.2-r5.ebuild
new file mode 100644
index 000000000000..21a221e8d610
--- /dev/null
+++ b/media-libs/woff2/woff2-1.0.2-r5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Encode/decode WOFF2 font format"
+HOMEPAGE="https://github.com/google/woff2"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND="app-arch/brotli:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON # needed, causes QA warnings otherwise
+ -DCANONICAL_PREFIXES=ON #661942
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ dobin ${BUILD_DIR}/woff2_compress
+ dobin ${BUILD_DIR}/woff2_decompress
+ dobin ${BUILD_DIR}/woff2_info
+
+ einstalldocs
+}