summaryrefslogtreecommitdiff
path: root/media-libs/woff2/woff2-1.0.2-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /media-libs/woff2/woff2-1.0.2-r4.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'media-libs/woff2/woff2-1.0.2-r4.ebuild')
-rw-r--r--media-libs/woff2/woff2-1.0.2-r4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/woff2/woff2-1.0.2-r4.ebuild b/media-libs/woff2/woff2-1.0.2-r4.ebuild
new file mode 100644
index 000000000000..0d01c3669e73
--- /dev/null
+++ b/media-libs/woff2/woff2-1.0.2-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Encode/decode WOFF2 font format"
+HOMEPAGE="https://github.com/google/woff2"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND="app-arch/brotli:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON # needed, causes QA warnings otherwise
+ -DCANONICAL_PREFIXES=ON #661942
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dobin ${BUILD_DIR}/woff2_compress
+ dobin ${BUILD_DIR}/woff2_decompress
+ dobin ${BUILD_DIR}/woff2_info
+
+ einstalldocs
+}