summaryrefslogtreecommitdiff
path: root/media-libs/woff2/woff2-1.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /media-libs/woff2/woff2-1.0.2-r1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'media-libs/woff2/woff2-1.0.2-r1.ebuild')
-rw-r--r--media-libs/woff2/woff2-1.0.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/woff2/woff2-1.0.2-r1.ebuild b/media-libs/woff2/woff2-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..da2442b94f67
--- /dev/null
+++ b/media-libs/woff2/woff2-1.0.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Encode/decode WOFF2 font format"
+HOMEPAGE="https://github.com/google/woff2"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ia64 ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND="app-arch/brotli"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON # needed, causes QA warnings otherwise
+ -DCANONICAL_PREFIXES=ON #661942
+ )
+ cmake-utils_src_configure
+}