summaryrefslogtreecommitdiff
path: root/media-libs/waffle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
commit73c318acdaf6f8309d68bd266051e6dd1f1bd787 (patch)
tree2878053f3e7faed19a1f82c733d3bd29df69991e /media-libs/waffle
parent2018227e9344edb9da15fc6a4a8298086cc2aa77 (diff)
gentoo resync : 08.06.2019
Diffstat (limited to 'media-libs/waffle')
-rw-r--r--media-libs/waffle/Manifest4
-rw-r--r--media-libs/waffle/waffle-1.6.0.ebuild69
-rw-r--r--media-libs/waffle/waffle-9999.ebuild53
3 files changed, 106 insertions, 20 deletions
diff --git a/media-libs/waffle/Manifest b/media-libs/waffle/Manifest
index 5a64d89d9c27..1c02df166ca0 100644
--- a/media-libs/waffle/Manifest
+++ b/media-libs/waffle/Manifest
@@ -1,4 +1,6 @@
DIST waffle-1.5.2.tar.xz 179284 BLAKE2B 40befb3e4463605e303b404677268d4758f6a43f5d83bee5e74222e2e2bf949f51444c0df68291ef0edc76be313363eca3e59e642b0356451c10703e66d96e56 SHA512 04f90f70421c88418d1d98175b552de9e036ea36b6c870a6c968c7fcc2d4cb2fa4ce08b0adcdd50f4853a7503558eae7a05ef75b292cf85d3c9796e7b342ca62
+DIST waffle-1.6.0.tar.xz 224400 BLAKE2B 458add99b346bd75dc757243b9e7db6ac269fb2c1e488333d921c640e10efd182e51e8a5e0312d334593033936adf047fc2339d21e675654d89d66edfb8922b3 SHA512 c8796ab8adf968df2c5c88e2941c83955fe41e87eb2b75b6a5cc61b0d0c06eaa44df2f255f573a51816036dc8bc3ec63f3fb51ccfb7efbfe83cdd50b3f1be13f
EBUILD waffle-1.5.2.ebuild 1414 BLAKE2B a88cd403d6173d0af963f2534d9df66a1b4ff184de9fcc98f88981eaea50bb338e58c12f165d5c320eb2071e6716d1dee3b6155c6367b13586e42b6cd8b9e1f2 SHA512 d0fca799279802a5deb3e8f32e85d3d63058f96ac78c8839c91f8bd2644f0fd35ea7bba647d24a57c6723f1f36340a63c5be6de264db71b8231a3ed692f85feb
-EBUILD waffle-9999.ebuild 1417 BLAKE2B c31f5b83990c3a8ef7ae90106bbf39fc508731fded1909fbb508beb3eede5ff5cf987f97602ecaf3e22e2d37348cebe1af472d26f345a85b89cae82073721606 SHA512 4f6ecbeaf8b830dcef8d57511ff8f1856f78c75b8186c9fecd194653b0a5f4184fbce7de7cfadc84b9868324fbd995bbae78fb7215cfab7db4587b3b21619a96
+EBUILD waffle-1.6.0.ebuild 1645 BLAKE2B 3d6c0a12d5484a9b4336d56a153a811804bdebd6aca67068b42a4824c21da01f5d1796d2ba704ed23833aa1a465bdade7208a21dadc902d60158bf81373f49b3 SHA512 15b9a381dc3b869bbdce9165ecf62582b37159a78f5b082c1b9d1eb6018b8fc2c0bbc83f7986296f5a027fab4b8dbac4405d166d372a6124d69c282f6b05ceda
+EBUILD waffle-9999.ebuild 1645 BLAKE2B 3d6c0a12d5484a9b4336d56a153a811804bdebd6aca67068b42a4824c21da01f5d1796d2ba704ed23833aa1a465bdade7208a21dadc902d60158bf81373f49b3 SHA512 15b9a381dc3b869bbdce9165ecf62582b37159a78f5b082c1b9d1eb6018b8fc2c0bbc83f7986296f5a027fab4b8dbac4405d166d372a6124d69c282f6b05ceda
MISC metadata.xml 416 BLAKE2B 961afc9a4ed531bd3816c8e7b1c37a9f6be25b912d94b6f79811da67cecd8476964934b9ff943fc98be6177feee1c2eacd3295777a1d873ec1cf3cd58cf20e82 SHA512 850db93f3892afdb36d471b55e911c9cdfc114bcd69b4ce9e59246eb688b145ab5916d9529ded4b913f0cfb6da5fd2d64b7854c9501abec9fd9d860e1953100d
diff --git a/media-libs/waffle/waffle-1.6.0.ebuild b/media-libs/waffle/waffle-1.6.0.ebuild
new file mode 100644
index 000000000000..a7c32a6cf596
--- /dev/null
+++ b/media-libs/waffle/waffle-1.6.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
+ GIT_ECLASS="git-r3"
+else
+ SRC_URI="http://www.waffle-gl.org/files/release/${P}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+fi
+inherit meson multilib-minimal ${GIT_ECLASS}
+
+DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
+HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="doc egl gbm test wayland X"
+RESTRICT="test" # gl_basic tests don't work when run from portage
+
+RDEPEND="
+ >=media-libs/mesa-9.1.6[egl?,gbm?,${MULTILIB_USEDEP}]
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
+ gbm? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=x11-base/xcb-proto-1.8-r3[${MULTILIB_USEDEP}]
+ doc? (
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.2
+ )
+"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature X glx)
+ $(meson_feature wayland)
+ $(meson_feature X x11_egl)
+ $(meson_feature gbm)
+ $(meson_feature egl surfaceless_egl)
+ $(meson_use test build-tests)
+ $(meson_use doc build-manpages)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ rm -rf ${D}/usr/share/doc/waffle1
+}
diff --git a/media-libs/waffle/waffle-9999.ebuild b/media-libs/waffle/waffle-9999.ebuild
index dc2a60608875..a7c32a6cf596 100644
--- a/media-libs/waffle/waffle-9999.ebuild
+++ b/media-libs/waffle/waffle-9999.ebuild
@@ -1,23 +1,24 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/waffle-gl/${PN}.git"
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
GIT_ECLASS="git-r3"
else
- SRC_URI="https://people.freedesktop.org/~chadversary/${PN}/files/release/${P}/${P}.tar.xz"
+ SRC_URI="http://www.waffle-gl.org/files/release/${P}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
fi
-inherit cmake-multilib ${GIT_ECLASS}
+inherit meson multilib-minimal ${GIT_ECLASS}
DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
-HOMEPAGE="https://people.freedesktop.org/~chadversary/waffle/"
+HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
LICENSE="BSD-2"
SLOT="0"
-IUSE="doc egl gbm test wayland"
+IUSE="doc egl gbm test wayland X"
+RESTRICT="test" # gl_basic tests don't work when run from portage
RDEPEND="
>=media-libs/mesa-9.1.6[egl?,gbm?,${MULTILIB_USEDEP}]
@@ -35,20 +36,34 @@ DEPEND="${RDEPEND}
)
"
-src_configure() {
- local mycmakeargs=(
- -Dwaffle_has_glx=ON
- -Dwaffle_build_examples=OFF
- -Dwaffle_build_manpages=$(usex doc )
- -Dwaffle_has_x11_egl=$(usex egl)
- -Dwaffle_has_gbm=$(usex gbm)
- -Dwaffle_build_tests=$(usex test)
- -Dwaffle_has_wayland=$(usex wayland)
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature X glx)
+ $(meson_feature wayland)
+ $(meson_feature X x11_egl)
+ $(meson_feature gbm)
+ $(meson_feature egl surfaceless_egl)
+ $(meson_use test build-tests)
+ $(meson_use doc build-manpages)
)
+ meson_src_configure
+}
- cmake-multilib_src_configure
+multilib_src_compile() {
+ meson_src_compile
}
-src_test() {
- emake -C "${CMAKE_BUILD_DIR}" check
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ rm -rf ${D}/usr/share/doc/waffle1
}