summaryrefslogtreecommitdiff
path: root/media-libs/waffle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-02 19:31:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-02 19:31:55 +0000
commit7228e7507f59b8f0982c3a68cc5ba8ea35ce1a76 (patch)
treef7e1474a0d0959d82e90a68fd3b17254284207d8 /media-libs/waffle
parentdd3e3c9214bc18697f6f656e8d645d3218a26d76 (diff)
gentoo auto-resync : 02:03:2023 - 19:31:55
Diffstat (limited to 'media-libs/waffle')
-rw-r--r--media-libs/waffle/Manifest4
-rw-r--r--media-libs/waffle/waffle-1.7.1.ebuild65
-rw-r--r--media-libs/waffle/waffle-9999.ebuild5
3 files changed, 71 insertions, 3 deletions
diff --git a/media-libs/waffle/Manifest b/media-libs/waffle/Manifest
index f060f3bae33b..f47da3c05a1d 100644
--- a/media-libs/waffle/Manifest
+++ b/media-libs/waffle/Manifest
@@ -1,4 +1,6 @@
DIST waffle-v1.7.0.tar.bz2 302120 BLAKE2B 8ebfc78182ff86447d88d92edd6452dae28c1515de5f9639c402203bfb5a135bc493040941420161690a4812a202552266bceb89eee948d0c7aeae55d5b8d3d5 SHA512 ee7b8419e309387fa6d610174ba5dddda97525cef41c9600772b902eddfc4570e940437596d7fb50ee9dc2f5945e723236b61463975d2b9cc0faa150696d24c2
+DIST waffle-v1.7.1.tar.bz2 305830 BLAKE2B 8be098fa957f3d9cc84a72920e58fcee9ca4ab0b23a6d93b6cc7dfea17501448ff44a41c42f4c06ff81ef26c0041258b8709bcaf8abb4a593e8b3ac21e2085cd SHA512 e2ce6092c3088d0c4e85581700096954ab4f644e758b8639d2e9fa91771d2d964cd028361d346c9ae9c4ef185e6fc4c59acdee4480ee6ea6436f0d4bd61581a5
EBUILD waffle-1.7.0-r2.ebuild 1606 BLAKE2B e986f97e87ca173d21babe3699a5d56e41aa78c4feb94d97fe7698af76bcdf6ac505f749a5d8c3084279f126d99af1facbdb5b32e19610bbbddd8bf9b21d1f2c SHA512 51caa025dc551ac3928158f477f1241b972b664edc90f5f9278ec67255a51857b347b3a4155cdfb35d72d4da3019d9b4b37b77ab6c0d2360d7572518ac4c1eb3
-EBUILD waffle-9999.ebuild 1609 BLAKE2B 75ed4e25c0946e27fe242c2780fad24798abee77a1a17d915dd39ee1ae427dbfef4b43a1cfea566a14175cb92c07e4583a373fdd40be949246bbe60031838598 SHA512 4342070b5f68bbb227f95a0d4ca6d23891a779255096a8e7150856c4a15e3a33e2bcc802ec741b0b88d937e6278131d920e6bf5fb05b480fdc94faf118b9c630
+EBUILD waffle-1.7.1.ebuild 1635 BLAKE2B 5f02b3640bd9d836fd0c65c3123e3eb6cee2676cc3c9c480ef7153e1c8a3bb7d2aa78d5caf94450bda29293d5d91bdda83e568c6b6778289e23656f17232d7d5 SHA512 5db41db968b739b8aea3443e4b57148b5e64ab02631bfee8f67d4180e85b58246c6fcff011c8a769cfd059ce613869ba3e4fce6cd8194b3199a5fe43ce91717f
+EBUILD waffle-9999.ebuild 1635 BLAKE2B 5f02b3640bd9d836fd0c65c3123e3eb6cee2676cc3c9c480ef7153e1c8a3bb7d2aa78d5caf94450bda29293d5d91bdda83e568c6b6778289e23656f17232d7d5 SHA512 5db41db968b739b8aea3443e4b57148b5e64ab02631bfee8f67d4180e85b58246c6fcff011c8a769cfd059ce613869ba3e4fce6cd8194b3199a5fe43ce91717f
MISC metadata.xml 532 BLAKE2B c0c240a536c012ce3eb478dff1af25d8ddb0b9ce0d565df3a5a82941179c661552d3b6616c2851344a8c47c1a3b568b0f042e003e6133218be46313262f47d1f SHA512 d75a395ae334e6d3c364db676a654939560d591cae77c2ccc55d4c44474b168a9922b68c01349243a899feb0214d057c260f64a6a5029ee292cc86f6ade01906
diff --git a/media-libs/waffle/waffle-1.7.1.ebuild b/media-libs/waffle/waffle-1.7.1.ebuild
new file mode 100644
index 000000000000..968c882955b5
--- /dev/null
+++ b/media-libs/waffle/waffle-1.7.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
+ GIT_ECLASS="git-r3"
+else
+ SRC_URI="https://gitlab.freedesktop.org/mesa/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}"/${PN}-v${PV}
+fi
+inherit meson-multilib multilib ${GIT_ECLASS}
+
+DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
+HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="doc +egl +gbm wayland X"
+RESTRICT="test" # gl_basic tests don't work when run from portage
+
+RDEPEND="
+ >=media-libs/mesa-9.1.6[egl(+)?,gbm(+)?,${MULTILIB_USEDEP}]
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
+ )
+ gbm? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.10[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ X? ( >=x11-base/xcb-proto-1.8-r3 )
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ dev-util/wayland-scanner
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/wflinfo$(get_exeext)
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature X glx)
+ $(meson_feature wayland)
+ $(meson_feature X x11_egl)
+ $(meson_feature gbm)
+ $(meson_feature egl surfaceless_egl)
+ $(meson_native_true build-manpages)
+ -Dbuild-tests=false
+ )
+ meson_src_configure
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ ! use doc && rm -rf \
+ "${D}"/usr/share/doc/waffle1 \
+ "${D}"/usr/share/man/man{3,7}
+}
diff --git a/media-libs/waffle/waffle-9999.ebuild b/media-libs/waffle/waffle-9999.ebuild
index a4611e934598..968c882955b5 100644
--- a/media-libs/waffle/waffle-9999.ebuild
+++ b/media-libs/waffle/waffle-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,8 +34,9 @@ DEPEND="${RDEPEND}
X? ( >=x11-base/xcb-proto-1.8-r3 )
"
BDEPEND="
- dev-libs/libxslt
app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ dev-util/wayland-scanner
"
MULTILIB_CHOST_TOOLS=(