summaryrefslogtreecommitdiff
path: root/media-libs/waffle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-libs/waffle
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-libs/waffle')
-rw-r--r--media-libs/waffle/Manifest3
-rw-r--r--media-libs/waffle/waffle-1.7.0-r2.ebuild64
-rw-r--r--media-libs/waffle/waffle-9999.ebuild10
3 files changed, 71 insertions, 6 deletions
diff --git a/media-libs/waffle/Manifest b/media-libs/waffle/Manifest
index 64de289e7199..5317e2a98b33 100644
--- a/media-libs/waffle/Manifest
+++ b/media-libs/waffle/Manifest
@@ -1,4 +1,5 @@
DIST waffle-v1.7.0.tar.bz2 302120 BLAKE2B 8ebfc78182ff86447d88d92edd6452dae28c1515de5f9639c402203bfb5a135bc493040941420161690a4812a202552266bceb89eee948d0c7aeae55d5b8d3d5 SHA512 ee7b8419e309387fa6d610174ba5dddda97525cef41c9600772b902eddfc4570e940437596d7fb50ee9dc2f5945e723236b61463975d2b9cc0faa150696d24c2
EBUILD waffle-1.7.0-r1.ebuild 1617 BLAKE2B 76bfbd6a39f365c3e29631a7101322261e56cc3b284ba21b862dc1262009de1588a22be27941e69c74bb5a63a2ba9bb45f0bbc08c9988b7a6bc4f5b0446bfb68 SHA512 4f2c0f90cc06214379ef5a3d95fd352bbebae532c0fd005a3c06a05ded84b3f2905d53d9c2242b57b2fd8b1d05145b9520a738945348ee95c8f94504eca37d97
-EBUILD waffle-9999.ebuild 1617 BLAKE2B 76bfbd6a39f365c3e29631a7101322261e56cc3b284ba21b862dc1262009de1588a22be27941e69c74bb5a63a2ba9bb45f0bbc08c9988b7a6bc4f5b0446bfb68 SHA512 4f2c0f90cc06214379ef5a3d95fd352bbebae532c0fd005a3c06a05ded84b3f2905d53d9c2242b57b2fd8b1d05145b9520a738945348ee95c8f94504eca37d97
+EBUILD waffle-1.7.0-r2.ebuild 1609 BLAKE2B 75ed4e25c0946e27fe242c2780fad24798abee77a1a17d915dd39ee1ae427dbfef4b43a1cfea566a14175cb92c07e4583a373fdd40be949246bbe60031838598 SHA512 4342070b5f68bbb227f95a0d4ca6d23891a779255096a8e7150856c4a15e3a33e2bcc802ec741b0b88d937e6278131d920e6bf5fb05b480fdc94faf118b9c630
+EBUILD waffle-9999.ebuild 1609 BLAKE2B 75ed4e25c0946e27fe242c2780fad24798abee77a1a17d915dd39ee1ae427dbfef4b43a1cfea566a14175cb92c07e4583a373fdd40be949246bbe60031838598 SHA512 4342070b5f68bbb227f95a0d4ca6d23891a779255096a8e7150856c4a15e3a33e2bcc802ec741b0b88d937e6278131d920e6bf5fb05b480fdc94faf118b9c630
MISC metadata.xml 417 BLAKE2B 93ea54a57c011a3488ec75dbb8b93bce0bd568dfc4438cf7c80b3c622513a9be4b3e809e9794646571f9f21afd1572d0b16915dbda35d7345d4ef6afcec4dca8 SHA512 1652ef53bd20fd9c526b77db60affc226920b007c1b1b2bbeb90c0606ae2d4e199cb352a3322e2953ae0b1472e671da516ea3c0fdfcc9aa26cc5a1c348590da6
diff --git a/media-libs/waffle/waffle-1.7.0-r2.ebuild b/media-libs/waffle/waffle-1.7.0-r2.ebuild
new file mode 100644
index 000000000000..a4611e934598
--- /dev/null
+++ b/media-libs/waffle/waffle-1.7.0-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
+ GIT_ECLASS="git-r3"
+else
+ SRC_URI="https://gitlab.freedesktop.org/mesa/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}"/${PN}-v${PV}
+fi
+inherit meson-multilib multilib ${GIT_ECLASS}
+
+DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
+HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="doc +egl +gbm wayland X"
+RESTRICT="test" # gl_basic tests don't work when run from portage
+
+RDEPEND="
+ >=media-libs/mesa-9.1.6[egl(+)?,gbm(+)?,${MULTILIB_USEDEP}]
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
+ )
+ gbm? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.10[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ X? ( >=x11-base/xcb-proto-1.8-r3 )
+"
+BDEPEND="
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.2
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/wflinfo$(get_exeext)
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature X glx)
+ $(meson_feature wayland)
+ $(meson_feature X x11_egl)
+ $(meson_feature gbm)
+ $(meson_feature egl surfaceless_egl)
+ $(meson_native_true build-manpages)
+ -Dbuild-tests=false
+ )
+ meson_src_configure
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ ! use doc && rm -rf \
+ "${D}"/usr/share/doc/waffle1 \
+ "${D}"/usr/share/man/man{3,7}
+}
diff --git a/media-libs/waffle/waffle-9999.ebuild b/media-libs/waffle/waffle-9999.ebuild
index 7b4d01d42f65..a4611e934598 100644
--- a/media-libs/waffle/waffle-9999.ebuild
+++ b/media-libs/waffle/waffle-9999.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
GIT_ECLASS="git-r3"
else
SRC_URI="https://gitlab.freedesktop.org/mesa/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
- KEYWORDS="amd64 arm ~arm64 ~ppc ~ppc64 x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
S="${WORKDIR}"/${PN}-v${PV}
fi
-inherit meson-multilib ${GIT_ECLASS}
+inherit meson-multilib multilib ${GIT_ECLASS}
DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
@@ -31,7 +31,7 @@ RDEPEND="
wayland? ( >=dev-libs/wayland-1.10[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
- X? ( >=x11-base/xcb-proto-1.8-r3[${MULTILIB_USEDEP}] )
+ X? ( >=x11-base/xcb-proto-1.8-r3 )
"
BDEPEND="
dev-libs/libxslt