summaryrefslogtreecommitdiff
path: root/media-libs/volpack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-29 09:22:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-29 09:22:29 +0100
commitb94ab464dd0d948b7e7eac833b9bb51c03515918 (patch)
tree130d52181c215cd1c3eced88bc503353a99a1fe8 /media-libs/volpack
parent62ea91b40c7650011a72ed2443f76b88b06123fe (diff)
gentoo auto-resync : 29:09:2022 - 09:22:29
Diffstat (limited to 'media-libs/volpack')
-rw-r--r--media-libs/volpack/Manifest3
-rw-r--r--media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch16
-rw-r--r--media-libs/volpack/volpack-1.0_p7-r2.ebuild (renamed from media-libs/volpack/volpack-1.0_p7-r1.ebuild)33
3 files changed, 36 insertions, 16 deletions
diff --git a/media-libs/volpack/Manifest b/media-libs/volpack/Manifest
index 73db9d78084d..e96f35b795ad 100644
--- a/media-libs/volpack/Manifest
+++ b/media-libs/volpack/Manifest
@@ -1,3 +1,4 @@
+AUX volpack-1.0_p7-skip-examples.patch 305 BLAKE2B 383b32eb67383c451aa8c1732340593b90fb6e5d54d42eb1b900d70a5d15b4f9c52924051edcc64412745a08665e7af809db4ac83288a5add744e293b8ef6377 SHA512 46d68fcfdd2bbf1c817234d66d0a50ea04daecd46c865be835674753dd4705e7b733af573da45ff429f73432e76c79bf5ede266944cb3014e72e7db8f75c178a
DIST volpack-1.0c7.tgz 1218492 BLAKE2B 8aa0e76da81a3c7a5050a42b9a16780e90142c0e9318021652b86473f2832cf6f88771c8bd461457ad07c85a9bd1d7723e46c283ea66227290c54d9339abca62 SHA512 1328918bb62e81a0aa9eb26d9b0cff98081518b0fc6c3457413870bb68c793d0d9bfe42d977fa5b5a7ad110358b736ce0d0aff8825333e32e37436d9dba3114a
-EBUILD volpack-1.0_p7-r1.ebuild 688 BLAKE2B 97796ceb39dbb83a92d4153c89aa9910a2ed8d358b0586297b5217fcf26cf4e1ef9147e413c9d3ff18188f949d27a2810e560ee6e73eef003156803fc5436658 SHA512 9cd1b7752268cee4523b97eef2e45b00a8b09e31a88adbccb0228abe19e38aacce9ab571f52a26e00310ee6d55261a63a9b82ee38713bb5ba3a541044a4e7a6d
+EBUILD volpack-1.0_p7-r2.ebuild 727 BLAKE2B 0bf40bd2a8ae8c495c071f995bfc0c682c6b640924edf35aba446169c7e2d0081d02c07077a10e0f886d09b3f505af248671113566c79dbe3cc06b1e06b05742 SHA512 59bc7ef419baa6986fb02aa3bc1ffb2b1a7787d5dd5910bc374dcc2d9bce3554c43cadf24282860ad4c9433ccde386689cf3d26b0e6108a32ab1e6e04794134e
MISC metadata.xml 603 BLAKE2B 9a91539ff37b42e4dcd36373b76289ca1f427f33779bb32a2900d6b34b620443182289d0a5708505dd09e16465933439052338eb8e3d7a28d7f4ce3a993e23a2 SHA512 4fa26855d6014aec78fd2b5e444b6464991ac8c1b31244cb48fbcf893827a8ecc29b356083e928a66c07af4bc87501c275b7659f5ca0b9dec7628db0e8c6e19b
diff --git a/media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch b/media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch
new file mode 100644
index 000000000000..1476f23084f5
--- /dev/null
+++ b/media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch
@@ -0,0 +1,16 @@
+Building these is broken with clang16 and they are primarily
+intended to be looked rather rather than built.
+
+https://bugs.gentoo.org/870706
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -7,3 +7,2 @@
+ man \
+- examples \
+ doc
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -196,3 +196,2 @@
+ man \
+- examples \
+ doc
diff --git a/media-libs/volpack/volpack-1.0_p7-r1.ebuild b/media-libs/volpack/volpack-1.0_p7-r2.ebuild
index b205f54d52bd..f7076c8c6c31 100644
--- a/media-libs/volpack/volpack-1.0_p7-r1.ebuild
+++ b/media-libs/volpack/volpack-1.0_p7-r2.ebuild
@@ -1,26 +1,25 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-MYP=${PN}-${PV/_p/c}
+MY_P="${PN}-${PV/_p/c}"
DESCRIPTION="Volume rendering library"
-HOMEPAGE="http://amide.sourceforge.net/packages.html"
-SRC_URI="mirror://sourceforge/amide/${MYP}.tgz"
+HOMEPAGE="https://amide.sourceforge.net/packages.html"
+SRC_URI="mirror://sourceforge/amide/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
-DEPEND="sys-devel/m4"
+BDEPEND="sys-devel/m4"
-S="${WORKDIR}/${MYP}"
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-skip-examples.patch
+)
src_compile() {
emake -j1
@@ -28,14 +27,18 @@ src_compile() {
src_install() {
default
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
if use doc; then
dodoc doc/*.pdf
+
docinto html
dodoc doc/*.html
fi
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
+ find "${ED}" -type f -name '*.la' -delete || die
}