summaryrefslogtreecommitdiff
path: root/media-libs/vo-aacenc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /media-libs/vo-aacenc
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'media-libs/vo-aacenc')
-rw-r--r--media-libs/vo-aacenc/Manifest4
-rw-r--r--media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild55
-rw-r--r--media-libs/vo-aacenc/vo-aacenc-9999.ebuild57
3 files changed, 61 insertions, 55 deletions
diff --git a/media-libs/vo-aacenc/Manifest b/media-libs/vo-aacenc/Manifest
index 26c8e42858f2..b6cac37c21c7 100644
--- a/media-libs/vo-aacenc/Manifest
+++ b/media-libs/vo-aacenc/Manifest
@@ -1,4 +1,4 @@
DIST vo-aacenc-0.1.3.tar.gz 612463 BLAKE2B d75f497c9e0c8b0b962593787c1a13ce2bba095d1ac15c49b6b55235219b22f7c8116da12c2f1fb0bf1cb7e175d2f0ca212ae50333c0d9e0a4a5b77c71698b89 SHA512 c8f00dfa758270ba9cad35dd6e24905dc7cf33d7717454b7c2c56c40dbf54f682450aa010a410a0350d70119d2aaa2e5ba4471b5bbe05ccec1f9d20ab3e57853
-EBUILD vo-aacenc-0.1.3.ebuild 1148 BLAKE2B fa75bee9b20d90c52cd6ac7b0667c3cff6c5ea2fad26a6294d0cc83278314b87055e6ff1c80a79123250a61a9f8a01f741d736b02a24fe38ecaab8b13dc05c5e SHA512 b5263cff4478db22f02a70023ee0902594a4f2cb1a70112a7dd66fcd8a1f5b4fe41f25f7b66e445b6393380e279eccd6c13e186e47fb16c27f153620f081463a
-EBUILD vo-aacenc-9999.ebuild 1161 BLAKE2B 84778c0185a1e9149a2077a1cabd779791d9b9d314094752b89a02c24f7697f45453ae33ae65d4fcd0f144f49db7de53b096d708b07f9b493bca8fbafb7d0576 SHA512 afa103980e411ca602c59774f40c38753834336f72171a61dcf738fb1d00cf35275896f4fac4f22786064dc596c0b3aacb0405aa643eac4f671414415f88f6e8
+EBUILD vo-aacenc-0.1.3.ebuild 1083 BLAKE2B 73b3386bcd1c930c26143302517d9011fe866fab96e0103633009e89eb549ce1513c3dc65d11a99cd21a157ddff46b3c05e3bff7153b7b0c123cec9381990cd4 SHA512 592211b501e13081d909325d3c87383f61c12ad16ab8cf7f4d8d685178eeafe7442138cc09a3c3fea3be249bb91379812d0242e5d9f295cc087f7f7de4777b28
+EBUILD vo-aacenc-9999.ebuild 1093 BLAKE2B a07a4c5b73e9f8d504b3dfc0b213d462cadcce610c3e22c924fb92d08e3a8300ba34a01ffb99e5047f82513d52d145ff6b391d77d80590f0c0ed46e2ff1ed007 SHA512 896f02554a72f2c5d0a136f4dff5c95caf78ee02773590038a0cb8cb3790bfe4d60cfd3a8c216a8f9b824a0c031156a7b5b853982763baaf3fa349dbc0f891ab
MISC metadata.xml 633 BLAKE2B 965a7d171a4ced000c73cee40fc2b2c752ff988668f8906bfaa2c7721d5b328290184fc8f0c1c24a21775a5b0cc066df9457e747159b4c3ec5907d6cce4b47fa SHA512 13dcd74fb4a9f1f003a8031cbf70620871bf2e3487cff75df3ec5b413e859d541f8a336b062d8cbed561e88dac51cc19a19329c3383fa7687e047236729871d4
diff --git a/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild b/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
index 20ed3fb06f70..7511d4823b83 100644
--- a/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
+++ b/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
@@ -1,42 +1,45 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-if [[ ${PV} == *9999 ]] ; then
- SCM="git-2"
+inherit flag-o-matic multilib-minimal
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
EGIT_REPO_URI="https://github.com/mstorsjo/${PN}.git"
- [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
- AUTOTOOLS_AUTORECONF=yes
+else
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
fi
-inherit autotools-multilib flag-o-matic ${SCM}
-
DESCRIPTION="VisualOn AAC encoder library"
HOMEPAGE="https://sourceforge.net/projects/opencore-amr/"
-if [[ ${PV} == *9999 ]] ; then
- SRC_URI=""
-elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
- SRC_URI="mirror://gentoo/${P}.tar.xz"
-else # Official release
- SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
-fi
-
LICENSE="Apache-2.0"
SLOT="0"
+IUSE="cpu_flags_arm_neon examples static-libs"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
-[[ ${PV} == *9999 ]] || \
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="examples static-libs cpu_flags_arm_neon"
+multilib_src_configure() {
+ if use cpu_flags_arm_neon; then
+ local -x CFLAGS="${CFLAGS}"
+ append-cflags -mfpu=neon
+ fi
+
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable cpu_flags_arm_neon armv7neon) \
+ $(use_enable examples example) \
+ $(use_enable static-libs static)
+}
-AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+multilib_src_install_all() {
+ einstalldocs
-src_configure() {
- use cpu_flags_arm_neon && append-flags '-mfpu=neon'
- local myeconfargs=(
- "$(use_enable examples example)"
- "$(use_enable cpu_flags_arm_neon armv7neon)"
- )
- autotools-multilib_src_configure
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
}
diff --git a/media-libs/vo-aacenc/vo-aacenc-9999.ebuild b/media-libs/vo-aacenc/vo-aacenc-9999.ebuild
index 7d6b2869b056..022f13cf020f 100644
--- a/media-libs/vo-aacenc/vo-aacenc-9999.ebuild
+++ b/media-libs/vo-aacenc/vo-aacenc-9999.ebuild
@@ -1,42 +1,45 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-if [[ ${PV} == *9999 ]] ; then
- SCM="git-2"
+inherit flag-o-matic multilib-minimal
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
EGIT_REPO_URI="https://github.com/mstorsjo/${PN}.git"
- [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
- AUTOTOOLS_AUTORECONF=yes
+else
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
fi
-inherit autotools-multilib flag-o-matic ${SCM}
-
DESCRIPTION="VisualOn AAC encoder library"
HOMEPAGE="https://sourceforge.net/projects/opencore-amr/"
-if [[ ${PV} == *9999 ]] ; then
- SRC_URI=""
-elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
- SRC_URI="mirror://gentoo/${P}.tar.xz"
-else # Official release
- SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
-fi
-
LICENSE="Apache-2.0"
SLOT="0"
+IUSE="cpu_flags_arm_neon examples static-libs"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
-[[ ${PV} == *9999 ]] || \
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="examples static-libs cpu_flags_arm_neon"
+multilib_src_configure() {
+ if use cpu_flags_arm_neon; then
+ local -x CFLAGS="${CFLAGS}"
+ append-cflags -mfpu=neon
+ fi
+
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable cpu_flags_arm_neon armv7neon) \
+ $(use_enable examples example) \
+ $(use_enable static-libs static)
+}
-AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+multilib_src_install_all() {
+ einstalldocs
-src_configure() {
- use cpu_flags_arm_neon && append-flags '-mfpu=neon'
- local myeconfargs=(
- "$(use_enable examples example)"
- "$(use_enable cpu_flags_arm_neon armv7neon)"
- )
- autotools-multilib_src_configure
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
}